cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

dazzlegamer
Adept I

Enabling Freesync causes screen tearing and motion judder when playing videos

  • Enabling Freesync causes screen tearing and motion judder when playing videos ( ie: Pot player, KMP, WMP)
    this is really annoying the hell outta me since i watch anime and other tv shows a lot, turning the freesync from radeon settings solves the issue though..
    SPECS :
    RX 570,
    Windows 10 1809 x64
    LG 22MP68VQ  (HDMI)
46 Replies
markiemarcus
Adept III

Same problem - commenting again for visibility!


The last driver that doesn't have this issue is 18.12.1.1. So this problem has been introduced with the 2019 Edition drivers, with the new Relive features.

Players I have tested include MPC-HC, MPC-BE, WMP, Films & TV player in W10. The machine is dual booted with Windows 8.1 where the problem also occurs using the Windows 7 driver, so I can only assume this also affects Windows 7.

I run an RX 480 with the LG 29" Ultrawide 29UM67 over Displayport.

markiemarcus
Adept III

Still broken as of 19.2.1

0 Likes
markiemarcus
Adept III

Still broken as of 19.2.3

0 Likes
vermundr
Journeyman III

Still doesnt work and it's not even acknowledged in the driver notes. COME ON AMD!

0 Likes
markiemarcus
Adept III

Still broken as of 19.4.3.

0 Likes
chrisro
Adept I

Still broken as of 19.5.1

0 Likes
Matt_AMD
Community Manager

Please can you check if you have Enhanced Sync enabled under Radeon Settings > Gaming > Global Settings? Enhanced Sync can cause some corruption or flickering in 2D applications. You may be required to add the media player to Radeon Settings as an application profile and set Enhanced Sync to disable. 

FAQ: https://www.amd.com/en/technologies/radeon-software-enhancedsync

0 Likes

 

Enhanced sync is disabled globally. The last known working driver version is 18.12.1.1. Short of reverting to that, you either have to disable Freesync entirely or use a D3D exclusive fullscreen mode if the video player supports that. These are only workarounds though.  There's another thread about the issue here:

https://community.amd.com/thread/235697

0 Likes

I have been unable to reproduce this issue. Below is the system i tested and the steps i followed. 

2970wx

Radeon VII

19.6.2

Win 10 1903

Samsung CF791 3440x1440P @100HZ FreeSync enabled

Samsung U32E850R 3840x2160 @ 60HZ FreeSync enabled

I downloaded the K-Lite Standard codec pack which includes Media Player Classic. Ran it using default install options. 

Downloaded the The Simpsons Movie – 1080p Trailer from here https://www.h264info.com/clips.html

Watched the clip on both displays, firstly in windowed mode, then in full screen mode, saw no tearing or stuttering. 

I then recorded some game footage using ReLive, 2160P, 30Mbps AVC 60FPS and saw no tearing or stuttering. 

I would appreciate it if you could provide some suggestions on how to reproduce this behavior. 

0 Likes

Appreciate you looking at it. You shouldn't need the K-lite codec pack; MPC-HC supports almost everything you can throw at it by default. It's just in case the K-lite codec pack is changing things somehow. A really good tester is actually the panning 20th/21st century Fox logo and the rotating circa 2000 WB logo. But it's everywhere here, including the Simpsons Movie trailer and particularly noticeable at the pan out around 19-20s.

 

From a clean install of Windows 7, 8 and 10, these are the steps I followed:

 

I ran Windows Update
I installed the latest drivers

I installed MPC-BE or MPC-HC

 

That's it. The issue manifests itself after driver version 18.12.1.1. Prior to version 1903 of W10 it also used to happen in the Films & TV player, but this doesn't seem to be the case anymore. Windowed mode seems fine, as is exclusive fullscreen mode.

0 Likes

I uninstalled K-Lite and downloaded and installed the standalone version of MPC from here: https://mpc-hc.org/

No change in behavior from my earlier post. Also tested on pot player and Movies and TV Player and no issues seen. W10 1903. 

Hopefully some more information comes to light that can aid a successful reproduction.

Matt_AMD
Community Manager

Just to add i also tested this on an RX 580 and was not able to reproduce this behaviour. 

0 Likes

Thanks for that. What I find very strange is that the D3D full screen mode works fine and that disabling Freesync completely fixes the problem. Ordinarily I'd just switch applications, but MPC-BE specifically is really good at tonemapping HDR content to SDR. Hardly touches the CPU. 

I'm starting to think that it's monitor related but unfortunately I don't have another Freesync display to test. 

0 Likes

I did not see this possibility mentioned so sorry if you have tried this. I have had a couple monitors now that FreeSync does not work correctly on unless you load the proprietary monitor driver. Most people just plug an monitor in and Windows loads a Generic PNP driver. This driver does not always have what it needs to make all features work. Especially if they update things after launch.

I noticed your monitor does have a driver from LG available. It may not help or change anything but would be worth checking out and trying.  LG 29UM67-P.AUS: Support, Manuals, Warranty & More | LG USA Support 

Please note that Windows after updates has a habit of reverting those drivers back to the Generic so if this helps then the problem comes back make sure to load the correct driver again. Even if it doesn't help this problem, you often need these drivers for sleep to work as it should.

Anyway GOOD LUCK!

Not at all, appreciate you posting. Unfortunately I have already tried this. Though it must be said that way back when the AMD windmill demo was still a reliable way of checking whether Freesync is working, in the early days of Windows 10, the driver was actually necessary. Makes zero difference now though. Freesync works fine in games.

This is a regression after driver version 18.12.1.1, when the 2019 Edition drivers were released with the new Relive features.

Is there any way this could be investigated further? More reports of this behaviour keep coming in. It seems at the moment to be monitor related, with a number of additional LG ultrawide displays being mentioned. There's still no mention of it in the known issues, which after 7-8 months is a little concerning.

I might be able to offer some additional insight... It might be related to LFC. Why you ask?

The standard Freesync range of my 29" Ultra wide LG monitor is 40 - 75 Hz. This is not enough for LFC to work. With these settings and Freesync on, I get a lot of tearing while watching videos. I have used a tool to increase the range to 30 - 75 Hz in the past, and I forgot to do it this time after my latest driver update. It was quite to coincidence that I now have tearing. So guess what. After I increased the range again, I now no longer have tearing while watching videos! And that extended range I set is the exact range where LFC is supposed to work perfectly at. 

Now, understand that extending your range like I did can damage your monitor or decrease its life significantly. I don't know if I'm one of the lucky ones, or if the majority of LG monitors can work with this extended range without any issues. You can try it at your own risk.

Most likely, the framerate of the video is not being doubled with Freesync enabled while LFC is not working, and therefore falls well outside of the Freesync range, causing tearing. Either that, or it is tripled or quadrupled rather than doubled, or something else is going on that only AMD can figure out. 

I haven't tried the following since I found my solution, but you can try your luck; 

- Try enabled Vsync by default and see if that helps the tearing.

- Turn on AMD Fluid Motion Video (Video Tab on the bottom between the Gaming and ReLive tab, then select custom to enable it). This should insert additional frames, technically increasing the framerate to fall within your Freesync range. 

Good luck.

Thanks for posting this. There is definitely something to it; 60fps video seems to play back normally which would indeed support the notion that LFC is simply broken. I'll look into extending the range to see if that works as temporary solution.

No joy with either forcing vsync or AMD Fluid Motion Video; I tested those a while back.

Your solution to this works. I've just tested CRU and expanded the Freesync range and like magic, the problem is gone. I wish I'd done this 18 months ago! There's some confusion in the other thread due to a Dunning-Kruger nutcase hijacking it (Enabling Freesync causes screen tearing and motion judder when playing videos)  but apparently Freesync shouldn't be running at all during video playback; what's strange is that forcing an override to force disable it doesn't work.

But anyway, thanks for your post. You're the only one to have actually narrowed the problem down.

0 Likes

Yeah this is so weird. I read through the new posts on the thread, and

boy, people can sure get off topic and fixated. Ironically, I'm the kind

of guy that will just turn settings on and off as suggested in posts,

and when it works, I just leave it alone

0 Likes
raulfiorito
Adept I

same here, win version 1903, RX480, same monitor, 19.6.3 drivers, I solved it using bluesky Frame Rate Converter. Freesync is working properly because I have no problems in game. Enhanced Sync is disabled for global settings, and is a fresh windows installation. 

Ah that's interesting, that's another workaround using an exclusive fullscreen mode. Thanks for posting.

0 Likes

Also I noticed that only MPC and Potplayer has problem with that, is not a problem in Windows Media player that comes with windows 10, and not a problem in videos over chrome. Bluesky frame rate converter totally fix it with fluid motion video enabled in AMD drivers. I am still testing and I downloaded a video to test tearing (just bars moving around at different speed). So far the problem only appears in Potplayer and MPC HC. going to check more video players.

0 Likes

And another thing, that only happens in full screen.

0 Likes

The built-in Films & TV player in Windows 10 used to have the problem prior to the release of W10 1903, but it works fine now.

If you switch to the exclusive fullscreen mode in MPC-HC (it's under presentation settings, D3D fullscreen mode) or MPC-BE (Renderer settings / Presentation / Exclusive fullscreen) you can workaround the problem without the need for Bluesky. It works here at least, but it makes for extremely sluggish transitions.

Windowed mode is fine here too.

0 Likes

yeah. same with potplayer if you use fullscreen, and it doesn't use the color profile either. I am trying VLC and has no problem, this is definitely a problem with potplayer and MPC HC in fullscreen only (not true fullscreen), and you can notice that the initial 2 seconds (or one) there is no tearing, something kick in after 1 or 2 second causing tearing. You can try better if you download a youtube video to test screen tearing (there is one with black and white bars. 

I am trying to check windows trash like the new freature with variable refresh rate, tried 60hz (instead of 75hz), also disabling full screen optimization. Nothing works yet. But well, I mostly use blue sky because I love to watch things in 60fps with fluid motion, and there is no problem with netflix or youtube, or any webplayer. Is pretty strange issue... and it happens in both of my windows installations, with different drivers and windows versions. 

0 Likes
zeer88
Adept I

I have this exact problem. Sapphire RX 480 on a LG Ultrawide 29'' with Freesync (75hz). Movies have a noticeable tearing line on the top third of the screen. Happens on MPC-HC, VLC and PotPlayer. You'd think watching a 1080p movie would be flawless in 2019... guess not.

nightantilli
Journeyman III

Same problem here as well after updating to the latest drivers, although I did not have it before. I'm using an R9 Fury Nitro, and also an LB ultrawide 29".

le-faux
Adept I

I have the same problem with VLC and Media Player Classic.

Running on Windows 10 1903

Vega 64 Drvier Revision 19.7.5

LG 27UD58-B

0 Likes
markiemarcus
Adept III

Still broken on 19.8.1.

0 Likes
zeer88
Adept I

Can someone from AMD please acknowledge this problem? This is a serious issue, I will not get an AMD card again when I upgrade my RX 480 if something as basic as watching a movie doesn't work properly...

I know you are not the first to complain of this, so likely it is an issue in recent drivers. I do however know that one thing that can help is to make sure you set your min and max on your freesync range  1 inside of the physical range. So if your monitor does say 45-75 you would set your range to 46-74. Not sure about video but doing that would smooth things out in games for me in the past. There likely hasn't been any real performance update either with recent drivers for the Polaris series as they really are trying to optimize for Navi. You don't need to update drivers unless you need to because something doesn't work. So if older drivers worked for you I would stick with one that worked. Just run DDU before your regress if you go that route.

0 Likes

This doesn't affect video games, only videos. There's the possibility of it being linked to LFC however; hence why it manifests with 23.976fps video content but not 60fps video content. The last working version is 18.12.1.1, but this is missing features and comes with its own bugs. For starters, VSR isn't available on Ultrawide displays. There's also an immensely annoying bug where if a second display is connected but not enabled intermittent freezing and stuttering occurs, even when moving the mouse cursor.

I'd like to, but I can't really defend bugs with something so rudimentary. There's a report of it happening with a 5700 XT also, so it isn't restricted to Polaris. Driver support has been rather poor IMO. If it isn't a bug with a game, it's a bug in Wattman, a bug in Freesync or problems with a second display. 


0 Likes

I know I have seen the complaints on the Navi of them not working at 75mhz but okay at 60 but not working with playback in browsers either. So yes many issues going around and it has been like this for about 2 years now since the Wattman drivers came out. Seems like 1 step forward 2 steps back. They never seem to have all their features working correctly at once. Dual monitors have been an issue in the same time frame too as you know. It's a shame because before Wattman AMD always had the better multi-monitor support. I don't know what is going on with them but I sure hope it doesn't take too much longer for them to right their ship. Many have lost patience. Make sure to file a Support Ticket with your issue, driver development doesn't see your posts here: Online Service Request | AMD 

0 Likes
robobrain
Journeyman III

I am facing the same issue. GPU: RX 580, Monitor: LG 29WK600. The tear happens exclusively on VLC and some other players. On VLC it tears at the exact same spot every time, it tears at 1 inch from the top. This doesn't happen in windows media player, chrome, SMplayer. Like mentioned previously by others, turning off Free Sync fixes this. 

Contrary to what others said, using the exclusive full screen mode on VLC does not prevent the tearing for my case.

0 Likes

Looks like I just got mine to work! Also running RX 580 but with DELL SE2717H monitor. I had exactly the same problem as you robobrain. Windows Media Player was working fine, but VLC was tearing about an inch from the top.

Anyway, I followed amdmatt's advice. But I noticed a lot of you say you disabled enhanced sync in global settings. I didn't do that. I followed Matt's advice and kept the global setting on, and instead I added vlc.exe manually to the gaming tab, and set it's "Wait for Vertical Refresh" to "Always off".

At first that didn't work, but then I remembered to restart my computer and then it worked!!! I hope it's not just a fluke, and stays fixed...

0 Likes

Neither way works here, unfortunately.

0 Likes

I have tried that with no success. I just stopped using VLC until this bug gets sorted, and transitioned to SMPlayer. SM works without a hitch, and that software has almost as many features as VLC. I just ended up compromising. 

0 Likes

Awww man. Sorry to hear. Like I said, I just hope it stays fixed with me...

0 Likes