cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

markiemarcus
Adept III

Enabling Freesync causes screen tearing and motion judder when playing videos

This is a recent problem in the last handful of driver versions. The problem goes away when you disable Freesync in Radeon Settings.

Driver version 19.1.1
RX 480
LG 29" Ultrawide 29UM67

Windows 10 1809 x64
Displayport


Players I have tested include MPC-HC, MPC-BE, WMP, Films & TV player in W10. The machine is dual booted with Windows 8.1 where the problem also occurs using the Windows 7 driver.

121 Replies

+ The Radeon driver for video players DOES NOT already run FreeSync.
+ In order for FreeSync feature to cause the problem you are having, you have to FORCE IT ON.
+ There is absolutely no driver behavior difference between Radeon panel glabal settings and custom profile settings of an application.
+ Video players do not offer VSYNC settings because it already works with VSYNC. Of course if you don't change it.
+ FreeSync does not work with video players anyway. Since FreeSync does not work, there will be absolutely no motion judder problem.
+ The probability of experiencing screen tearing and motion judder problems at the same time is almost zero.

You have shared lots of information that contradicts the above informations. I can increase the number of sentences above. But there is no need. I don't know how much computer knowledge you have. You have wrote errors full of contradictions. 

0 Likes

You're not listening and you're reading what you want to read. 

"+ In order for FreeSync feature to cause the problem you are having, you have to FORCE IT ON."

None of us have forced it on for video playback. This is the default behaviour. Do you understand that? This is the default behaviour. Do you understand?

"+ The probability of experiencing screen tearing and motion judder problems at the same time is almost zero."

Firstly, you pulled that probability out of your backside. Secondly, they don't occur at the same time. It alternates between tearing and motion judder. It's clear as day to anybody experiencing the issue. Some frames are fine but pacing and persistence is way off, others are badly torn. 

Are we all making it up?

"You have wrote errors full of contradictions."

No, you write answers before reading the question. You are, and always were, looking for an argument and to feel big. I don't know why and I don't care, but it's extremely tiresome. Now if there's nothing else, scram, because people in both of these threads actually need AMD to pull their finger out and fix this and you clearly have nothing to contribute.



0 Likes

I'm bored with your lies. It is impossible to experience tearing and flickering problems you experience while watching a video with default settings for the driver and for the player. FreeSync must be enabled for flickering problem. VSYNC must be disabled for tearing problem. Even if FreeSync is enabled and VSYNC is disabled, these two effects do not appear at the same time. In order to get this effect, you need to change FreeSync range with CRU. I really annoy with your lies. If this sh.t is something that works differently on different computers, I'll justify you. But there is none. 

0 Likes

I don't want to be right. My purpose is to help and I have added for this as a new message (at the bottom). But in order for someone or AMD to help you, you need to tell them what changes you have made without lying. 

0 Likes

Ok I just realised that it didn't fix the tearing for me either. It is now tearing at the bottom of the screen instead of the top ffs. I have submitted a couple reports a while ago, seems pretty useless to me.

I can understand the problem you're having. Does your problem improve with FreeSync setting? Do you use Enhanced Sync? What is your monitor?

0 Likes

The issue goes away when I disable global freesync. Enhanced sync is off. I am using an LG 24MP59G-P. 

Please provide the information i requested above.

Another sample for you:

https://easyupload.io/uadm2p

Clear as day on this one. As stated many, many times before, creating a profile override for MPC in Radeon Settings to manually disable Freesync, and/or Enhanced Sync, makes no difference. The posts that you keep marking as helpful, are not helpful, Matt. We've already tried them.

Yo markie!
Thank you for sticking to this bs by the way. I have long lost my patience and given up on AMD fixing this one.

I also want to point out, that it is actually harmful, that these non solutions are marked as helpful as soon as one single person suggests that they might work, even though a bunch of others claim they don't work.
This is one of the reasons why no progress has been achiedved over such a long time.

Have these findings been reported to the driver team or not? If not, why not and when, because 18 months of this nonsense is a colossal waste of everybody's time, including yours. It's going nowhere.

0 Likes
mstfbsrn980
Grandmaster

Prove that you are not lying and share this evidence with AMD with that...
https://www.amd.com/en/support/contact-email-form 
Show us the problem you experienced with your monitor with a good camera step by step from outside.
+ Firstly, download VLC and run it.
+ Then show us Radeon panel FreeSync global options.

+ Then show us Radeon panel global graphics settings.
+ Then show us VLC custom profile.
+ Then run VLC and show us its input codecs simple preferences.

+ Then show us flickering and tearing problem. At the same time, these problems do not need to occur.
+ Also show the CRU FreeSync range without changing it.
This issue is easier to understand by AMD officials if you record them with a good camera.

Some models of LG were released only with the support of nVidia. But you have a monitor released with AMD FreeSync logo. AMD may not provide proper FreeSync support for some monitor models. However, you need to share what we need to agree with this.

0 Likes

You still don't get it. I am writing for you not for me. Do as I say or do not. If you do, AMD will fix the problem if they see it. No engineer takes what you has written seriously without proving your problem with a video. Inconsistent.

0 Likes

Does this guy really think all those threads are just a conspiracy by some AMD haters?

If he had read the applicable threads, he'd know that all the measures he suggests have been taken.

I even did a clean windows install and still mpc video playback is torn as all hell when freesync is globally enabled.

It is puzzling to me why anyone would suggest, that we are all just lying about our problems with the AMD drivers.

How the hell can people be this toxic?

I'm actually even on a mostly different machine now too. The only common elements are the GPU and monitor; somebody else posting here said the same thing. Multiple clean installs of Windows 10, the latest builds, even tested on Windows 7 and 8 with the same results.

Yet miraculously, the old driver fixes it in all cases...funny that

0 Likes
Matt_AMD
Community Manager

Please keep to discussing the topic rather than taking unnecessary jabs at each other. Such posts will just be removed from the forum. If this continues, further action may be taken to get things back on topic. 

I'd recommend that all users in this discussion read the forum rules and regulations before making any further posts. https://community.amd.com/thread/196210 

For users experiencing the issue, please provide some detailed steps on how to quickly reproduce this issue. Please also include a video sample that clearly shows the issue that i can test on my system. 

FreeSync should be disabled when video playback is activated, but this should happen automatically. As mentioned above, Enhanced sync can also cause this behaviour and should be disabled. 

From my testing based on the feedback in this discussion, i am not seeing any screen tearing or flickering on the setup below.

RX 580

FreeSync on globally, enhanced sync off. 

20.5.1

Win 10 2004

Windows 10 Media Player

MPC (latest version)

VLC (latest version)

0 Likes

There are no steps, just play any video with MPC or VLC. All stock settings. I suspect that the reason you're not seeing the problem is because it's monitor specific, and anything beyond the driver version mentioned breaks Freesync compatibility with certain monitors.

The interesting thing is that it doesn't happen with 60fps video @75Hz, but it does with 24fps video. Somebody had mentioned that LFC may not working, which makes sense, but that would indeed suggest that Freesync is not being disabled automatically on these monitors. 

Creating an application override doesn't work. Disabling enhanced sync doesn't either. The only thing that works is fully disabling Freesync on a global level or on the monitor itself.

I have had this persist across multiple cleans installs of Windows 10, 7, 8 and an almost entirely new machine, using only the same GPU and monitor.


0 Likes

I am not 100% sure about this, but I think that most people that are havong this issue are using LG monitors.


A lot of them have been, yes.

0 Likes

Can you provide a short video sample at 24 fps which shows the issue? We can try testing on that. 

It sounds like FreeSync is not being automatically disabled via the driver in certain scenarios. 

Matt_AMD
Community Manager

Can you also provide a list of affected LG monitors.

0 Likes

LG 29" Ultrawide 29UM67
LG 24MP59G-P
iiyama XUB2792QSU
LG 34" Ultrawide 34UM59
LG 27UD68-W
Samsung C27F390FHI
LG 34UM68-P
AOC2590
LG 27UD59-B
LG 27UD58-B
LG 34UM68-P
Philips 246E9QDSB/01
LG 22MP68VQ
LG 29WK600
LG 27MP68VQ

And a 23.98 fps movie trailer:
https://easyupload.io/onhvg2 

The first few seconds will be fine, but then after a few seconds the problem starts. In MPC-BE, if you keep the video windowed, everything is fine. It's when you maximise or fullscreen it that the problem occurs. Even the frame persistence is wrong. Note that MPC-BE isn't even exclusive fullscreen by default; exclusive fullscreen actually side steps the problem, but it's a pain and disables a lot of the functionality. Last time I checked, I had exactly the same problem in VLC.

Thanks, I'll pass this feedback onto engineering. 

Much appreciated.

0 Likes

Glad to see this is finally getting some attention.

Just bought a new monitor excited for FreeSync and experience this issue - HUGELY frustrating!

Graphics: RX 560

Monitor: Samsung U28E590

Connection: Display Port

Driver: 20.12.1

Windows: Windows 10 Pro 19042.685

Media Player: MPC

Only solution for me is to globally turn off "Adaptive Sync Compatible" in AMD Radeon software. I'm speechless how something like this is not being fixed after MONTHS of reports!

0 Likes

RE:  I'm speechless how something like this is not being fixed after MONTHS of reports!

Well that depends. 
Reporting bugs to this forum will get nothing fixed. 

People have to either use the AMD Bug Report Tool in the Adrenalin 2020 driver or download it from here: 
https://www.amd.com/en/support/kb/faq/amdbrt

You have to be prepared to let AMD Trawl your PC for data and send it to them. 
There is no opt out. 
I am not prepared to let them do that so I no longer report any  bugs. 

You can always open an email support case here: 
https://www.amd.com/en/support/contact-email-form
That is too much effort if you ask me.

There used to be an online WEB form based Bug reporting form. 
That option is gone. 

Bye.

0 Likes

 I was having some e-mail correspondence with AMD customer support, just a short summary:

- "You should use a high quality display port cable, this might help solve the problem" <- WTF??? Seriously?

- "People complaining about driver issues are the minority, for the majority of people everything is working fine." <- Yeah, right, thx for the infomation!

"Tearing can occur if the freesny range of the monitor is outside of the FPS/Hz of the video being played." <- OK, this is something I can work with, setting my freesync range to 20-60 Hz with CRU tool still didn't help, problem persists.

- "Please use bug report tool, our people will look into it." <- Did it, no confidence that anyone will really look into it.

Overall it was pretty disappointing and I would be surprised if they took this bug seriously and did something about it. I'd be very happy if they prooved me wrong.

As kind of a workaround I switched to madVR in Media Player classic and activated "use Direct3D 11 for presentation" and "present a frame for every VSync" in rendering general settings. Tearing seems to be gone! Hope this is of help to some of you guys.

Have a nice day,

Nelson

Uhh, so this is still an issue in 2022. I am still having to turn off Freesync before using MPC-BE. Any updates from AMD or what?

0 Likes

I had an issue similar to this after getting one of the 22.3.x drivers, don't remember which one though.
It happened on videos AND games. freesync/enhanced sync enabled. 
I downgraded to 22.2.1 and it went away. I'm on 22.4.2 right now (after one completely borked install) and it hasnt come back.
Very strange...

0 Likes

I noticed something similar. These newer versions actually stutter and lag even more than those released earlier in the year e.g. 22.2.x. Just having freesync on while watching MPC BE makes the cursor stutter badly and basic navigation of Windows is atrocious with all the lag.

I'm going to try 22.4.2 and see if that's any better. Also, has anyone contacted the MPC devs? It might be a bug on their end that AMD can't fix.

Edit: Still happening on 22.4.2

0 Likes

Basically any video played with VLC, KMPlayer and Media Player Classic produces the tearing issue at least from my experience. The only way to remove the tearing is to manually disable freesync inside the global settings. Setting a profile for the player and disabling freesync there does nothing. My monitor is an LG 27MP68VQ paired with an RX-570. And yes, if I use SVP for example, forcing the video to run at 75fps in sync with the monitor's refresh rate which is 75hz, the tearing is gone.

mack0y
Elite

I added MPC-BE to the Radeon Software and disabled Freesync.  It works.  Refresh rate stays at 144Hz compared to 72Hz (LFC 24FPS x 3).  It might be an LG thing.  Can you monitor the refresh rate?

RX 5700XT

It doesn't work here unfortunately. It should work and I get why everyone keeps suggesting it, but it doesn't work for us. It's as if Radeon Settings is ignoring the override. Frame persistence is lousy too. Any time you even move the mouse the video judders. If you seek it takes a second or two to actually deliver frames consistently.

But here's a thing: The Radeon Software (Press Alt + R) to Open prompt appears in the top right after a few seconds, after you go fullscreen, right when the problems start. I'm assuming that this isn't normal behaviour for video playback. Well, it's the default here.

Unfortunately this display has no way of monitoring the active refresh rate. 

I appreciate you trying to help so this is not directed at you at all, but there are only so many times I and other people in this thread can repeat ourselves:

The only "fixes" we have found that actually work for our monitors are either globally disabling Freesync or reverting to driver version 18.12.1.1. An 18 month old driver. So this was working; it's a regression. This should have been sorted an eternity ago. I've collated a list of the all the monitors affected so far, tested multiple operating systems, several clean installs, sent off multiple bug reports, dozens of driver updates even going as far as establishing the last known working driver version to help the support team, and we've been largely ignored since January 2019.

That stinks. That really stinks. I'm out.

 

markiemarcus
Adept III

OK, I have the mystery of this partially solved (thanks to a post from nightantilli in the other thread), at least I think so, but I stress that it's a not a solution and AMD are going to have to fix this.

It does appear that Freesync isn't being correctly disengaged during video playback in MPC-BE and a whole host of other players; creating a profile override to force disable it doesn't work, so stop suggesting it. My monitor has a Freesync range of 40-75HZ, but unfortunately, this isn't enough for LFC to work. LFC on my monitor, seems to require a differential of at least 2x between the minimum and maximum, which this monitor (and I suspect any monitor affected by the problem) doesn't have. Either that or they handle LFC differently with different conditions for engaging it.

If you use CRU to expand the Freesync range to either 35-75 or 30-75, both creating a larger than 2x differential, this tearing and stuttering problem vanishes without any other user intervention. To test this at your own risk, you need to launch CRU, click "edit" next to the active monitor, enter a sensible minimum V rate value that creates a differential of least 2x between it and V rate max. So for instance, 35 works, but 38 doesn't.

Anybody not experiencing these problems with MPC, out-of-the-box, I suspect already has functioning LFC. So this problem could actually be much larger, it just isn't manifesting for most people because LFC is correcting for it.

As far I can tell, the driver changes introduced 18 months ago crippled video playback compatibility with monitors that don't by default support LFC. Again, the per-app ability to force disable Freesync does not work here; it has never worked so please stop suggesting it.

But here's the problem. amdmatt‌, you said that you tested on a Samsung U32E850R and didn't see any problem (did you try the second clip in MPC?). That monitor does not have a 2x differential in range and is only 60Hz, so there must be another mechanism by which this is being corrected for or by which LFC is being engaged. Or do some of these older monitors like mine just implement LFC very differently? I'm also wondering if the frame duplication pattern is a factor; 24p to 60Hz conversion is very specific and it's possible that the player, MPC, is handling that in a way that plays nice with your display.

We need a solution to this. I think we've all been very patient. I'm going to stress this one more time for the people in the back:

Creating a profile override for MPC in Radeon settings, to force disable Freesync, doesn't resolve the issue and Enhanced Sync is disabled. A profile override should work, but it doesn't and I don't know why. Something else is going on or not being fully disengaged, be that LFC or something undiscovered. 

mstfbsrn980
Grandmaster

... ... ... ... Check if the "AMD External Events Utility" service is running? If this service is not working, custom profiles may not be applied.

0 Likes

Edit: Check C:\Users\##USER##\AppData\Local\ATI\ACE\APL\User.blb file if exist...

0 Likes

Knock it off. I've only just tested CRU based on a recommendation; the stock experience is the problem.

And yes, the External Events Utility is running, as is the other file.

0 Likes

Profiles are not applied if user.blb file is not available.

0 Likes

The file is there, dude. You're not helping. You're being actively counterproductive. 

0 Likes