Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

DXGI_error_device_removed @ Spellfore 3 @ AMD RX5700 @ OLD BUG coming back

I get these two in Spellforce 3 (Steam version). And only there. I had the same problem in one of the newer Tomb Raider games some time ago. It was solved by a driver update, which took about 1 year to implement.

Card is a Sapphire Pulse RX5700 8G.

Driver is 20.2.1.

Spellforce is the only game i have which gives these errors so far. I am gonna try the Tomb Raider games again in these days.

(DXGI_error_device_removed) [Create texture failed, size 1472x736 depth:1 format:a8 srgb:no]

(DXGI_error_device_removed) [failed to create pixel shader]

There is a ticket about this bug at the developer bug report community of Spellforce 3 too. 

Bug #39325: Direct X hung when i started to move in the first mission - SpellForce 3 (Community) - T... 

So when will the bug be fixed again.

"And when will it come back again?"

6 Replies
Journeyman III

VERY much WAITING, please fix with the new driver#rx 5700 xt#driver bugs#games crahses


Even AMD Adrenalin 2019 Edition 19.12.1 has the same problem. So its no more only a driver problem, as the old driver has the same problem too. It's more of a HW problem now or something how the gfx card works the shaders.

Adept I

Radeon Vega 56


Hello, I have the same problem.

Reproducible with the game Arma3.
If I go to the desktop with Alt + Tab and then back again, there is the error.

Now have the following solution.

If I install the latest AMD driver, the error is there.
After I uninstall it again and simply search for the driver via the device manager, everything works.

It's a shame because I can't use the AMD driver and the setting options.

Finally, I have tried all the existing solutions. Nothing helped.
I even reinstalled Windows, but nothing.
The AMD driver shoots everything.

Adept II

Problem still exists in 20.2.2 and 20.3.1.

Journeyman III

Persists in 20.4.2. Doesn't seem to matter whether all graphics settings are set to minimum or maximum, nor is there a difference between full screen and borderless window. A bunch of DirectX errors pop up about vertices and lost devices.

Adept II

I read about problems of the game mode of Windows 10 with newer AMD and NVIDIA drivers, so i'm gonna test in one of these days if disabling it helps.

UPDATE: It doesn't help. Now i installed the debugging tools from the Windows 10 SDK, but i am too tired to check all the crash dumps for common errors. Trying that at a later time.