cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

ATrashInTheWorld
Journeyman III

Drivers Ubuntu 20.04, dpkg: error processing package libgl1-amdgpu-mesa-dri:amd64 (--configure):

Jump to solution

Hi community,

Like the title says, I have some issues installing my driver on my Ubuntu 20.04.

For some reason, every time I try to install the drivers, I always have the 2 same errors, that seems to be like a chicken-egg one. (The second image with the red dpkg)

I tried many things to uninstall and re-install them, but nothing works, every time I get those 2 errors. I tried installing other things for gaming on Ubuntu, but they all depend on those 2 packages and every time I try to install I get those 2 errors.

I seriously don't really know what to do anymore. I'm kinda noob with GPUs and ubuntu.

Below I've also put a picture of my specs, if it can help.

The kernel is: Linux 5.13.0-27-generic x86_64

Thank you for your time and sorry for the disturbance.

Screenshot from 2022-01-30 17-46-18.pngScreenshot from 2022-01-30 17-46-39.png

0 Likes
2 Solutions

Accepted Solutions
timcharper
Adept I

Re: Drivers Ubuntu 20.04, dpkg: error processing package libgl1-amdgpu-mesa-dri:amd64 (--configure):

Jump to solution

I could not get the drivers to build for kernel version 5.13.x. The drivers will build for 5.11.0-44.

Recommend kernel downgrade until we get an update from AMD.

 

View solution in original post

0 Likes
Wedge009
Adept II

Re: Drivers Ubuntu 20.04, dpkg: error processing package libgl1-amdgpu-mesa-dri:amd64 (--configure):

Jump to solution

I confirmed something similar in https://community.amd.com/t5/drivers-software/linux-mint-20-3-kernel-5-13-amdgpu-install-failes/m-p/.... But my failed installation was on amdgpu-dkms, not libgl1. Either way, seems okay with kernel 5.11.0-46.

View solution in original post

0 Likes
4 Replies
timcharper
Adept I

Re: Drivers Ubuntu 20.04, dpkg: error processing package libgl1-amdgpu-mesa-dri:amd64 (--configure):

Jump to solution

I could not get the drivers to build for kernel version 5.13.x. The drivers will build for 5.11.0-44.

Recommend kernel downgrade until we get an update from AMD.

 

0 Likes
ATrashInTheWorld
Journeyman III

Re: Drivers Ubuntu 20.04, dpkg: error processing package libgl1-amdgpu-mesa-dri:amd64 (--configure):

Jump to solution

Ok, I will give it a try, thank you very much

0 Likes
Wedge009
Adept II

Re: Drivers Ubuntu 20.04, dpkg: error processing package libgl1-amdgpu-mesa-dri:amd64 (--configure):

Jump to solution

I confirmed something similar in https://community.amd.com/t5/drivers-software/linux-mint-20-3-kernel-5-13-amdgpu-install-failes/m-p/.... But my failed installation was on amdgpu-dkms, not libgl1. Either way, seems okay with kernel 5.11.0-46.

0 Likes
Wedge009
Adept II

Re: Drivers Ubuntu 20.04, dpkg: error processing package libgl1-amdgpu-mesa-dri:amd64 (--configure):

Jump to solution

I know it's been released for nearly a week now, but I've only had time to try it today: with amdgpu-pro 21.50 it appears the main difference (from the release notes) is to add support for Ubuntu 20.04.4 as we were discussing here. I have both 'legacy' and ROCr-based OpenCL running on the current (as of writing) Ubuntu HWE kernel 5.13.0-30 with this release of amdgpu-pro.

It looks like not everyone is having success with the new release, however.

0 Likes