Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Drivers Refuse to Function

The issues:

Dead GPU ports, artifacting, refusal to properly install drivers, GPU generally not working



GPU: AMD Radeon RX 5700 XT

MOBO: MSI B450 Gaming Plus Max

CPU: AMD Ryzen 5 3600 6-Core, 12 Thread Unlocked

PSU: Corsair CX 750M

My Tale of Woe:

This is a new build that I started about a week and a half ago. It was running fine, until my GPU started having difficulties due to an insufficient PSU (I was using a Corsair 450W). I swapped that out for a Thermaltake 700W, and things were fine again for a couple days. However, while running an Oculus Quest 2 game via PC link, my GPU crashed (fans were still running, but no image). I shut it down and let it sit for a few minutes (in case it was an overheating problem), but was only able to get fans with no video.

I refitted my GPU and RAM several times, swapped in a new PSU (the Corsair 750M), tried using the secondary PCIE slot, isolated my RAM sticks, reset my MOBO, used a variety of HDMI cables, but finally got it working with a brand new DisplayPort to HDMI cable.

Out of three DisplayPorts and one HDMI port on my GPU, only one is working. That one is giving me stable artifacts across my screen. Taking a screenshot and pasting it does not display the artifacting, leading me to think it's a problem with the port rather than the GPU itself.

To troubleshoot, I tried to update my drivers. Radeon gave me the "No AMD graphics driver is installed, or the AMD driver is not functioning properly" pop-up. So I uninstalled the drivers manually, and reinstalled them. Same problem. I disconnected from the internet, disabled Windows updates, started in safe mode, uninstalled them with DDU, restarted, then reinstalled with Radeon. Same problem. I updated my BIOS with a flash drive, did a clean install of windows, and tried to install the drivers. It failed, so I went ahead and did the laundry list of Windows updates. I installed the drivers with Radeon, restarted my computer, and tried firing it up. Same problem. I uninstalled with DDU one last time, reinstalled, and... well you've probably guessed it didn't work.

Trying to open up any game quickly confirms that the GPU is indeed not carrying its weight. I haven't dropped or mishandled any components, I've quadruple checked that everything is slotted correctly, there's no sign of a short, I never enabled overclocking, the fans are working on the GPU, I didn't put my greasy hands on the connectors, the PSU is properly connected, and the priest confirmed there are no angry Intel spirits haunting my house (although at this point I'm considering getting a second opinion). 

The only thing I even can guess to try is to run DDU again and try to manually install each driver and chipset... but I'm not holding out hope since my impression is that Radeon is supposed to do that for me. Is there anything I should try, or do I need to contact AMD so I can send it in?