Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Driver Timeout with Hardware Acceleration with Samsung monitor


I have thought of making a thread about this issue on here, as I am frankly quite unsure on where it best belongs - it seems like a multi-culprit kind of case, is why.

So, to best explain: I have bought a new monitor on September 3rd (Samsung Odyssey Neo G7), and roughly a pair of days after I started using it, the driver timeouts began. At first I thought it was GPU OC-related, but troubleshooting, research, and the causes for the issues began putting a target on the HW Acceleration on my browser (and presumedly, anything like Discord, that also had it).


My system (at its core) is this:

Monitors - Samsung Odyssey Neo G7 (32'), LG GN850-B (27'), running at 240Hz and 144Hz respectively

CPU - AMD Ryzen 7 5800X3D (owned since August 2022)

GPU - Powercolor Red Devil RX 6900 XT (owned since January 2021)

RAM - 32 GB (8x4) of Corsair Vengeance RAM (CMK16GX4M2B3200C16)


Mobo - ASUS B550-F Gaming (with the latest bios, 2803)

PSU - Corsair HX1000

OS - Windows 10 Pro 64-bit (21H2)


My research led me in a bit of a rabbit hole where I first discovered this thread, which put the spotlight on HW acceleration:


Still, tried to pinpoint a cause by doing each of these steps, every time the driver timeout issue occurred for me:

- Updating the monitors' firmwares to their latest

- Disabling the monitor's USB hub (which I had been using around the time the first timeout occurred)

- Disabled Freesync on one monitor first, then the other, thinking it was due to the Hz difference

- DDU'd my 22.7.1 driver install (in Safe mode), switched to 22.8.2

- Lowered Hz for both monitors to 120

- Disabled 10-bit color depth and set it to 8 for both monitors

- DDU'd again (in Safe mode), and reverted to the latest stable, 22.5.1, then updated chipset drivers to latest

- Reseated the GPU and ensured there were no cable issues

- Reset BIOS settings, but kept DOCP on for the RAM

- Disabled Power Down mode on RAM, and enabled Gear Down mode (as per thread)

- Set the RAM to 2133Mhz

All of the above took more than a week to troubleshoot through, and in the end the only way to stop the issue from occurring (it's been almost 48 hours now, VS it happening every 4 hours on average before) was disabling HW Acceleration.

The issue always occurred when interacting via Chrome with any web content that leveraged said acceleration (Tweetdeck, Youtube's recommended, Destiny Item Manager - or DIM being notable examples of this).

Now, I do not quite know on who is more at fault, here. The obvious first one is AMD drivers, as this might very well be a low-priority kink in them (not unlike the whole HEVC issue they have). Second one is Microsoft, as it'd not be the first time something about an update of theirs messed it for others. Third one is Samsung, given that this issue began ever since I started using their display.

I am hoping this post helps shine the light on this, so that it can be looked into - I am for sure not the only one who has been experiencing this.

Thank you kindly for reading, as well!

9 Replies

Use driver 22.5.1. It is listed as the recommended WHQL driver. You should always stay on that. Anything that says it's optional, or not WHQL, is unstable for many people. I have a G7 and had all sorts of issues like gray screens and way more game crashes and driver timeouts and 22.5.1 solved everything. Also update the firmware on the monitor if you haven't (I didn't read your entire post).

Edit: Just noticed you tried 22.5.1. Maybe use the AMD cleanup utility, reinstall chipset and gpu drivers, then test again. Really, 22.5.1 made all the difference for me.

[ 5800X3D | Aorus 5700XT | MSI B550 | H115i Pro | G.SKILL 32GB 3600Mhz | 850W Gold | Samsung Odyssey G7 240Hz | HP Reverb G2 (v2) ]

Both of these are listed in the troubleshooting taken. 22.5.1 did not fix it, monitor firmware update was the first thing done.


Since these issues persisted after DDU, this highlights a wholly different issue than just the driver version.



[ 5800X3D | Aorus 5700XT | MSI B550 | H115i Pro | G.SKILL 32GB 3600Mhz | 850W Gold | Samsung Odyssey G7 240Hz | HP Reverb G2 (v2) ]

DDU (or Display Driver Uninstaller) is a much more optimal tool for cleaning up driver installs. This was done twice, with the 22.7.1 to 22.8.2 switch, and then with the 22.8.2 to 22.5.1 switch.


Yeah I know of DDU and have used it in the past. Just last week I used the AMD utility and it helped. I don't want to debate which is better. Just saying it's something to try.

There are many posts everywhere about instability and driver issues around high refresh displays and hardware acceleration and what not. All your troubleshooting items listed above I have enabled/on/turned up/etc. HW accel is enabled on everything. All my issues are solved. Even in an alpha game I play all the random crashes where the display driver would time out etc are gone (star citizen). I had issues with that every day, and now it's smooth, stable, and I can have chrome/discord/steam, etc everything that uses hw accel running with no issues.

I believe 22.5.1 is "Recommended WHQL" for good reason. Even if you think your issue is different from everyone else, it may be good to base all your troubleshooting on that version, and not an optional driver.

In addition to 22.5.1 I really felt like these BIOS settings made a difference as well but take it with a grain of salt:

Power Down Enable = switched to Disabled

Cmd2T = switched to 1T 

I don't know for sure if they affected this situation but I do feel my system performs better in addition to being stable now. Another thing to try perhaps.

[ 5800X3D | Aorus 5700XT | MSI B550 | H115i Pro | G.SKILL 32GB 3600Mhz | 850W Gold | Samsung Odyssey G7 240Hz | HP Reverb G2 (v2) ]

To be clear on my side: this issue happened only in what might as well be GPU idle states - when I wasn't playing anything, or when maybe I was alt-tabbing to a browser, with the issue happening shortly after.

At its core, this was brought forth by said HW Accel issue, but, to fill in some additional gaps:


- RAM is running at its own with 1T, with its DOCP profile. Even then, it being set to 2133 MHz should not have had the issue occur, which it did.

- Following the steps from the link above (which included Power Down being set to Disabled and Gear Down on Enabled, which made no difference

The likelihood that the Cleanup Utility will help address something more compared to DDU is incredibly small, when all of the attempts have not had the minimum difference. We shall see when the next driver release comes out - I plan to keep things up to date on that front, if I can help it.

Adept I

October update:

The issue persists as of Optional version 22.9.1, which is no surprise.

Issue has not presented itself in any way ever since my original post, due to disabling Hardware Acceleration in places where this was used most (Google Chrome, Discord, Microsoft Teams).

Issue has however reared its head again today due to two specific aspects I have been using more lately, which are related to Hardware Acceleration: Steelseries GG, Windows 10 Video Player. Both of these are aspects where disabling HW Acceleration is close to unfeasible (only for Windows, possibly).


Some notes:

- I have seen the known issue in regards to VSync being Globally Off, however this is Off, unless specified by the application, so this is not the factor

- 22.10.1 is out and seems to acknowledge this as an issue (, but I cannot confirm if that is the case. @Matt_AMD could you help confirm on this, potentially?


Have you tested with just 2 sticks of RAM in slots A2/B2?

Are you running the latest AM4 chipset drivers from

Are you able to test with a different power supply? .. are you running separate power cables from your PSU to each power input on your GPU?

My wife was having driver timeout issues .. tried all the things you have done but under Windows 11. I replaced her power supply and all her issues were resolved.

ThreeDee PC specs

This issue did not occur prior to the new monitor, the RAM was not a factor in this, and neither are the PSU cables (this is the 'ensured no cable issues' mention in my original post).

Software-wise: Chipsets were up to date when I created this thread and they still are.

The issue only began with the new monitor, and only with hardware acceleration, which has already been pointed as the fault here, AKA software, not hardware. The fact this is potentially the one shown in the latest driver notes as known issues is a good thing, but the confirmation would be great as well.