Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Driver Set 19.8.2 vs 19.9.2 & Old Games

I noticed that before updating my Radeon 5700XT Drivers to 19.9.2, I had the 19.8.2 drivers and games like the original Sims, Warhammer 40k: Winter Assault, Prey (2006), and the main 4 Quakes (links below on Quake for support to fix this) were all working perfectly fine. Full and in the middle of the Screen with black bars (for anyone who has played old games while upgrading their computer, they know that this is normal).

That was with 19.8.2. Here is why I would bring up 19.9.2. I updated it to 19.9.2 and all of a sudden, the games shrunk and went into the upper left corner of the screen. I thought it was weird and I got worried. Turned out, that after using DDU (Display Driver Uninstaller) and reinstalling 19.8.2, the problem was solved.


Quake: The Offering on

Quake II: Quad Damage on

Quake III: Gold on

Quake 4 on

This really isn't a question, it's more of a problem that needs to be fixed by AMD.

26 Replies

Did you run an incremental update from the AMD Radeon Settings?  It often fails to install properly for me.
Just download full Adrenalin Driver. Download latest version of DDU. Disconnect from the internet. Boot into safe mode.
Run DDU to remove all old AMD/Nvidia driver traces. Reboot into normal mode. Install new Adrenalin driver version.
Reboot. Connect to internet.
The AMD incremenal installer / installer is broken without use of DDU in too many cases.
It needs fixed / improved.
You should not need to use DDU but in practice I find I do.

I wouldn't have posted it if it worked on the incremental even after DDU


It looks like this one might be specific to RX5700/XT.
It might be that AMD is working on new GPU Integer Scaling on RX5700/XT since it is on new feature voting list here, and that might have caused something to break: 
Vote for Radeon Software Ideas - July 2019 
I have a copy of Quake II RTX on Steam, I can try and see if that runs that on Adrenallin 19.9.2 on an RX Vega 64 Liquid right now and let you know if that is broken if you want.
If you have an old title like Star Wars Dark Forces I can try that out as well. It was scaling o.k. on RX Vega 64 Liquid last time I checked.


colesdav wrote:

It looks like this one might be specific to RX5700/XT.

I'm afraid not. It's happening on laptops too.

CS:GO Doesn't Run FullScreen on AMD 560X Laptop 

Thanks for letting me know.
Looks like it may be worth me testing it on RX Vega 64 Liquid then.
I am running blender jobs on the card at the moment.
I will try out some old games as soon as they complete.


Quake 2 RTX version is no good like Quake 2 xp :

Quake II RTX on Steam  vs quake2xp mod - Mod DB 



Thank you for this information.

I just tested the following old games I already had in a Steam Library Database.
Star Wars Dark Forces.
Alien Versus Predator Classic 2000.
Quake II RTX.

They all seem to be running o.k. on Ryzen 2700X+RX Vega64 Liquid + BenQ 4K 32 inch monitor + Windows 10 64bit 19.03 updated and checked just now.

I have tried all combinations of GPU Scaling options and Virtual Super Resolution on/off so far.
All testing has been using DisplayPort so I will look at HDMI output as well.

I am running the games at low resolution modes.
I note that Alt + Enter will get me a windowed version of the games in the top left hand of the screen but another Alt + Enter will put the games back to centered or full screen. Preserve Aspect Ration on the RX Vega 64 always gives a full screen. I was looking at that one for another user earlier last week.

I will look at the BenQ Monitor scaling modes next, when GPU scaling is off I have options FullScreen/Preserve Aspect Ratio/ Centered.

I am testing this next on the above system.
Star Wars Jedi Knight Dark Forces II.

I could get hold of the entire Quake series and test those but since Quake RTX is running fine for me so far I do not think that is necessary yet.

I will take a quick look at running older games on older GCN gen R9 Fury X with a simple + cheap Viewsonic 1080p monitor and see if that makes any difference.

Thanks again for your help.

Correction "Preserve Aspect Ration on the RX Vega 64 always gives a full screen on Dark Forces". - will edit when I can.


Switching to HDMI output on Star Wars Dark Forces I do see a "Chopped" - does not extend completely over to the rhs of the screen)  and off center screen image on the RX Vega 64 Liquid:




Note these old DOSBox based games have a DOSBox Configuration file which may need modified as DOSBox has it's own scaling options in configuration files and it may be those files that need modified.

I assume Quake uses DOSBox?



OK I just purchased and installed Quake on Steam.
I do not use GOG and maybe there is some difference in GOG configuration files that cause problems or it might be issue with different GPU / Monitor.
I am not purchasing another copy of Quake from GOG just to find out. Quake is more expensive on GOG. Over to someone else to look at that.
It is working fine on both DisplayPort and HDMI on: Ryzen 2700X+RX Vega64 Liquid + BenQ 4K 32 inch monitor + Windows 10 64bit 19.03
Some screenshots:
Fullscreen set in AMD Settings GPU Scaling:
Preserve Aspect Ratio set in AMD Settings GPU Scaling:
Center set in AMD Settings GPU Scaling:

Thats all I have time for to look at iton this machine. I need to set up to run more blender jobs.

Bye for now.

I tested R9 Fury X + i7-4790K on Quake (Steam version), It is also working fine on DisplayPort.

I have too the DEvil's CAnyon 4790k (Gooood) but with the RX 580 and I run DOS games with the DOSBOX SVN Daum and for 3dfx games I use the Nglide and then I set REsolution to 'DEsktop'.


Yes the i7-4790K is a great processor. Mine runs at 4.4-4.5GHz which is slightly higher than my  Ryzen 2700X can manage.
Is GPU Scaling working fine for you on Quake as shown in the above pictures?


Have you tried any of the alternative engines? Some of them are add great compatibility to modern Windows.

I use the Dark Places Engine for running the original Quake. I know the purists don't like it, but I like the extra blooms and effects it adds. Looks really good to me. To each is own right? If you have not played with that one it is pretty cool. They have some links to texture packs to use with it too that really update the game. Google Quake and Dark Places if you would like to check it out.


I run only Quake 2 and I use the version Quake 2 xp

I remembered : I run vkQuake from github and I can say that it is Perfect !

I have not tried that one. Thanks, I will try it out!

Great observation. The OP may find if they installed the new driver that same way it would be fine too. Worth a shot and if it is bad report it to AMD: 


Please see my reply as I did do DDU and the newest one and it still did it

Sorry to hear that. All you can do is return to a driver that worked as you have. Just make sure to report it to AMD.

Adept I

Were you using Virtual Super Resolution for those old games?


Does compatibility mode make a difference?

Adept II

Hi jagdogger2525‌,

What monitor are you using ? 
Please attach your dxdiag.

Chaitanya Krishna.

Journeyman III

I had the problem that Dosbox refused to go into fullscreen in the latest driver versions.

My solution was to deinstall with DDU, restart, disable internet, "update driver" in device-manager with the local saved 19.8.2. (in short, the Win95 way of installing drivers)  and so without the whole hightech bloatware. (I have a old 7700, only for old games)

Now I can play Dosbox in fullscreen again.