Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Driver Problems after update

Hi all,after the last update i get an error. All my games lost the minimum requirements and they has a red icon like they re not supported. Before the update the icon was green and all games were run perfectly. Also if i click update it says update fail. I tried to reinstall but i didn't resolved nothing.Immagine.png

11 Replies
Adept I

Consultor.PNGMe and my friend, we have exactly the same problems.

And not only that, but when playing, we noticed a very stuttering too.

Already tested changes like revert to previous drivers (chipset and graphics) and even reinstall windows, but the problems are the same (like your printscreen, and the stuttering as I mention above)

My hardware : AMD 5900X + AMD Rx6800 XT

I uninstalled all AMD software chipset, drivers etc and deleted the whole AMD folder. I cleaned the cache and i clean the registry with CCleaner.

I reinstalled again chipset,software and driver but it keep showing all games doesnt have the minimum requirements and also it keep showing update fail...

I tried that too, and tested even with older versions of the drivers (chipset and graphics).

Used AMD clean utility....

Do you tried, when installing the graphics driver, to perform a clean install? Said that needs to restart, and then continue the installation process, but after restart, nothing happens. I need to run setup again, and start over (need to restart, and then doesn't start the installation process after that restart)...

I don't know whats going on, but I hope AMD fix it ASAP.

For the moment it keep showing me all my games doesnt have the minimum requirements even if isn't true . If i click update it no show more failed but  updated.  My R5 and Vega 7 support a lot of new games and is werid it keep show the Red X icon on old titles too.

I read a lot of people having issues with Upgrade advisor which says the hardware doesn't meet the minimum requirements. How to disable or remove it ?

How i can fix it ? 


same problem 

Same problem on rx 5700
Reinstalling the driver does not solve the problem. DDU and AMD Cleanup Utility also does not solve the problem
have you installed windows 11 health check? As observed, the problem started after installing this program


Before a clean install, yes.

But now, I already made 2 fresh installations, and the issues still the same as before (even with chipset and graphics card older drivers that don't have any issues, now I've). 


Hahah, well, I guess issues like this one only prove that the newest AMD drivers always tend to break stuff more than improve upon anything. The best rule I've figured out for myself is:"If you somehow manage to install good drivers once and they're stable/reliable in various applications and games, then it's better to never update them at all, unless some crucial changes are implemented in the new ones".

In relation to the topic, I'd advise rolling back to the previous driver versions (or cleaning your current drivers and installing older ones).

W10Pro (22H2)|Kingston A400 240G|ASRock B550 Phantom Gaming 4 (L2.71)|Ryzen 5 5600|ID-Cooling SE-225-XT Black V2|nVidia RTX 3070 FE 8Gb|XPG GAMMIX D10 [2x8GB] DDR4 3200MHz (XMP)|DeepCool PK700D

Not hotfix yet?

Journeyman III



I have the same issue. I do not think that this issue is related to the 21.6.2 Version of Radeon Software. I guess it is an AMD server issue. After noticing the issue (which has no impact on game performance by the way) I downgraded to 21.6.1 and afterwards to the version before using DDU to remove the previous installations. Even with the older versions the issue was still there. I think that the AMD servers send false information that lead to this display error while scanning the local game library of known games. Deinstalling and reinstalling the drivers cleared the cache and parts of personal settings/data (ddu AMD Cleanup) and cannot be downloaded correctly via the upgrade assistent. This might lead to the wrongly displayed information even while using different versions of Radeon software. The Version of Radeon Software has no impact on the issue - it must be the servers connected to the Upgrade Assistent.

As the issue seems to be widely spread, AMD should issue a statement on this issue and when they are going to fix it. It is only a "visual" bug but could have a negative impact on lesser experienced users who could think that their hardware might be broken.

For now - just go to the settings seciton and turn off the upgrade advisor to ignore the wrong information that is displayed currently until AMD gives us further notice - which I hope the will.