cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

fractalyse
Adept I

Driver 19.30-(838629/855429) no legacy opencl

I'm running ubuntu 18.04.3 LTS kernel 5.0.0-25-generic, I use to have 18.50-756341 which works well with my Radeon VII and my rx 550.

I've removed drv 18.50-756341, then I installed 19.30-838629.

When running clinfo, it only detects the 'PAL' platform of the radeon VII, not the 'legacy' one for RX 550, same for RX 580.

I've also tried with 19.30-855429 same issue.

It seems OpenCL support for Polaris is missing in this driver.

0 Likes
1 Reply
porcelainmouse
Adept I

Did you get it working by now?

Just wondering if you tried the explicit option of amdgpu-install to select legacy OCL drivers.  Or, did you use that option, which is why you thought it was weird that it didn't detect?

0 Likes