Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Do you like the new interface of Adrenalin 2020 Edition?

Do you like the new interface of Adrenalin 2020 Edition?
Personally yes, but not too much. I like the idea and the single elements of the interface, but overall it’s quite a mess. Everything should be reorganized a little bit.

456 Replies


I have never seen the "Microsoft Windows Operating System" show up as a Game before either. 

It turned up after the AMD Adrenalin 19.12.3 UI froze on me when I was running BF1 with Chill turned on in Global and Game settings. 
Thinking about it I am not surprised I got the OS Kernel Security BSOD after launching "Microsoft Windows Operating System" from the AMD launcher
It probably tried to inject some Chill or Boost code into Windows 10.

I had a look in the Windows Registry to see if there was anything obvious in there that would help me stop the Game Advisor from running all of the time. 
I am sorry to say I did not find anything yet. 
Killing obvious "AMD" processes that might be the Game Advisor running did nothing positive (killing some of them caused the Adrenalin 2020 19.12.3 GUI to crash). 
So I am sorry to say I have been unable to stop the Game Advisor. 
I think it is part of the GUI exec itself. 
Only option I can think that is left is to look at the Driver installation files and maybe remove something in there. 

But I have had enough. 

I should be working or gaming, not debugging or trying to work around bad driver GUI/UI implementation. 
I was very happy with the Adrenalin 2019.19.12.1 driver/GUI/UI. 

There were a few minor things that could have been improved on it, but it was/is really good overall.  

I would prefer AMD concentrate on Fixing Chill, improving performance and stability for older GPUs like R9 390X and Fury X's and Vega cards I still run, and stop locking HBM OC on Fiji cards.
Also it would be great if I could run Radeon Pro Enterprise 19.Q4/20.Q1 drivers on Fiji GPUs. 
It would also have been great if AMD would provide a decent driver GUI/UI for use on latest Ubuntu / Fedora / Centos Linux to control AMD GPU settings.

Instead the focus is on a Gaming App built into the driver that I cannot switch off.
There are plenty of Gaming App alternatives available from third party companies. 
You do not need one built into the drivers. 


Yep, I totally agree and now all I get is more stuttering on Post Scriptum, Tannenberg and Squad which are most of the MP games I play and it's all because of the crap AMD advisor and AMD in-game overlay which the later at least is disabled but keeps injecting when opening a game it always shows up which never happened before on older drivers it would be completely disabled...

On games that AMD drivers show them  up in the game page\tab and doesn't open the AMD in-game overlay neither it keeps track of the game, they seem to have the same performance as before, all the ones where AMD injects their crap and have gaming advisor running and always keeping record of game performance is killing my CPU performance and causing more stuttering than ever, this is just pissing me OFF...

I don't like the newer user interface, but It doesn't even bother me, what bothers me is really not having the custom install and completely not install the streaming stuff, the game advisor stuff and other crapware that I don't care, and also I'm still to see anything on this latest driver that actually works...

Almost nothing works for me on those latest drivers, OC on game page doesn't work, the clocks of the GPU and memory are still the default, disabling the in-game overlay doesn't disable it, game advisor crap is always on and no way to disable it when I don't want that garbageware CPU performance killing garbage to just report game time and avg FPS which when I want I'd use MSI app but not to actually play a game as it always loses a few FPS... The only thing really that works for me is just changing the resolution from the crap always badly detected ycbcr default crap settings to RGB 4:4:4...


I will just start it now. 



Shortly after launching the OS as a game Windows 10 BSOD with Kernel Security failure. 

Journeyman III

I hate it, i just wanted a videocard driver.
Every time i need to ctrl-alt-del to go to taskmanager so i can kill that bloody overlay that f#$^cks evrything up.
Otherwise i get only ingame sound and a black screen from my r9 290x

Adept II

Well, this update finally pushes me away from AMD, and next week i am getting my Nvidia card.

The new update sooooooo bad, that one can not even set everything to automatic and to keep the maximum

power limit. Automatic means power saving. Extremely stupid. Zero Rpm broken for years, Anti lag and Boost are completely useless, in some cases even add some stutter, the UI is the worst that i have ever seen (i really liked the previous one, clean and nice, why was it even changed?).

Im sick and tired of all the bugs, the clunky UI, the not working drivers, one has to be a voodoo shaman to get the zero rpm to work as it should with manual fan curve speeds, etc etc etc. I am sick of it.

Goodbye AMD.


Enhanced Sync is broken on Adrenalin 2020 19.12.3. for me running on PowerColor Red Dragon Vega 56. 
I see terrible FPS performance - dropping below 12 FPS on Starcraft II. 

See: Low FPS with sapphire radeon rx 5700 xt nitro+ special edition 


Adrenalin 2020 19.12.3 with 1 Nvidia Primary and 5 AMD secondary GPUs: 








I was not aware that Radeon Image Sharpening had been enabled on Fiji based Radeon Pro DUO. 



Gaming Graphics shows this with the Nvidia Primary Display the only active display. 


Swapping over to RX Vega 64 Liquid (in secondary motherboard PCIe slot). 

I can now see CrossFire Mode options in the Advanced Tab. 


Crossfire options are available for the "Primary/Discrete" GPU1 RX Vega 64 Liquid: 


And for the Radeon Pro DUO ... no CrossFire option is available. 
That may be because I am running the GPU from a PCIe 3.0 x 4 M.2 Adapter, which for some reason, the Asus Motherboard will only allow me to run at PCIe 2.0x4. 


Blender sees the GPUs O.K. 





Compubench 2.0 sees and runs OpenCL tests on all GPUs with no problems:


None the CUDA tests will run for the RTX2080, but it's OpenCL performance beats the the RX Vega 64 Liquids in a some tests.  


Compubench sees the vega GPUs as gfx900, and does not distinguish between Vega 64 or 56. 


LuxMark is running fine with Adrenalin 2020 19.12.3. Driver. 



Fan Speed control appears to be broken on Adrenalin 2020 19.12.3 driver for the XFX R9 390X OC Black Edition GPU. 
I have to set the fan setting to maximum RPM to even get the fans to spin at all. 


Fan speed control is completely broken on R9 390X GPU. 

Incrementing fan speed seting in steps of 50 and nothing changes, fan stays at 150 RPM (off) until this point: 
Then RPM shoots up to 3634. 

Increasing Min Fan Speed further to 5200 I see this: 


Guess you forgot about posts as far back as 2016 about the R9 390/X fan control not being supported in wattman. Never will be.

By the way, I too can force/add Win OS (with some manipulation/renaming/moving) to games list.

Although why you would try it when it has an exclamation mark on it, is beyond me.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

RE: By the way, I too can force/add Win OS (with some manipulation/renaming/moving) to games list.

Go make your false accusations and trolling somewhere else, or do some testing yourself.


I think the favourites setting is useful. 



I just tested BFV combined operations on RX Vega 64 Liquid in Adrenalin 2020 19.12.3. at 4K Ultra settings with in game FPS locked to 60 FPS max. 
The GPU is running with a HBM2 frequency of 1120MHz, and fans maxed out. GPU CLK is at stock settings. 
I see the following problems. 
Radeon Chill hotkey assigned to Alt+W does not work at all. I have to use F11.
Radeon Performance Overlay consistently switches off. 

Chill performance is as usual. With Chill_Min = 30, Chill_Max = 300 I get a maximum of 55 FPS with Keyboard only input. 
Rapid mouse movement is locking to Chill_Min, so far.
Holding down shift and rapidly tapping W to do the "Chill Chicken Walk" increases FPS to 60.  
If I turn Chill off the GPU will run at  60FPS for a short time period before overheating followed by the usual HBM2 temperature related blue screen flashing corruption. 
I would like to leave Chill on and hit 60 FPS when character running. 
I need to be able to turn off as much of the driver "additional features" as possible please such as the Game Advisor. 


I was running BFV in DX12 in the above case. 


Update - Rapid mouse movement is not consistently locking to Chill_Min. 
Sometimes when I launch BFV DX12 with Chill on, rapid mouse movement does get locked to Chill_Min.  
Other times not. 
Even when running the same section of the game. 
This needs fixed. 

If Global FRTC was still there it would be a workaround. 


RX Vega 64 Liquid running. 
I think there may be a Browser conflict / bug. 

I have Mozilla Firefox as my default browser. 

I have the AMD Adrenalin 2020 19.12.3 "built in" browser running as I write this and it appears to use my default browser (FireFox). 

If I launch Google Chrome (its a brand new fresh install) all I see is a black window as shown here: 


I also had a issue with Chrome. Giving AMD the benefit of the doubt (and really wanting things to work well) I uninstalled 19.11.1 and installed 19.12.3 to see if it was improved over 19.12.2. As a work around for frame limiting I decided to use RTSS (just on its own without Afterburner) until FRTC is brought back (fingers crossed!). It installed without issue - so far so good - and then I opened Chrome to check something system froze requiring a restart. I uninstalled 19.12.3 and reinstalled 19.11.1. Why Oh Why, AMD! Don't fix something that is not broken........ 

Adept II

I would have liked to see each feature to be option. That way each user can customise it to their liking. 

Totally agree, 1st I don't want to install AMD LINK, game advisor and the game performance metrics which is killing my CPU performance and causing much more stuttering crippling my old CPU even more, neither I want the streaming garbage installed if I don't plan to ever use it, I want a custom installer with choices and actually being able to enable\disable everything I want...

I can't disable the game performance metrics and the game advisor which are always keeping record of my games performance and I don't even want, when I want to lose a few FPS to check in-game status I'd use MSI afterburner, but only temporarily and then close it so that it doesnt screw a single FPS from my gaming session, I don't want this crap to be ON 4 ever...

Adept II

The new driver really looks awful. And facebook in my gpu driver is the last thing that I need. They have to cater to mature customers as well, not having any options in the installer is unacceptable.

Adept II

FYI: You have to kill the X-Box Game Bar in Windows 10 to stop the pop-ups when ever launching a game


Put it this way: I've been a stalwart, AMD exclusive user for the last 15 years, ever since I got my 9600XT in 2004, owning 10 cards over that time span, and the new 19.12.2 UI is way too clunky, slow to navigate, unnecessarily large, lacking in such basic features as an OFF option for ReLive the way all previous ReLive versions had, lacking previous existing useful features such as FRTC, and still doesn't have the intelligence to prevent creation of useless game profiles for non games. It is even worse than Catalyst Control Center, and a huge step back from the snappy Radeon Settings. I absolutely refuse to use it, and will purchase an nVidia card as my next upgrade if it is not corrected.

Thought I would add this here, from AMD's current livestream from CES. The way they boasted about it, including the new unified UI, despite the complete lack of applause, somehow I think this is, sadly, here to stay.


What 20 new and improved features?
In any case I downloaded it. I am not using it and I will not be using it.

Not applicable


Just read the whole thread, its quite sad.

We had the Fury X with a custom BIOS to disable the powerplay underclocking and since 2016 I haven't had a single issue, solid FPS, it was great.

So now with the Radeon VII all hell has broke loose.

HDMI Scaling locks to 30FPS, I cannot see the edges of my display, if I scale the display, it locks to 30FPS, WTF

19.12.3 driver, with any game, if I don't do anything afk, the black screen of death occurs, most likely a powerplay BS undervolt issue so I'm back to square one right now.

Already flashed the Radeon VII with 4 BIOS roms, edited the power tables, no luck.

20 new features and improvements AMD? Talk bollox as per usual. You couldn't be bothered to test your own drivers.

AMD are a bunch of scam artists.



Release Date

Update 20.1.1 Release notes 

Does nothing to address any of the problems listed above.


Sadly, and nothing official I have seen from AMD's official social media sources either. Not that I don't trust GamersNexus, but it's easy to tell someone something behind closed doors and have them repeat it on Youtube, and quite another to come out and say "We F'd up, we're working on the problem", especially when prices are so bloody high...

Adept I

Hell no. I can't even record my desktop without that huge stupid bar popping up on the left which I cannot close, And gets recorded with the game. Whoever designed this interface needs firing seriously. I can't stand it, I've actually gone back to my old driver. It needs to be optional.

Adept I

I cant tell, because its not starting. And VLC Player is laggin Fullscreen when Mouse is moved... All since 19.12.2 Since that New Gui/Driver was released.amd.jpg


Are you getting the invisible settings window with 20.1.1 version as well?

Adept I

I do like the new interface, I think it's an improvement from the previous version, it's easy to use & understandable at least for me, not saying that there's no room for more improvements, but, the drivers were terrible!!

I am currently using the 19.12.1 version, I've one super annoying problem, that is the screen not waking up & the "NO HDMI Signal" most of the times, I've to turn the monitor on & off couple of times or unplug and plug the HDMI cable to wake the screen again, if anyone knows how to solve this problem, please help me, thank you.