cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

kni_slaughterer
Journeyman III

Display Keeps Losing Signal On Windows Boot - RX480 Win 10 FCU

Guys I'm facing some problems when my computer start i see the MSI logo and everything is good but when windows start loading i hear something disconnect and reconnect multiple times and then monitor shows no signal and then it reconnect right back and it's working again !!!

is this a faulty driver ?

or Windows 10 FCC problem????? because i started seeing it after the FCC i trying DDU and reinstall but nothing .

however when i use newer version of driver the problem become worst i mean something  disconnecting in game and monitor shows no signal and eventually crashing the whole pc !! this is the best situation i get with the July 2017 update..... -MSI RX 480 GX 8gb-

System:

I5 6600K @stock speed

MSI Z170 Tomahawk

HyperX DDR4 8gb 2133mhz

Crucial SSD 250gb

Seagate HDD 2 Tbs

MSI RX 480 8gb Gaming X

Windows 10 FCC update -all updates are installed until 19-01-18

Attempt to solve :

-Formatting windows

-Using DDU in safe mode and reinstalling driver

-Trying different driver but eventually using 17.7.2 ----> i have only the startup problems with this version the other ones produce crashes in games.....

Message was edited by: Matt B

We have updated the title of this discussion with relevant details to better describe your issue.

Tags (1)
0 Likes
3 Replies
plumboby
Miniboss

Re: AMD driver crashing.......maybe....

experiencing same issyue yusing my cpu videocard atm cant boot past windows load screen from after driver update so unstable tried many ways wround it

0 Likes
amdmatt
Community Manager
Community Manager

Re: Display Keeps Losing Signal On Windows Boot - RX480 Win 10 FCU

Have you tried using the latest 18.1.1 driver and upping the GPU Power Limit to +50% in Wattman and then click Apply, which is located in the upper right corner? I recommend trying that and then seeing if things still crash.

plumboby
Miniboss

Re: Display Keeps Losing Signal On Windows Boot - RX480 Win 10 FCU

roll back a driver the 18.2.1 isnt the most stable atm i found rolling on the 17.1.1 driver atm as most stable & my build is a i5 2400 8 gig ram with sandisk ssd. Check you psu & make sure your getting enough juice to run it another issue i found with mine i am on a 600w psu atm so running a bit more stable atm tho still a bit hit or miss on boot atm. & done everything AMD has suggested there are a few bugs in the system from Windows update throwing weird issues between AMD drivers & 10 atm i have found. Creators update been a curse for AMD drivers atm. Make sure if you can get running on the lower driver version to lock back your wattman power as can brick your pc on boot to.

0 Likes