Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Disabling MPO fixed blackscreen crashing and glitches with hardware accelerated applications

Hello everybody,

I recently switched to RX 6700 XT. After few days of usage, I noticed strange behaviors in hardware accelerated applications like web browsers, Viber, etc. First were glitches, flickering, typing cursor color glitching. Then blackscreens started with long timeouts. After some troubleshooting and searching for a fix, I found the solution in a reddit post. After turning off MPO in Windows, all of the problems I mentioned got fixed. Here's the reddit post ->

I beg AMD to pin this post.

6 Replies

Good day!

Everyone here has been aware of this for about 2 weeks now.


I can assure you that only 10-20% of users are aware. We need to reach more.

Adept II

im going to give this one a go.

the hardware accel turn off in apps fixed it pretty well for about a month. crashes started up again not too frequent, then added Deemon69's hw accel disable to it but that didnt make it better. long black screen driver crashes still.

im on 22.10.2

ill add here if this one helps. thanks


Ive not have any crashes despite re enabling hw acceleration in most places. The disable MPO is the real fix for the moment!

Adept I

I am going to try this one, I started receiving black screens like 6 months ago on a random basis - sometimes in a game or sometimes while casually browsing. I've tried everything and nothing worked so far. Thanks!

Adept III

Disable MPO fixes 95% of all problems AMD drivers is facing. Still, it seems AMD is not aware of this. Is there anyone on this forum that can pass this to the ingeniers? Its huge...