Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

DirectX9 and DirectX12 issues with 6800XT

Hi, I've concluded that I cannot solve this issue by myself and I think more brain power is needed. It has taken me at least a month of research and work trying to fix this, I tried almost everything I could find on the internet and still it didn't work.

First, the specs of the PC:

CPU - AMD Ryzen 7 3800X
RAM - 32 GB 3600 MHz (4 sticks of 8 GB RAM)
Motherboard - B450 Tomahawk Max
GPU - XFX Speedster Merc 319 6800 XT 16GB
PSU - Seasonic Focus Gold GX-650 650W
HDD/SDD - 2 HDDs (2TB and 4TB) 2 SSDs (256GB with the OS and 512 GB)
I don't think that it's causing the issues, but I also have Valve Index headset.

Before I even start:
yes, I have updated all the AMD drivers, yes I had an NVIDIA GPU and yes and I did clean the drivers with DDU.
I've tried reinstalling windows multiple times (performed "Recovery", the "Reset this PC" option and selected "keep all files" and that did work and fixed the issue, but after two/three days it went back to the state on video).
I've tried DXVK, I've tried safe booting (more on that later), I've tried disabling all non-microsoft services in msconfig.
I've checked the crashlogs of most games (if they had any)  and even minidump file that was generated when trying to launch PAYDAY 2 (but it didn't help much, if anyone wants more info, I can send screenshots of the dump).

Now the issue:
I've recorded myself trying to launch titles that use either DX9 or DX12 (namely PAYDAY2 and Metin2 use DX9, DRG and Amid Evil have an option for DX12). (First time posting, so if it doesn't work I've uploaded the vid to Gdrive:
As you can see, the DX9 games don't even launch, while the DX12 games do, but they either crash while playing the game, or something breaks and it shuts down.
When I go into safe mode, the games launch just fine and without issues (obviously in an unplayable state, otherwise I would just do that and leave things as they are).


But alas, as soon as I leave the safe mode, it will just refuse to launch again.
I am getting really desperate at this point... I hope someone can help me with this issue :(.

0 Replies