Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Current state of linux amdgpu drivers for Vega M on Kaby Lake G?

Hi.  I ordered one of the new HP spectre x360 laptops with the new i7-8705G/Vega M GL chips

I intend to run linux on this device whenever I'm able to.  I have heard that amdgpu drivers do not yet work, but there is not much information out there yet.  This is really the only report I can find at all:

Quoted for convenience:

wasn't able to get it to use the amdgpu driver for the AMD card. lspci sees it as "[AMD/ATI] Polaris 22 [Radeon RX Vega M GL]", but no driver is assigned to it. Adding it to MODULES in mkinitcpio also makes no difference -- no driver assigned, X still happily running on the Intel card. 

I'll try to set up Mesa Git and maybe AMDGPU PRO, but I'm not terribly optimistic, as there's no info at all about this GPU on the internet. AMD driver download page doesn't even list it.

I have not tried myself yet as the laptop has not been shipped yet.  I am curious, what is the official state of these drivers?  Is the user correct there are no functional drivers yet?  Any ETA?


3 Replies

If you are not already watching there too, I would ask this and hope for answer in the support forum for whatever Linux Distribution you plan to run. Typically the distro guys know way more about what is going on that us here do. Most of us here are Windows helpers and none of us are AMD we are just people like you. Some do come through and may answer your question but just so you get an answer as fast as possible. You may even send HP support that question too. They may know something as well. 

Journeyman III

I recently purchased the NUC HVK and am making this post from the newly minted Ubuntu 18.04 partition. Prior to getting the Ubiquity installer with 18.04 working I tried:

  • Successful Windozer 10 on one hard drive for gaming - irrelevant to the topic of this post but included for full disclosure
  • Arch's 2018.05.01 release and learned how woefully incompetent I am at partitioning two M.2 hard drives for UEFI/GPT boot - catastrophic failure, if I was better with Grub and EFI I probably could have got this to work but sadly much to learn I still have
  • Antergos, in hopes of getting Pacman + GUI. Attempted with live disk boot entry both with and without 'nomodeset' but 'booted' to black screen or fail prompt
  • Ubuntu 16.04 - also tanked with fire, did not try modificationating the live disk boot entry with 'nomodeset' but 'booted' to black screen assuming because it couldn't determine how to do anything with the graphics similar to Antergos
  • Ubuntu 18.04 - worked like a champ, followed the askubuntu forums for how to get that second hard drive going correctly under UEFI/GPT and grub does everything it should including picking up the Dozer as well

The original plan was to not dual boot, install Arch on the board's fake raid and use the Intel and AMD iommu to do full passthrough to a KVM Dozer 10. But that was all a little bit ambitious, maybe someday.

I am currently under the impression that support for the Vega M isn't coming until the 4.18 kernel drops so regardless of distro we aren't getting anything 'ffishully until September. Right meow I'm in the process of building the 4.17 kernel and see if I can horse around and get Mesa 18.2 built and working but we'll see. If you'd like I can keep this post updated with my progress on the hax until September rolls around.


You might check with Intel or their support forum  Downloads for Graphics Drivers