cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

fmnostatic
Journeyman III

Crimson Driver 16.4.2 not installing properly?

I tried downloading 16.4.2 twice, and it shows up instead as 16.5.1 on my system.  Also noticed the 16.4.2 download is the only crimson driver that doesn't start with a capital letter, does that sound right?   Anyhow, decided against using 16.4.2 for now because I'm apparently unable to obtain it.  Any helpful advice would be appreciated.

0 Kudos
2 Replies
goodplay
MVP

Re: Crimson Driver 16.4.2 not installing properly?

Have you tried Clean Install AMD Graphics Drivers

If that fails, then INFORMATION REQUIRED WHEN POSTING A QUESTION

Guessing 16.5.1 is a typo.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3200c16d kit, Aorus nvme gen4 1tb, Nitro+RX6900XT,
0 Kudos
fmnostatic
Journeyman III

Re: Crimson Driver 16.4.2 not installing properly?

Thanks for the reply.  Yep, clean install, as per directions listed on main page, as always, twice.  The version installed was listed as 16.5.1 instead of 16.4.2, so I uninstalled it both times.  Also, unlike the previous Crimson drivers dl'd from the official site, the dl executable for 16.4.2 didn't start with a capital letter.  Card is Sapphire Nitro R9 390, desktop, Windows 8.1 pro x64 OS, Crimson driver 16.4.1, benq 1440p fs display/dp connection, Asrock x99 extreme6 mobo, xeon e5 1650 v3 cpu, Evga 1k p2 psu, 32Gb/ 2133 quad channel ram.


No discernible problems after install, other than the listed version number itself.  I uninstalled upon seeing listed v number both times.  Considered using DDU tool to uninstall current drivers, but for the moment 16.4.1 seems to be working well enough I guess?