Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Crashing, bsods on a new system


I've got a new rig up and I'm having BSODs and applications crashing constantly. I don't know what's causing these errors and I would appreciate any help. I am using Windows 10 64bit.


My hardware:
AMD 3900x
570x Asus ROG Crosshair VIII Hero
Corsair MP600 1tb
G.Skill Trident 2x16gb 3200mhz (F4-3200C14D-32GTZR)
ASUS Geforce 2080 ti ROG Strix
Corsair PSU HX750

I also have tried with an old 1070 graphics card and another set of ram sticks (F4-3200C16D-16GTZR) and I have the same problems.

What I am doing:

1) Format and install windows using latest media creation tool
2) Install drivers from mobo manufacturer
3) Install drivers from AMD
4) Install latest NVIDIA drivers

5) Windows update
6) Install firefox
7) Firefox tabs crashes constantly
😎 Install a game and watch it crash constantly

I have the latest BIOS version and I've made sure the PCIE slot is using GEN3.

I've had these problems for over 2 weeks and I can't figure out whats causing it. I'm out of ideas?

0 Kudos
5 Replies
Journeyman III

Re: Crashing, bsods on a new system

Anyone have any ideas?

0 Kudos

Re: Crashing, bsods on a new system

This is from Microsoft Support about your first BSOD error "* FAULTY_HARDWARE_CORRUPTED_PAGE":


This bugcheck can only occur by memory corruption due to physical memory access. The causes for physical memory corruption include:

  1. Defective RAM hardware
  2. A driver or device incorrectly modifying physical pages via an incorrect DMA operation or associated MDL.
  3. Corruption caused by a hardware device or firmware corrupting memory, such as firmware illegally modifying physical pages across a power transition.

To eliminate defective RAM Memory, run MEMTEST86 and see if you get any errors at all. One error is considered a defect.

Also run Windows CHKDSK to see your Hard Drive or SSD has any bad Sectors on it. Faulty Hard drive can also give you this type of BSOD.

Another website also mentioned defective RAM Memory beside checking Windows using SFC /scannow. It suggests you either install the latest GPU driver or roll back to the previous GPU Driver.

This Windows Tech site gives some good tips on how to resolve that first error: How to Fix: FAULTY HARDWARE CORRUPTED PAGE error on Windows 10 

For the second BSOD error "PAGE FAULT IN NONPAGED AREA":

This tech site mentions also to Check RAM and Hard drive plus some other tips: Page Fault in Nonpaged Area BSOD Error on Windows 10 Solved - By Nikhil Gupta 

Method-2: Run Disk and memory Check

Faulty RAM and corrupted NTFS volume may be the reason behind the blue screen. If removing recent changes doesn’t work for you,then the problem will be in your RAM. But do not worry, we have a solution for this error. The diskcheck will help you in removing the error. If you do not know how to perform this task, then follow the steps given below.
It shows step by step how to do the above.
Seems like the one thing common in both, as far as Troubleshooting goes, involves possible defective RAM or Hard Drive.  I found another Tech site that mentioned to check those two also for the BSOD error you got.
0 Kudos

Re: Crashing, bsods on a new system

Plus your RAM Memory is not listed under ASUS QVL List for RAM MEMOY: ROG Crosshair VIII Hero Memory / Device Support | Motherboards | ASUS USA 

This list is for 3200 MHZ RAM MEMORY for G.SKILL RAM MODULES

Since I needed to download the QVL List I have attached it here for you to download and look at it yourself if interested.

NOTE: Possible that RAM incompatibility could be causing your problems with the 3rd Generation Processor.

0 Kudos
Adept II

Re: Crashing, bsods on a new system

Strongly suggest you load up a USB stick with MemTest86 and run the full battery of tests. Your first error appears to indicate memory-based corruption, from one source or another...

0 Kudos
Journeyman III

Re: Crashing, bsods on a new system

Hello, thank you for the reply.

I ran MemTest86 overnight and it did not catch any errors. I've also tried another pair of ramsticks (F4-3200C16D-16GTZR). On the QVL F4-3200C16D-16GTZ are listed. The id is very similar, I don't know if it's an typo or not. However I have the same issue with both pair of ram. Tried different voltages and speeds, from default to extra voltage, downclock etc.

I've installed the latest GPU drivers from nvidia and sfc /scannow don't return any errors right now. It used to return errors before I changed the speed to GEN3 on the pcie speed.

I've reinstalled windows many times and I should not be getting corruption/bad drivers with a new copy?

0 Kudos