Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Crash on Windows 10 login with RX 570

I installed Windows 10 Home (2004), on machine using ASRock B450 ITX/ac, Ryzen 5 3600, Sapphire Nitro+ RX 570.

I opted to not connect to the Internet so the entire initial setup completes successfully using basic drivers.

When connected to net, Windows Update downloads appropriate AMD drivers and on next restart, machine hard crashes at the moment when it's supposed to switch to login screen. That's the moment I assume AMD GPU drivers are activated. It hangs in a way that even power button is not working and only physical PSU button can help. Sometimes all fans start spinning with max speed.

I tried not connecting to internet and installing latest drivers (20.10.1) manually - same thing, same crash.

I tried to installing manually latest B450 chipset drivers (this went fine) and then Adrenaline - same crash when restarted.

This is purely drivers issue, as this same hardware works fine as long as AMD GPU drivers are not installed. It also works fine in another OS. Re-installed Windows 10 several times already trying all this, always ends up the same.

How can I resolve this? What older drivers could I try that could possibly work..?

4 Replies

Also tried with Windows 1909 and 2009, all with 20.9.1 drivers. Every single one crashes. This is beyond ridiculous now.


Is it possible that something in the ASRock BIOS is influencing this behaviour?

I have CSM off, Above 4G decoding ON, the rest is pretty basic and pretty much by default.


did u find a fix?

i ahve something similar i have r 570 sapphire ntro+ 8gb and worked fine on system for ages. windows updated to 20H2 and then not long after amd released new drivers. 20.11 and i started getting now and then issues. crashes . but a few days ago whenever windows attempted to load in the adrenalin package at desktop landing system would green screen and hard reset itself.


have tried DDU drivers, refresh windows install. still crashing. even tried older drivers 19.11 and no dice. card was running well for months after initially being a PITA to install and have drivers work correctly.

have windows and amd bricked my card? 

even put card into old system it came from and not working in there either.

Journeyman III

I have this issue as well. Have an Asrock B450 Pro on 1.8 bios with a 2400G CPU. Installed the Visiontek rx 5500xt 8Gb received for Christmas and it worked for a week, then started freezing on bootup into windows. 


Wiped drive and reinstalled windows and as soon as I try to install the AMD drivers the system goes to a black screen and freezes. On reboot it freezes on windows load. Only way to get into windows is to boot into safe mode and roll back the video driver to ms vga driver. But it only works with the MS vga driver. Any attempt to either load October 20H2 windows update or any AMD driver (went back to 19.11 and up) and the black screen returns. Ran DDU and tried several times. No dice. Tried reflashing bios and turned off internal graphics, nothing works. 


Finally giving up. Going back to internal graphics which oddly enough does work fine with the AMD drivers. So I think it's a problem with external AMD video card drivers.