cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Highlighted
Journeyman III
Journeyman III

Crash on Windows 10 login with RX 570

I installed Windows 10 Home (2004), on machine using ASRock B450 ITX/ac, Ryzen 5 3600, Sapphire Nitro+ RX 570.

I opted to not connect to the Internet so the entire initial setup completes successfully using basic drivers.

When connected to net, Windows Update downloads appropriate AMD drivers and on next restart, machine hard crashes at the moment when it's supposed to switch to login screen. That's the moment I assume AMD GPU drivers are activated. It hangs in a way that even power button is not working and only physical PSU button can help. Sometimes all fans start spinning with max speed.

I tried not connecting to internet and installing latest drivers (20.10.1) manually - same thing, same crash.

I tried to installing manually latest B450 chipset drivers (this went fine) and then Adrenaline - same crash when restarted.

This is purely drivers issue, as this same hardware works fine as long as AMD GPU drivers are not installed. It also works fine in another OS. Re-installed Windows 10 several times already trying all this, always ends up the same.

How can I resolve this? What older drivers could I try that could possibly work..?

0 Kudos
3 Replies
Highlighted
Journeyman III
Journeyman III

Re: Crash on Windows 10 login with RX 570

Also tried with Windows 1909 and 2009, all with 20.9.1 drivers. Every single one crashes. This is beyond ridiculous now.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Crash on Windows 10 login with RX 570

Is it possible that something in the ASRock BIOS is influencing this behaviour?

I have CSM off, Above 4G decoding ON, the rest is pretty basic and pretty much by default.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Crash on Windows 10 login with RX 570

did u find a fix?

i ahve something similar i have r 570 sapphire ntro+ 8gb and worked fine on system for ages. windows updated to 20H2 and then not long after amd released new drivers. 20.11 and i started getting now and then issues. crashes . but a few days ago whenever windows attempted to load in the adrenalin package at desktop landing system would green screen and hard reset itself.

 

have tried DDU drivers, refresh windows install. still crashing. even tried older drivers 19.11 and no dice. card was running well for months after initially being a PITA to install and have drivers work correctly.

have windows and amd bricked my card? 

even put card into old system it came from and not working in there either.

0 Kudos