Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Computing mode not switching for all cards

I have 2 Gigabyte RX 580 8 GB and use them to mine crypto and compute Matlab from time to time. 

Now that I was trying to get the mining up and running again I started to notice more problem with an old issue. 

When changing the work type to "Compute" Adrenaline will restart as normal and then not be able to find my second card. No other software, like MSI Afterburner or OpenHardwareMonitor find it either. 

The only way to find it again is to restart the entire computer. And even then, if I try to mine I will still get performance like the second card is still in Graphics-mode. Both cards compute as the same speed when I try having both in graphics mode and switching to Compute mode only changes the performance of on of the cards. 

Does anyone know what might be causing this?

I'm scared it might be a hardware fault and I have just been lucky so far to be able to fidget cables and cards enough for it to temporarily work before. As I said, it's an old issue, but changing cables/(card slot when I was using extenders)/updating drivers have worked previously. 

I'm on Adrenaline 20.8.3 


I figured it out, didn't see that you still had to switch what card you where switching settings for. Didn't realize the [GPU1] [GPU2] where buttons you could click. 

0 Replies