Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Computer freezes during AMD driver detect

I have a newly built rig as of last year. Win10 (now at v1909), Ryzen 3700X, 32GB, AMD RX580 8G (Sapphire Nitro+), and Seasonic 620W PSU.Everything is running at stock speeds. Everything works except I cannot update the Radeon drivers. I have tried dozens of drivers, old and new and when the driver hits the detect hardware stage (just after extracting the files) the whole computer freezes and then resets. There is no BSOD. It happens every time, even in safe mode. I tried AMD cleanuputility, DDU, AND a full Windows reinstall from scratch, etc. The only driver I have that works came with Windows and it is version 23.20.832.0 (3/3/2018). I have been playing a bunch of games with it and everything works fine. The last game I played through was Rise of the Tomb Raider. So clearly the card works. I never have any game issues or crashes. There are no yellow flags in the device manager, and The device mgr "Update drivers" option says the best ones are already installed

Now I want to play Wolfenstein II The New colossus and the game won't even run despite the machine being fully capable. Of course, the first troubleshooting step is check the drivers. Well I can't do that.

I suspect that the default driver doesn't come with the full vulkan stuff and I think the game needs it. When I run the game directly from the Steam folder it says "The code execution cannot proceed because vulkan-1.dll was not found..." I've wiped and reinstalled the game.

AMD Radeon Settings (2018.0303.2240.40774) show up in Apps & Features and the desktop context menu but the app won't run.

What I am looking for at this point is a direct download or a way to run just Wattman so I can maybe underclock the card and see if that will get the driver installed. I can't find a download and I think they're included in the adrenalin pkg.

An alternative might be to manually install a subset of the drivers without a detection phase. I can't find any information about that, but the AMD minimal driver download also crashes the PC.

5 Replies

Have you tried updating it from Device Manager...display/update driver/have disk/go to the Graphics/inf 64bit


Yes. It gets so far as to say that the driver is not signed and then it freezes and crashes.

Specifically, I did update driver > find locally, navigated to the extracted folder and let it search. C:\AMD\Win10-Radeon-Software-Adrenalin-2020-Edition-20.2.2-Mar5\Packages\Drivers\Display\WT6A_INF\

After that I had a complaint when logging in about a missing AMD dll (amdihk32.dll) , so clearly it had written something to disk and/or deleted/registered something. That DLL complaint went away after the next boot.

Also chose browse local and show compatible driver. It has listed a microsoft basic driver, an AMD RX 580 driver from 2017, 2018 (installed), and the latest downloaded.  (v26.20.15019.19000) But installing from here also fails.


Check this out. I moved the RX580 card to another computer in the house, and the software installed just fine. This one has a Gen 1 Ryzen, 32GB of RAM, and the same power supply (Seasonic 620 bronze). 

Journeyman III

I am having the exact same issue, but with slightly different hardware, and have done most of the same things trying to fix. Ryzen 3600x, 64GB 3200, 5700xt, MSI X570-A Pro MB. EVGA 850 GQ PS. Any help would be appreciated.


I got it fixed. I had to update the bios on the motherboard... first time I've done that