Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Colors inverted in Full - Screen.

If I play a game or do somethink in Full Screen the color be inverted. Black and White are Normal.

I have installed the AMD Driver 20min Ago before I had only the catalyst control center. I never had a problem like this and hope that this is only a wrong setting. 


12 Replies
Journeyman III

Same problem here (R290X card), and I highly suspect this is an issue of a new driver. My previous driver was 19.10.2 and it did not have such problem. Upgraded to 20.12.1 and here I am.

First, I'm 100% sure this is an AMD problem, and not some kind of Windows issue or whatever.

Second, I must note that I only see this color issue in non-exclusive fullscreen games. In other words, the issue is present in borderless fullscreen games, and only in Unity engine. I've tried a couple of other games that support Borderless mode and didn't see the issue.

I suggest you to check if your game is in Borderless mode. E.g. you can try switching in and out of it with Alt+Tab and see if there is any blinking happens. Also check out a huge list of games that support Borderless mode -

The latest game with this issue for me is - you can try the demo to see if you have this issue. That would mean there are at least two of us with this problem.

I'd really like this to be fixed somehow. There is this thread with a certain proposed workaround but sadly it won't work for me since I'm on Windows 8.1, and it doesn't have the "disable fullscreen optimization" compatibility option...

In the mean time I'll send a report using the AMD tool supplied with the driver.

Please let me know if you find some other solution, or if you find the exact driver version that started this bug.

Journeyman III

anyone know how to fix this

Journeyman III

I have the same problem also. I’m running a AMD A8-6410 APU with Radeon R5. If I attempt to play ATS or Roblox in fullscreen I get the inverted colors. If I take them out of full screen, the colors are fine in the game, but now inverted for the computer itself. In Minecraft, I don’t even have to deal with the problem. Any fixes? Updated the drivers, nothing new. 

Journeyman III

I got AMD RADEON R7 and still got this absurd problem..... I tried reporting but got nothin yet



Journeyman III

Are you running a Windows Insiders release?

I have the same issue on a Nvidia 1080, and it's due to me running this release.


i think i found a solution. try disable fullscreen optimizations and enable run this program as administrator. i think its not work on any game because i have test in roblox, etc. and i hope it works for you guys

Journeyman III

Hey, I had this exact problem. Looked for solutions everywhere. I got the idea from another forum where they talked about fixing the problem by reinstalling windows, updating windows, and then installing the video drivers. Turns out if you update windows after you install the drivers, then this error happens.

So how to fix it?

1. go into device manager

2. under display adapters, uninstall the drivers for your GPU(s)

3. in the uninstall window, make sure to select "delete the driver software for this device," otherwise windows will just reinstall it immediately

4. either install the drivers yourself, or let windows do it by restarting windows. I did that and opened my device manager, I don't know if that's necessary, but windows reinstalled the drivers and told me to restart my computer.

5. Presto, problem solved. Colours are back to normal in Two Point Hospital! Yay.


Hope that helps!

Journeyman III

So, my video card is Radeon R5 and the att after 20.11.1, try switching to this version.

Journeyman III

okay, 22.6.1, , and AMD A10 PRO-7800B R7 graphics. no problems on windows 10, but when i installed win11, cs2 colors become inverted. i cant run it in borderless mode (cmon, its cs2 on internal graphics)

Journeyman III


Short way:
1. Download this and run the version for your PC.
2. Problem solved.

Long way:
1. Install Autohotkey V1
2. Create a empty .ahk file, for example: "KeepColors.ahk"
3. Copy and Paste all of this Code:

#SingleInstance, Force

ShowText1() {
   static TextInst
   TextInst := TextInst ? "" : new SimpleText("", "Calibri", "s128 c0055AA q3", -1, 0, 180)

class SimpleText
   ; __New(text, font, fontOptions, x, y, trans := 255) {
   __New(text, font, fontOptions, x, y, trans := 255) {
      Gui, New, -Caption +ToolWindow +LastFound -DPIScale +AlwaysOnTop +hwndhGui +E0x20
      this.hwnd := hGui
      Gui, Margin, 0, 0
      Gui, Color, 123456
      WinSet, TransColor, 123456 %trans%
      Gui, Font, % fontOptions, % font
      Gui, Add, Text,, % text
      Gui, Show, NA x%x% y%y%
   __Delete() {
      Gui, % this.hwnd . ": Destroy"

4. Run the program "KeepColors.ahk".
5. Problem solved.

If for some reason it doesn't work, run it as Administrator.

You can create a shortcut and copy it to your startup folder (shell:startup) so that the program runs whenever you turn on your PC.


Can i ask what this does exactly ? cause it fixed a different problem i have, It fixed an issue with hdr games washing out color while in fullscreen on a buncha games.