Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Clean Install 19.2.2 BSOD

The title says it all. Updated to the new drivers, that had Metro Exodus support, with a clean install, and got a BSOD, a Kernel Security Check Failure one. After that, tried running the Windows´s driver check, and got stuck on a BSOD loop, meaning there *were* driver related issues. This made me reset the pc, keeping the files, but even that didnt work (Now having the IRQL_NOR_LESS_NOR_EQUAL). Trying a clean reset. It is the second time this happens to me, the last time being with 19.1.1.

22 Replies


I guess there is no more info I can give you, that relates to this. I have and RX570 Nitro+, overclocked and tested on 1400/8000 MHz, memory was memtested and passed, same with the CPU, who got stresstested and passed. 

Since I did a clean install, I wasnt able to roll back a driver, but I wasnt expecting it (the bsod) to happen, since I used AMD's own cleaning utility. I usually give it a week or two before updating to a new driver, but this time did it as soon as it came out, since it had Metro Exodus support.

Thats all there is to be told, I guess everytime I want to update my drivers I'll have to boot into safemode and DDU the previous one!


Did you read this?


Describe your system:

  • AMD Graphics Card
    • Make and model; e.g. AMD R9 290X
  • Desktop or Laptop System
    • If a laptop, make and model of the Laptop
  • Operating System
    • E.g. Windows 10 64bit
  • Driver version installed
    • E.g. Radeon Software Crimson Edition 15.12

Clean Install AMD Graphics Drivers 

-RX570 4gb Nitro+ overclocked to 1400/8000 MHz.

-Desktop, made by me and built by professionals, all tests made and everything was ok.

--Windows 10 Pro 64bit.

-Previously had 19.2.1, running ok. 19.2.2 cause bsod. ( Radeon Adrenaline )

Adept II

I had gotten a BSOD as well when I first installed 19.2.2 possibly due to the previous installed driver not being completely uninstalled. I solved it by downloading DDU and then going in safemode. Uninstalling the driver completely and let your system restart back in standard windows. Installing 19.2.2 again and everything worked flawless.


Exactly what I did, apart from it still not working and had to fully reset my PC. Guess those 600gigs of games and work werent meant to stay! 

But yes, I guess I'll have to boot into safemode everytime I want to update my drivers, apart from giving it One week or two after release to actually update it.


Never, ever put 600 GBs of games and/or applications on C:\...!  That is a huge no-no, and leads to problems exactly like yours.  Either partition your C:\ drive to add a suitably-sized D:\ partition for your games and apps, or else add a new hard drive for a D:\ partition and put all of your games and applications *there.*  That way--if you ever for any reason want to wipe C:\--for instance to restore a backup image of of your boot drive--you a) don't have to back up all of your games and apps just to back up your Windows partition, and b) won't lose all of your installed games and apps even if your C:\ partition  goes down for the count. 

I have ~8 TBs of drive space on 5 physical drives, and partitions C:\ through M:\, for instance.  It's also great when it comes time to back up your games and apps if you elect to do that, because with smaller partitions backups are *much* faster, too.  No one with lots of games and apps installed should be using giant C:\ drives where everything is commingled--just asking for problems at some point, that is.

Also, the reverse is true--should a game or an app crash hard enough to bring down the partition upon which it is installed with a write error--then your C:\ boot partition stays up and is unaffected.  With HDD space going for $50 a TB and less these days (I recently bought a 4TB HDD for $90, for instance--new) it is simply *bad policy* to cram everything into one giant C:\ partition!  Trust me--if you get into the habit of doing it right you will never go back to the giant C:\ drive.

BTW, no problems here with 19.2.2 and I run a RX-590/480 8GB Crossfire/Multi-GPU system. Running Win10x64, build 18334, version 1903.  If I had known how well X-fire (D3d9-11)/Multi-GPU (DX12 and beyond) works, I'd have done this far sooner!...;)



Yes, I know about the C: drive, and I do never put things that aren´t necessary on it.

Currently using a 128Gb SSD for Windows, and windows and other applications only. For games and work, mostly editing and creation software, I´ve got a 1TB hard drive, dedicated to it.

I don´t have the money to afford 5 physical drives or two GPU's, but I can handle myself!

Also, did a full reset, and on its way installed the latest recommended drivers for my GPU, 19.1.1 (which, funnily enough, were the ones that caused me troubles back then. As of now, haven´t had one error while on workload.

Adept III

That sounds like a cpu stability issue, becuase the 19 series makes cards run hotter and higher; its possible that its showing you a system issue others didnt.

Run prime 95 for an hour with Heaven benchmark on loop. 



Already did, and everything turns out right! The only thing my CPU doesn´t like is being overclocked, other than that, he runs gorgeously fine!

Adept III

I did a DDU uninstall since i popped in an RX 470 then RX 580 with the driver uninstaller.

Got weird artifacts when booting the drivers into windows; So did a full uninstall and it cleaned it up.
Used DDU x2 to purge traces, reinstalled 19.2.2 testing now, running heaven for 4+ hour benchmark to see. 

RX 580 -   61c @100%load and  1500 rpm fan. 

Will be testing more games and reporting back. 


Not surprised you are having issues if you think that pulling the card and running DDU is the right way to change out a card, it is not. Sometimes just pulling the card does work but often times it hoses the registry as you are now finding out. 

Have the driver you want to load already download, 19.2.2 is most current at the moment. 

Disable hibernation and fast startup. 

Disable Windows Update from auto updating drivers. Easy to do on Pro, harder to do on Home edition. Download Winaero Tweaker (winaero_com) and it has a simple check box to do this that works on either version.   

The proper way to pull the card is to uninstall the driver from the Control Panel / Programs

Then go to device manager choose the display adapter and choose uninstall.

Shut your machine down and now the card is ready to be physically uninstalled / pulled from the system.

Disconnect from the Internet unplug or disable wifi.

Restart your machine and install the current AMD Driver. Choose clean install if available. 

If it is not available then the uninstall already got everything that needs to be uninstalled. So proceed with the install.

If the machine comes up and is not running correctly, reboot it again. If things are still not correct. Don't uninstall the driver or run DDU, just simply express install the same driver over itself again. If it doesn't work at this point then you should should report the issue to AMD:

Online Service Request | AMD 

You should now repeat the above and install a previous driver that worked for you. If that also now doesn't work then your registry is corrupt or now have a hardware issue. Could be your GPU, Memory, Motherboard or CPU etc....

Good Luck!

It's hard to get the registry right again with hardware id's once you uninstall improperly and it gets messed up. 

I also want to add that running DDU is not an issue just in this case wasn't enough. It only deletes the GPU related drivers and settings and when pulling the card there is more that needs to be deleted. For instance if I have an issue upgrading a driver using the express install of the driver. I will run DDU then reinstall the driver. I don't then clean install the AMD driver as it deletes everything the AMD driver installed including settings and game profiles that DDU leaves untouched.

Journeyman III

Same problem IN THE GAME (wasn't clear that OP has problems in the game or in Windows?).

 Sapphire AMD Radeon RX 580 4GB NITRO+  with 19.2.2  (may have had same issues with previous driver - cannot remember).

Doesn't seem to be many people gaming with AMD (or perhaps Steam users are Nvidia fanboys?)

Anyway the RX580 seemed good value to me...   The general issues in Metro Exodus are :- (not THAT frequently, say every 30minutes...)


2. lockups with load audio fixed buzz.

These occiur mainly in cut scenes, but otherwise randomly.  Max temp as reported by the Watt app (or whatever its called) is 75degC.

Driver is a clean install.  Is this more likely to be my rig problem of game bug?  Cheers.


Your issues are that this game is running the GPU at 100% thus the card is Throttling. Two things cause issues. Not enough power ceiling and thermal throttling. 

You need to raise the Power Limit slider to max and set a custom fan profile to controll the throttling. Then set chill to about 72 max on that game. This should help a lot. See my RX 580 settings for reference:


Great  - will try this today (Monday UK) some time. Seems a lot of fiddling - poor default settings?  I'll try your advice first. (before complaining some more :-)

EDIT: thanks pokester - I see your reply about default settings. Very odd.  Anyway, I changed the settings but I'm staying on 19.1.1 for today - because it works. I have set max power to 50 (another strange upper value) and changed the fan profile.  I can now hear the fan.  In fact the game stutters (briefly) when the fan level changes.  I have no idea what "set chill to about 72 max on that game" but that may be a setting specific to 19.2.2 rather than 19.1.1 (which doesn't list the game. I'm sure it did when I started; nevermind).

Summary:-  19.1.1 is still working fine with Metro Exodus which I expect to finish today some time; then I will reinstsall 19.2.2.


default setting won't work at all on my RX 580 so IMHO "POOR DEFAULT SETTINGS" is the understatement of the year. The cards all worked before Wattman drivers came on the scene. Raising the Power Limit was always a thing you did to help stability but defaults at least worked. AMD does not acknowledge there is an issue yet it is the #1 piece of advice the users here give.

Adept I

I too had a BSOD after updating to 19.2.2. After reboot I then had a DLL corruption problem. I updated based on an email I received from AMD. After spending a couple of hours trying to find solutions, I decided to uninstall 19.2.2. Went on AMD and used auto detect for the correct version of software and it gave me 19.2.1. I install it and problems went away. I have a Ryzen 5 2400G using onboard graphics, I should have never received this email, it sent me on a wild goose chase.

Trying 19.1.1  (that was the last one before 19.2.2 as far as I can see). With my RX580 Metro Exodus has been fine for 30mins (but I'll give it a good fo later.)

EDIT: 19.1.1 appears to work; 19.2.2 appears to cause occassional BSODs, lockups (e.g. with sound stuck);  just playeed the entire desert area with no issue at all.

EDIT: started crashing again. BUT I notice the 19.2.2 driver has automatically installed. How did that happen?  Anyway, trying pokester's settings some time on Monday.


your issue is a classic sign that you don't have your power limit set at is't maximum. Should be set at 50. The setting is in Wattman below the fan settings. A red slider, slide it all the way to the right. Should fix this issue. 



With so many complaining it may be a bug, this not unusual as 19.2.2 is a beta driver. If you did not clean install the driver with the internet disconnected,  I recommend you do that. If it doesn't help revert to 19.2.1 many say it works, make sure to clean install that driver, always clean install when regressing drivers. 



Tell AMD:  Online Service Request | AMD 

Adept II

no 19.2.1 also not workin on MSI R7970 Lightning so we need a solution.