Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Chipset Install Failed

I've installed, uninstalled, reinstalled the AMD drivers half a dozen times now and I keep coming to this road block where the Radeon software goes through the whole process just to give me "Chipset Install Failed"... worse yet, the "show me details" link brings me to a "page not found" on the AMD site.

I've tried it several times. Used the microsoft uninstall tool to wipe everything AMD and start over beginning with the AMD chipset drivers (which install without error) only to get to Radeon for the whole thing to hit a wall. Updated all the bios in my MOBO again. Checked for windows updates. Same result.

Any idea what the problem is?



Ryzen 7-5800x

Radeon 5600 xt

ASUS Tuf Gaming B550M-Plus (Wifi)

Windows 10 64-Pro

32GB Ram



8 Replies

What is the open app behind amd installer ?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

ASUS TUF GAMING FEATUREASUS TUF GAMING FEATUREIt's some ASUS feature that I'm not familiar with yet. I didn't open it, it was somehow opened during the Radeon install.

BTW, I'm in this mess after changing my mobo and cpu and did a fresh install of windows - this 5600xt has plenty of flawless hours on it over the past couple years so I know what it can do - it installed to my last asus mobo no problem. This new one however is giving me a migrane.

ASUS z170 Pro Gaming -> ASUS B550M Tuf Gaming

Intel Core i5-6500 -> Ryzen 7-5800x


I'm really at a loss here. I'm open to reinstalling windows if that would fix it but **bleep**, this new MOBO is disappointing me


Where are you downloading the AMD chipset driver from

I updated to Chipset from the Tools  menu of Armoury Crate, no issues at all

AMD Ryzan 5 3600, Asus GeForce GTX 1650 Graphics (522.30), Asus Prime B550M-A LGA 1200 mATX Motherboard, (BIOS 2003) Cooler Master MWE White 230v 550W 80+ V2 Power,500GB SSD, 16GB DDR4 Ram, 2TB HDD, 32inch Phillips 1920 x 1080 Monitor, Samsung 28 inch 3840x2160 UHD 4K LED Monitor. Win 10 21Hl, Build 19043.11466

If this is a new build you may need to update your MOBO Bios this can often solve a lot of issues. Also if your running a VPN turn it off when downloading critical updates. I had similar problems updating my chipset on an MSI X370 MOBO and the VPN was severely throttling my download speeds and causing random files to not get downloaded when making critical updates. I've heard that a lot of third party software can cause issues like these. The ones I hear most about it Twitch and Discord and having your Antivirus sensitivity setting set to high rather than medium. Hope some of this advice helps you find a solution. 

You can also use Microsoft Install/Uninstaller Troubleshooting tool that has helped many Users at AMD Forum to successfully install the AMD CHIPSET drivers after continually failing: Microsoft Install/Uninstall Tool 

Run the MS Tool and delete all AMD Drivers that you see then afterwards try installing the CHIPSET drivers again. Make sure you have deleted the AMD CHIPSET installation folder at C:\AMD first to prevent any conflicts or corruption with the current Chipset installation.

elstaci i was trying to fix the issue for over a day with no positive result. your solution work first try!!! thank you sooooooo much man for posting that solution (MB asus X570 crosshair VIII Hero)

thank you so much that solved the issue for me too!

Thank you!!! Fianlly came across this, managed to install the Chipset drivers straight away. (TUF X470)