cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

blackkeys1098
Journeyman III

Chipset Install Failed?

Alright... so I just rebuilt my rig with a new motherboard and CPU and this problem ("chipset install failed") just won't stop happening

MOBO: ASUS B550M Plus

CPU: Ryzen 7 5800x

GPU: Radeon 5600 xt

RAM: Gskill 8gb x 4 (32 total)

OS: Windows 10

 

I installed the hardware and reinstalled windows 10. Ran all my AMD installers and eventually got to "chipset install failed".

RE-reinstalled windows 10. FULLY UPDATED WINDOWS 10; repeated the AMD driver install, same result.

Ran window uninstaller (MicrosoftProgram_Install_and_Uninstall.meta) and removed everything AMD.

After uninstalling all AMD drivers, off my external drive, I ran the chipset driver (amd_chipset_software_3.10.08.506) with success this time. Then proceeded to install the Radeon software driver (radeon-software-adrenalin-2020-21.12.1-minimalsetup-211202_web) and then ran into the same issue at the end: "chipset install failed"

 

Where is the hangup?

 

If you need any more specifics to my rig in order to answer, please ask!

0 Likes
0 Replies