Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Chipset driver no go

I've tried this with Widnows 11 but also wanted to try it now that I am back with WIndows 10.  I downloaded the latest AMD chipset driver for my MSI Meg X570 Ace motherboard, the one released 21/10/2021.  But when I run it I get as per the attached picture.  I tried searching for what they looking for but could not find it.


Any help would be greatly appreciated.


If my picture is not attached, let me state what is says.

"The feature you are trying to use is on a network resource that is unavailable"

"Click OK to tray again, or enter an alternate path to a folder containing the installation package "AMD_Chipset_driver.msi" in the box below"


But I search everywhere and without any luck.  Please help me.


6 Replies

When you tried to install the Chipset did you change the Default installation path?  That can cause that error I believe.

What was the error code (Number of error) that showed up?


Hi thanks for the reply.  Look when I install the driver I leave it to do what it usually does, which is why I was surprised to the same same happen even in Windows 10.  I am back on Win 11 and will try again now and see if there is some error code which I could not see, unless I need to check it somewhere else.


Oh and how do you add a picture to your post.  I am asking as I uploaded pics but it does not show.  Just tried it now in Windows 11, even found the file they specified but it would not continue to install.  Taken that I cannot show the image I will give a direct link to it uploaded.


Whenever I run the AMD CHIPSET package it creates a AMD Folder at C:\AMD automatically. 

See if you have a C:\AMD installation folder at your Root Directory.

To upload an image, Click on the Camera Icon above the Text Windows on the Task bar. Then click on "Choose Files". Then click on the image you want to upload by clicking on "open". Wait a few seconds then click on "Done".

Or you can drag the image to the Upload box. But the image to be uploaded can't be larger than 3MB otherwise it will be rejected as being too large.


Thank you Ill check as I saw the folder in root c:AMD but not sure what is in it.  Thank you.

Volunteer Moderator

Delete the AMD folder in the C drive and then try to install the chipset driver again