Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Cant set resolution to 1920x1080

So after updating Windows past an old build I was using (think it was 15xx) my monitor defaults to 1600x1200 for no apparent reason, when it's a 1080p monitor, nothing helped, not driver updates, not windows updates, nothing, I've read tons of posts regarding this issue and nothing seems to work. The only thing that DID kind of work was using a tool called custom resolution utility which DOES make windows see the resolution but it doesn't always work, it has also created tons of bugs, like when I turn on the computer it sometimes makes the drivers go into a reset-loop causing the screen to flicker on and off, the only remedy I have found was to restart the PC, after which it gets fixed. Some of the games don't even start up and cause the same restart loop again, the only fix to it being to tweak the launch options of the game to force into borderless windowed mode.
I've had this problem before but it was easily fixed by turning off EDID in the old Catalyst drivers.
Sadly, with the new crimson drivers that option seems to be gone or I can't find it.
I've already tried to reinstall drivers, I've even installed a fresh copy of windows and it still defaults to 1600x1200 with no way to change it without using 3rd party software (in this case CRU). I'd also like to add that the default custom res thing that comes with the drivers does not work and causes the same flickering as described in the post.  
About my PC:
It's a Philips monitor with only VGA in, so I have to use a DVI to VGA converter to connect it to my PC
GPU:Sapphire R9 270x
RAM:Kingston 4GB (1 stick)
MOBO:Biostar B85MG
Running Windows 10 Pro 1809

2 Replies

Are you using a "Active" or "Passive" DVI-VGA adapter?

If passive that could be the problem. "Active" Adapter convert the digital (DVI) signal into a analog VGA signal.

It's a passive adapter.
Thanks to your comment I also found another interesting thing, when I unplugged to check whether it was passive or active and replugged it in, The driver started to do the restart loop, again. Though the thing is it worked perfectly before the  Windows Anniversary update. I've also tried using linux to see if it makes a difference, and it somehow did, albeit with a few manipulations in the terminal but nothing too hard.