cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

mnm12
Adept I

Cant install driver 20.20 for Ubuntu 20.04

Hello, trying install latest driver for ubuntu 20.04 but getting:

Package amdgpu-hwe is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package amdgpu-pro-hwe is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'amdgpu-hwe' has no installation candidate
E: Package 'amdgpu-pro-hwe' has no installation candidate

Appreciate any help.

Greetings.

5 Replies
jlneill
Journeyman III

Re: Cant install driver 20.20 for Ubuntu 20.04

I have exactly the same issue with exactly the same output! I suspect that we are not the only ones either. I haven't a clue as to a work around.

mcginleyr1
Journeyman III

Re: Cant install driver 20.20 for Ubuntu 20.04

I have the same issue.  I tried ripping out all the HWE kernels and packages and still got it.  I got it with less output by installing all the HWE stuff.  

jlneill
Journeyman III

Re: Cant install driver 20.20 for Ubuntu 20.04

I have now got it to work.

1). Run the following command <sudo apt list --installed *\hwe\*>

The output should look something like this:-

jlneill@orac002:~$ sudo apt list --installed *\hwe\*
[sudo] password for jlneill:
Listing... Done
linux-generic-hwe-18.04/focal-updates,focal-security,now 5.4.0.37.40 amd64 [installed,automatic]
linux-signed-generic-hwe-18.04/now 5.3.0.28.96 amd64 [installed,local]
xserver-xorg-core-hwe-18.04/focal,now 3:14.5 amd64 [installed]
xserver-xorg-hwe-18.04/focal,now 3:14.5 amd64 [installed]
xserver-xorg-video-all-hwe-18.04/focal,now 3:14.5 amd64 [installed]
xserver-xorg-video-amdgpu-hwe-18.04/focal,now 3:14.5 amd64 [installed]
xserver-xorg-video-ati-hwe-18.04/focal,now 3:14.5 amd64 [installed]
xserver-xorg-video-fbdev-hwe-18.04/focal,now 3:14.5 amd64 [installed]
xserver-xorg-video-qxl-hwe-18.04/focal,now 3:14.5 amd64 [installed]
xserver-xorg-video-vesa-hwe-18.04/focal,now 3:14.5 amd64 [installed]
jlneill@orac002:~$

Notice that there are NO packages with 20.04!

2). Now delve into the < amdgpu-pro-20.20-1089974-ubuntu-20.04 > directory and run ls -ial and NOTE the following two lines:-

1080541468 -rwxr-xr-x 1 jlneill neill 10849 Jun 15 15:42 amdgpu-install

1080534783 lrwxrwxrwx 1 jlneill neill 14 Jun 10 02:01 amdgpu-pro-install -> amdgpu-install

3). Now open up amdgpu-install in any text editor and you should see this:-

set -e
shopt -s nullglob

REPOSITORY="/var/opt/amdgpu-pro-local"

BASE_PACKAGE=amdgpu-core
META_PACKAGE=amdgpu
META_LIB_PACKAGE=amdgpu-lib
METAHWE_PACKAGE=amdgpu-hwe
METAHWE_LIB_PACKAGE=amdgpu-lib-hwe
DKMS_PACKAGE=amdgpu-dkms
VERSION_REQUIRED=false
VERSIONLIST_PACKAGE=amdgpu-pin
VERSIONLIST_PRO_PACKAGE=amdgpu-pro-pin
OPENGL_META_PACKAGE=amdgpu-pro
OPENGLHWE_META_PACKAGE=amdgpu-pro-hwe
OPENCL_LEGACY_META_PACKAGES=(clinfo-amdgpu-pro opencl-orca-amdgpu-pro-icd)
OPENCL_PAL_META_PACKAGES=(clinfo-amdgpu-pro opencl-amdgpu-pro-icd)
VULKAN_META_PACKAGE=vulkan-amdgpu-pro
LIB32_META_PACKAGE=amdgpu-lib32
LIB32_OPENGL_META_PACKAGE=amdgpu-pro-lib32
LIB32_VULKAN_META_PACKAGE=vulkan-amdgpu-pro:i386
PX_PACKAGE=xserver-xorg-video-modesetting-amdgpu-pro

Put a # at the beginning of the lines which have got -hwe in them; there a re three such lines.

eg: METAHWE_LIB_PACKAGE=amdgpu-lib-hwe becomes

      #METAHWE_LIB_PACKAGE=amdgpu-lib-hwe

Now save that file.

4). Now run the uninstall script if you have not already done so and try the installation again and it should work like a charm!!!

mcginleyr1
Journeyman III

Re: Cant install driver 20.20 for Ubuntu 20.04

Doesn't work for me.  Wonder if the "Packages" file is why. hmm

0 Likes
rm1567
Journeyman III

Re: Cant install driver 20.20 for Ubuntu 20.04

same problem

0 Likes