cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

arronlee1994
Journeyman III

Cannot open Ryzen Master

Just got a new prebuilt DELL Inspiron 5676 with Ryzen 7 2700X.

Everything was running fine, until I installed Ryzen Master. 

Whenever I open Ryzen Master, a new blank window pops up (not responding), as if the system is trying to open Ryzen Master, but it freezes for about 15 seconds (just the Ryzen Master window, not the system), and the window shuts off afterward. No matter how many times I tried, Ryzen Master just won't open. (I have the latest windows updates/drivers/BIOS etc).

One weird thing I noticed: whenever I tried to open Ryzen Master, one of the cores (or the 1st core)  hit 100% utilization for that 15 seconds. 

What is going on here? Am I having a defective CPU?

Any help is greatly appreciated, thanks! 

Tags (2)
3 Replies
benman2785
Big Boss

Re: Cannot open Ryzen Master

sounds like your MoBo is not compatible with "on-the-fly" bios changes

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes
elstaci
MVP

Re: Cannot open Ryzen Master

A while back there was an issue identical to what you are describing concerning Ryzen Master.

This User opened a thread concerning the 2700 Processor but received no answers: issue on launching ryzen master 

This is similar to yours concerning a 2600 processor: Ryzen Master dont work.  Try billy72 suggestion and see if it works.

Another one similar to your but no answer with a 2600x processor: Ryzen Master crashes instantly after start 

This was the AMD Thread I was looking for with the almost similar issue as you have but with a 2700x Processor: https://community.amd.com/message/2891214?commentID=2891214#comment-2891214 

I would open a AMD Online Service request and let them know there is a bug with Ryzen Master and 2nd generation Processor from here: Online Service Request | AMD 

nicks504
Journeyman III

Re: Cannot open Ryzen Master

You need to roll back your version to AMD Ryzen Master 1.4.0.0728 , I had the same issue but now it works fine. 

0 Likes