cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

pom
Adept I

Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

Hello!

When I launch installer it tells me that Im running on not supported OS, and it requires 10.14 + but in the specifications is written that it should work on High Sierra. Is It possible to run prorender 2.2 on high Sierra ?

Thanks for answer !

1 Solution

Accepted Solutions
pom
Adept I

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

Thank You for your answer !

Finally I managed it on my own. I run installation right from package, not from installer and it seems to work !

View solution in original post

12 Replies
hardcoregames_
Big Boss

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

OS X Catalina is the current version. Apple users are as bad as Windows users for not updating their OS.

0 Likes
pokester
MVP

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

So why are you bashing an OP for using a still supported Mac OS. Many macs can only run up to High Sierra. Plus on the Apple side of things it really isn't prudent to be an early adopter. In many cases by the time 3rd party software is optimized to work with the new OS, the next OS is coming out. Apple does not give access before release to developers in the same way Windows does. The OP could have a lot of reasons to still be on High Sierra and it will be supported for one more year as Apple supports the last 3 OS versions at a time. 

Sorry OP that I can't answer your question on 2.2 asI could not find the specs.  I would ask it in an Apple Forum too. 

The specs for current pro render are as follows and High Sierra is supported:

Software

  • Blender® 2.80 and 2.81 (experimental builds not supported) for Microsoft Windows®, macOS®, and Linux®
  • Microsoft Windows® 7, 10 64-bit
  • Microsoft Windows® 10 64-bit (non-AMD GPU)
  • macOS® High Sierra 10.13.3 and up (10.13.4 required for external GPU support)
  • Linux® distributions: Ubuntu® 16.04.3 and 18.04.0
0 Likes
pom
Adept I

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

I'm using my Mac for work, and I want to be able run all my programs right. Features like dark mode or end of openCL acceleration in new Mojave or Catalina really doesn't satisfy me. So that is the reason why I will stay with High Sierra. 

pom
Adept I

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

Thank You for your answer !

Finally I managed it on my own. I run installation right from package, not from installer and it seems to work !

View solution in original post

hardcoregames_
Big Boss

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

I am on the Apple forum a lot. I own a MacBook, 2 iPads, 7 iPhones and more.

OS X Catalina is the current OS and if the machine can run High Sierra then Catalina will run on it

0 Likes
hardcoregames_
Big Boss

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

unless you have some 32-bit dinosaur, catalina wants all apps to 64-bit

also make sure you have some security tool installed as mac machines get hit occasionally

0 Likes
pokester
MVP

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

No you can't load Catalina on any Mac that would run High Sierra. Frankly it is a very uniformed comment that would steer an OP completely wrong. You could not be more wrong. You literally can Google compatibility on these and find out you are wrong in about 30 seconds. Now I didn't have to as I already knew this. I have used Macs in a production environment for over 30 years. 

macOS Catalina is compatible with these computers - Apple Support 

How to upgrade to macOS High Sierra - Apple Support 

Depending on model Catalina dropped support for 2 years to 5 years of Macs that OS X Sierra supported. 

Now the comment on 32 bit dinosaurs is frankly ill informed too as motion artists, graphic artists etc. are still using apps and plugins with 32 bit code. Because of how Apple releases there software it takes time to get that code re-written. So again often it is 6 months to a year before 3rd party developers catch up with the new operating system. And again Apple does not drop support for the prior 2 OS versions when the release a new 3rd one. So nobody is doing something wrong for using a system that not only works but at that point is likely more bug free and fully works with the 3rd party apps. 

Stop treating people like they are stupid for using what they use. We are here to help others not belittle them and worse give misinformation. 

0 Likes
pokester
MVP

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

You are very welcome. Not sure if not being able to install from the installer has anything to do with native security settings. OSX by default does not let you run software that is not from the apple store or from unidentified developers. So a lot of software from open source developers does not have the paid for security certificates so you have to change the security settings to allow for unidentified sources to run and also enter a terminal command. It is different from version of OSX to another as to how to do this so just Google your version and you will get the information to do this. 

0 Likes
hardcoregames_
Big Boss

Re: Cannot install radeon pro render 2.2 on High Sierra 10.13.6.

Jump to solution

pokester wrote:

You are very welcome. Not sure if not being able to install from the installer has anything to do with native security settings. OSX by default does not let you run software that is not from the apple store or from unidentified developers. So a lot of software from open source developers does not have the paid for security certificates so you have to change the security settings to allow for unidentified sources to run and also enter a terminal command. It is different from version of OSX to another as to how to do this so just Google your version and you will get the information to do this. 

I have several downloaded programs on my MacBook which runs OS X Catalina. They all work fine.

Blender is not an exotic package but I am very adamant about being fully patched for all updates. OS X recently was patched which too my machine over 20 minutes to install, which mean the updates were extensive.

0 Likes