Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

can't upgrade primary

Hello everyone i'm having an harsh problem.

at the current time my card specs are:

Video Card

Video card: (Linked) AMD Radeon R5 M230 Series

Chipset: AMD Radeon Graphics Processor (0x6665)
Dedicated Memory: 2.0 GB
Total Memory: 2.0 GB
Pixel Shader Version: 5.0
Vertex Shader Version: 5.0
Hardware T & L: Yes
Vendor ID: 1002
Device: 6665
Plug and Play ID: VEN_1002&DEV_6665&SUBSYS_F9271179&REV_00
Driver Version:

Video Card:(Primary) AMD Radeon(TM) R5 Graphics


Chipset: AMD Radeon(TM) R5 Graphics

Dedicated Memory: 3.0 GB

Total Memory: 8.0 GB

Pixel Shader Version: 5.0

Vertex Shader Version: 5.0

Hardware T & L: Yes

Vendor ID: 1002

Device: 9851

Plug and Play ID: VEN_1002&DEV_9851&SUBSYS_F9291179&REV_05

Driver Version: 13.352.1004.1018
As you can see my primary card is outdated, still in version 13. But no matter what i try to do i can't upgrade it.
i tried downloading the last version from here Radeon Software Crimson ReLive Edition 17.7.1 Release Notes And then tried to check for updates from the software but didn't work.
I tried uninstalling and downloading this one first AMD Radeon Software Crimson Edition 16.2.1 Beta for Non GCN Products Release Notes and checking for updates but still didn't work. i tried a bunch of sets like this, uninstalling one, installing other, checking for updates etc but every time my versions continue the same.
And the last time i tried uninstalling and installing the software gave me this error Error 1603 – A General Error Has Occurred During the Installation of the AMD Software Package

I dont know what to do anymore i'd appreciate a lot if someone knew and could help me with this bloody problem. i'll leave an image of my AMD folder, dont know if it helps or has any problem.

AMD folder.png

1 Reply
Volunteer Moderator
Volunteer Moderator

Re: can't upgrade primary