Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Can't open Radeon Settings



Win10 Pro 64bit


Dual monitor

Acer XR341CK, Display port, 3440x1440, 75hz

XF270HU, Display port, 2560x1440, 144hz

ASRock, Z170M Pro4S

Intel Core i5 6600K

Corsair 500W

16GB ram

Computer is running fine, but for some reason I can't open the radeon settings in the system tray. You know, the thing that lets me access specific settings for different games or wattman. I did a full uninstall with DDU and AMD's own driver uninstaller and installed the latest driver from the site but it's still not working.

When the computer starts up, I can see the Radeon Settings tray icon and can right click it but if I try to select Open settings, it just disappears. If I try to go to the start menu and open Radeon settings it creates the tray icon and same thing, I can't double click on it or right click, it just disappears.

I've attached a little video of what I'm talking about. In the video, I go to start menu and open the file AMD Radeon Settings to make the tray icon appear but I can't do anything beyond that.

I don't actually get any errors by the way. It doesn't say application has stopped running or anything like that. It just disappears.

10 Replies
Journeyman III

Try going to C:\Program Files\AMD\CCC2\Install and running ccc2_install.exe

There seems to be a problem with the Radeon Setup program.

Thanks for the advice but that didn't work for me.

When I go to C:\Program Files\AMD

I have a few folders, CIM, CNext, Performance Profile Client, WVR

In the CIM folder, I do see a folder Config, and in there there's a file ccc2_install.xml(not exe)

Under C:\Program Files (x86)\AMD

There's a folder CNext > CCCSlim

There's a CCC.exe and CCCInstall.exe but neither seems to do anything.


If you still have the driver files in local disk C/ AMD, try using the ccc2 file,

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

You might report this issue to AMD > AMD Issue Reporting Form 

Thanks for the suggestion. I'll give that a shot as well.

Journeyman III

Hello, im from Argentina (sorry for my bad english) i have the same problem and i try all.. last windows update, last amd drivers with clean instalation, and installing the "ccc2_install" i cant found it in: 

C:\Program Files\AMD\CCC2\Install and running ccc2_install.exe 

but i search in my disk C and i found one cc2 and i install it but nothing happens... the graphis card works fine i think...


This is my pc :

Sapphire Amd Radeon Rx580 Nitro 4gb Pcie Rx 580
Fuente Thermaltake Smart 600W 80 Plus White
Procesador Intel Core i3 8100 3.6 GHZ LGA 1151 Coffe Lake
Mother Gigabyte B360M DS3H LGA 1151 8va GEN
Monitor Philips 24" VGA HDMI DVI-D 1ms
Memoria GeiL DDR4 8GB 2400MHz EVO Potenza Black

I have had sporadic issues with the Radeon Settings not working after driver installs for years. I had it happen to me on when I installed the 19.1.1 driver on one of my 4 computers with AMD gpus just a few weeks back. What has worked for me is to just install the same driver again over the itself (don't uninstall the other or use ddu or clean install) using the express install this time and that has usually fixed missing and non-starting Radeon Settings issues for me. You all certainly could have a different issue going on. If so I would probably report this on directly to AMD and ask them for their help:  Online Service Request | AMD 

Adept I

Ok guys, i had the same problem (nothing happens when i try to open Radeon Settings) and reinstalling the driver suite (using DDU first) did not help me. Then, after a lot of google searches, i solved my problem. I don't exactly remember at which site i found, thus, i can't give credit (sorry for that). I'll share my solution here hoping to help others. I'll explain as simple as i can.

(This solution may work if you are using an intel CPU with CPU graphics enabled alongside your main AMD GPU)


Step 1: Open Windows Task Manager (right click on the clock and click on Task Manager). Switch to "performance" tab. Here, you can see real time performance graphics for your hardware like HDD, Network, GPU etc. Do you see your intel on-board GPU here? Is it seen/identified as GPU 0 or GPU 1 by Windows? If your intel CPU graphics is seen as GPU 0, this solution may not be for you (but you can still try it cause it doesn't involve anything potentially harmful for your system)


As i understand it, If your intel CPU graphics is listed as GPU 1, this is the problem. Supposedly Radeon Settings tries to communicate with GPU 1 and it doesn't work because it's an intel on-board GPU. This may be a Windows fault too, i don't know. 

Step 2: Now the solution is pretty simple. You need to first uninstall (in my case it's a HD 4600), download and install the latest drivers for your on-board GPU.

To download most recent drivers (if you know this you can skip this paragraph): Go to intel web site, navigate to "drivers&software" page (direct link: Drivers & Software ) and from there you click on "Graphics Drivers" link and at the next page you only need to select your CPU family (ie 4th Gen), download type (you need drivers), your OS version.

You should install (as admin) the suitable and most recent driver package. 

Step 3: After installation is completed, restart your PC. In my case i didn't need to do anything else after restarting and my Radeon Settings worked flawlessly. I didn't need to re-install Radeon Settings either. And now Windows sees my on-board graphics as GPU 0 (as it should be).

I'll share this solution in similar forum posts.

Sorry for my poor English. I hope this solution works for you. 

Adept I

Guys i Have found a solution if this problem occurs on a PC running an Intel GPU alongside your AMD card, in my case a laptop and also if your Intel GPU shows as GPU 0 in task manager:

1- Uninstall AMD driver with DDU (Safe mode recommended)
2-After restart i downloaded and installed the latest driver of my AMD card
3-When i tried opening AMD radeon settings it didn't open so
4-i updated my intel graphics card from device manager and the AMD settings opened successfully
5-restart and enjoy
Thanks and i hope my solution helps others

This is how it is supposed to be done, however the Intel driver should be updated first.

These AMD instructions linked to in the pinned topics under the forum headers explain this: