Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Can't open AMD Radeon Settings...

cnext-error.pngEvery time I try to open AMD Radeon Settings I get the error message in the image above and I have no idea how to fix it or how this happened, it use to work just fine then all-of-a-sudden this started happening. I have already tried doing a clean install of the driver software to no avail, the error still occurs. The version of the Radeon software that I had installed when this started happening was Radeon Software Adrenalin Edition 18.5.1, so then I downloaded version 18.9.3 Optional and did a clean install but the error persists.

I just don't know what to do next or how to fix this. Has anyone else encountered this error and/or know of a fix?

Any help would be greatly appreciated. In case this info is needed:

OS: Windows 10 Pro (64-bit) | Version 1803 | Build 17134.320​

GPU: AMD Radeon R9 200 Series | Sapphire Radeon Dual-X R9 280 3GB



Problem seems to have been resolved, had to boot into safe mode then used the AMD Clean Up Utility and reboot again out of safe mode then install the Radeon Software as normal and now it works. I was under the impression that a clean install did all of this for you but apparently I was wrong...

Message was edited by: Kenneth Persad

0 Replies