Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Can't install chipset drivers

I have a Gigabyte X570 Gaming X mainboard, which, as the name implies, has the X570 chipset. The CPU is a Ryzen 5 3600X. I'm running Windows 10 Pro 22H2.

I always used to keep the latest chipset drivers installed, but starting with the chipset version before the current, I have had persistent installation failures. I just tried with the newest version,, and again, it failed.

The log shows "Installation success or error status: 1603" which is extremely vague.

Things I have tried:

  • Uninstalling the chipset drivers using the native uninstaller.
  • Manually deleting all \AMD directories.
  • Re-downloading the drivers.
  • Running the oft-recommended DISM / SFC commands.
  • Doing an in-place upgrade of Windows 10.
  • Installing with Microsoft Defender disabled (the only AV I'm using).

Nothing has helped so far.

Could the installation failure really be caused by the fact that my Documents, Pictures, etc. directories point to non-defaults, as some websites claim?

The driver package I'm trying to install is the "AMD Chipset Drivers" listed under "Windows 10 - 64-Bit Edition" here:

9 Replies

I opened a support ticket with AMD for this. They ended up telling me to do a clean install of Windows 10.

What a joke.



At the end you have the option to view the install log and install summary, at least I did when I installed the driver package on my b650E based system. I would presume the same option would be present for the AM4 version of the drivers. So I would look in those reports to see if it identifies the underlying issue. 



I reviewed the log until I was blue in the face, but nothing therein clearly referred to what the problem was. I also sent AMD "support" the log (even though they didn't even ask for it).

It's just low-effort development on their part to fail and not say why. I don't see why installing drivers should be so difficult.


Hi, I have exactly the same issue, did you have a solution now ?


Unfortunately I never found a solution. AMD simply advised me to do a clean install of Windows, as I mentioned above. A repair install of Windows may also work, but I haven't tried that as yet.


In the past when Users had issues installing AMD CHIPSET I would suggest for them to use Microsoft Install/Uninstall Utility. Afterwards they were able to install the chipset package, at least most of them were able to: Microsoft Install/Uninstall Tool 

When you run MS Install/Uninstall Utility delete all AMD Non-Graphics drivers and then run the AMD CHIPSET package again. See if it installs successfully.

You can also use the Utility to uninstall the AMD Chipset package or install it.


I had tried the Microsoft "Show or hide updates" troubleshooter package, and it didn't work for me. Thanks anyway. Maybe it will work for Hil.


My link is not for the "Show or Hide Updates" it is for "Install/Uninstall" software that have issues installing or uninstalling from Windows.

"Show or Hide Updates" Tool is prevent a Windows Update from being installed on your PC.


Right, of course. I'm aware. I misspoke because had just used the "Show or Hide Updates" troubleshooter for a separate Windows 10 issue.

I had indeed tried the "Install/Uninstall" troubleshooter, and it didn't help. I had also separately tried (after restoring a system image) the NirSoft UninstallView utility, which does the same thing (simply finds hidden uninstall entries in the registry and runs them).

Thanks and sorry for the confusion!