cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

timis101
Journeyman III

Can't get AMD Radeon software running properly (RX 5700 XT)

Recently I factory reset my Windows 10 64-bit machine and ever since I can't get the AMD Radeon software to run properly. Originally after downloading the software the first time it worked fine. It wasn't until I updated the software that I started having issues. While attempting to update the software the update crashed, canceling the update. After the cancelled update I could no longer run the software so I uninstalled and reinstalled. But when reinstalling(using the same download I used to install originally) a windows warning message popped up saying that windows couldn't verify the publisher. Weird. So I went to AMD's website and redownloaded it. Ran the installer and same windows error message popped up. Seeing as I downloaded straight from AMD's website I ran the installer anyways. System works for about a day. Next day my computer crashes a couple times. So I decide I'll try reinstalling again. I redownload straight from AMD's website, now having 3 identical install files in my downloads, uninstall the software and install it again. Windows no longer shows the unknown publisher message and reads as publisher Advanced Micro Devices Inc. Weird again. Once again everything seems fine. Fast forward to the next day(today) and when I powered up my computer I get a message reading:   RadeonSoftware.exe - Application Error The application was unable to start correctly (0xc0000142) Click OK to close the application. I will be uninstalling and reinstalling(AGAIN) today.   Is this an issue others are familiar with? Any help would be greatly appreciated as I'm getting a bit annoyed having to reinstall something that worked fine for years before I factory reset my PC.

0 Likes