cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

ANTI_666_LXIX
Journeyman III

Can't do anything with AMD software, windows error "device not functioning"

Hi everyone, I'm posting here out of desperation so any help or advice is appreciated.

I own an RX 570, I've had it for a few years. A few weeks ago, I started having graphical issues- textures in games would be warped and smeared, webpages would have random pixels in different colors, icons within Discord app came up smeared and altered, and some games just wouldn't start up. I tried to update my drivers, but using the updater app, the update only went halfway and then ended, and ever since then, any time I try to run any of these apps for AMD stuff, Windows 10 gives me an error that reads simply "A device attached to the system is not functioning." This happens if I try to run the AMD cleanup utility, as well.

So, I tried buying a new GPU. I bought the Radeon RX 6650 XT, and installed it in computer. It seems to have cleaned up the weird graphical issues, but I'm still getting the same "A device attached to the system is not functioning" error and cannot update drivers, or use any AMD software on my computer.

Windows device manager doesn't recognize the GPU, instead listing "Microsoft Basic Display Adapter" under Display Adapters.

I'm assuming it was a GPU issue which is why I bought a new one, but my computer is still malfunctioning and giving me these issues. Is there something else I can try? Is this not a GPU issue? I can't seem to find anything on the internet about the "device not functioning" error in conjunction with the AMD software stuff.

Please help!!!!

0 Likes
6 Replies
ANTI_666_LXIX
Journeyman III

ANTI_666_LXIX_0-1658618924868.png

this is what I get when I try to run the AMD cleanup utility, or the auto downloader, or other things like a benchmark utility.

0 Likes

System specs?

0 Likes

 

Windows 10, Ryzen 5 2600, 16GB ram. First Radeon RX 570 and now Radeon RX 6650 XT. ASRock B450M pro4 motherboard

0 Likes
Vynski
Exemplar

Sounds more like a motherboard problem with the error your getting.


Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"
0 Likes

Could it have something to do with the App. folder location (onedrive) ?, try downloading new versions to the recommended save location and clean install from there.

 

 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
0 Likes

Since having made this thread, I realized that I get the error anytime I try to do anything with administrative permissions, so I'm currently reinstalling Windows to see if this solves the issue, but if not, I think it might indeed be a motherboard issue

0 Likes