Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Can't access Radeon setting for 18.2.3 & 18.3.1.

I did a clean install for each even using AMD clean up utility. I get the error message "Radeon Settings version and Driver version do not match. Please try again after updating to the latest version". I have to roll back to 18.2.1 to access my settings.

7 Replies

Download the full set of AMD Driver set from AMD Support.

Use Windows Uninstall feature to uninstall the AMD Software and driver. Download and use DDU in safe mode to completely erase all traces of the current AMD driver and software. Delete C:\AMD folder in the Root Directory. Disconnected the Internet from the computer to prevent Windows Update from installing a different Driver before you start your installation. Reboot

Install the AMD full set of Driver and software and reconnect the Internet and see if it works correctly.

Hello, I tried what you said and it didn't work. It still says the same error. "Radeon Settings and Driver version do not match". this is with 18.3.1. I have to roll back again 18.2.1.



Sorry it's:

  • AMD Graphics Card
    • MSI 480 RX 8GB
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Windows 7 64bit
  • Driver version installed
    • Radeon Software Adrenalin Edition 18.3.1 but Rolling back to 18.2.1.
  • Display Devices
    • LGTV 42LM620T-ZE 1080p
  • Motherboard + Bios Revision
    • Asus  p8z77-v pro, Bios Version 2104
    • Intel i5-3570K @3.40GHz
  • Power Supply Unit  Make, Model & Wattage
    • Corsair AX1200 Professional Series Gold
  • RAM
    • Corsair Vengeance 16GB
Adept I

Alright it's working. I had to restart again. I installed it, it restarted and the error came up, but i thought to just restart again and that fixed it.


so finally what you really did? as far I have the same situation and all adjustments give this info:SHU_1Y1Moa.jpg

and I could only from within packages uninstall control centre (Radeon Settings) and report generation centre which was placed separately in this folder together with uninstall SHU_YMjnmr.jpg

I am completely lost.

All is on windows 7

Windows reports this version of driver  23.20.15027.2002 so it is 18.3.2.

I got that error, couldn't access the Radeon settings no matter how many times I clicked. So I just restarted and it worked. I followed elstaci instructions at the top. I also couldn't access the settings in the start menu.