Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

BSOD installing drivers on KVM guest

I'm trying to install modern Radeon drivers on the guest. I'm currently trying 19.4.2, but have tried back through mid-2018 drivers. Install progresses to 33%, hangs, and then BSODs with a PAGE_FAULT_IN_NONPAGED_AREA. Drivers from Windows Update work fine, but are pretty old and seem to be lacking Vulkan support (, dated 4/24/17).  Event viewer says:

The computer has rebooted from a bugcheck.  The bugcheck was: 0x00000050 (0xfffff8020000000e, 0x0000000000000010, 0xfffff8020000000e, 0x0000000000000002). A dump was saved in: C:\WINDOWS\MEMORY.DMP. Report Id: aac0ab2d-f025-4f16-9e15-079560d86e43.

Here's the backtrace from the above dump, so pdbs so no function names for the driver:

 # Child-SP          RetAddr           Call Site
00 ffffe08c`35d513f8 fffff802`6b0608db nt!KeBugCheckEx
01 ffffe08c`35d51400 fffff802`6aed13d7 nt!MiSystemFault+0x1302ab
02 ffffe08c`35d51540 fffff802`6afca183 nt!MmAccessFault+0x327
03 ffffe08c`35d516e0 fffff801`0000000e nt!KiPageFault+0x343
04 ffffe08c`35d51870 ffffb80d`0dcf0dc0 0xfffff801`0000000e
05 ffffe08c`35d51878 ffffe08c`35d51d90 0xffffb80d`0dcf0dc0
06 ffffe08c`35d51880 00000000`00000003 0xffffe08c`35d51d90
07 ffffe08c`35d51888 00000000`00000000 0x3

Hardware: Intel i7-2600, Gigabyte Z68MA-D2H-B3, Radeon R9 280X

Host: Fedora 29, up to date

Guest: Windows 10 Home, fresh install with all stable updates

libvirt XML:

I have the following module option set:

options kvm ignore_msrs=1 options vfio-pci ids=1002:6798,1787:3001,1002:aaa0,1787:aaa0 disable_vga=1

I also have dracut configured to load early so that the radeon/amdgpu drivers do not get loaded before vfio-pci. I confirmed this with lspci output. intel_iommu is enabled in the kernel arguments, no scary errors in dmesg.

Things I've tried:

- disable_vga argument on vfio-pci

- adding video ROM

- i440fx chipset with SeaBIOS (totally different VM)

- connecting GPU via ioh3420

- updating virtio drivers (originally on 0.1.141)

- Remove QXL adapter

- Move to a dual core, single thread CPU

- DDU between each attempt

However all of these result in the same exact behavior.

Any pointers or success stories would be appreciated. I'm happy to give any other information needed.

6 Replies

This website give instructions on how to install KVM using Fedora 29: 

Here is another website giving instructions on installing KVM using Fedora 29: Fedora 29: Install KVM for virtualization - Narrow Escape 

also: Fedora 29 : KVM : Install : Server World  and from a Fedora Website concerning KVM: Getting started with virtualization :: Fedora Docs Site 

Possible one of the steps in the above links might solve your problem.

I went to AMD Download page and all the different type of Linux drivers are all from 2015:AMD Radeon™ R9 280X Drivers & Support | AMD 

Not sure which one is compatible with Fedora 29.

Found this Fedora Website that has AMD Driver for Fedora 29: xorg-x11-drv-amdgpu-18.1.0-1.fc29.x86_64.rpm Fedora 29 Download 

See if this AMD download helps. Cant verify whether it is a safe download or not, but none of my Web security add-on indicates it is an Unsafe website.


I'm not looking for a Linux driver. This is using Windows drivers on a KVM guest.


Thanks. None of them really dive into VFIO specifically.

Journeyman III

The key was hiding KVM and setting a bogus hypervisor id.

This is strongly reminiscent of NVidia's attempts of preventing passthough, although they are nice enough just to refuse to load the driver and log a vague error code instead of putting the guest into a boot loop. This is a major reason I don't buy NVidia hardware.

AMD: What the hell?


did you solve this issue? If yes - I would like to know how because i have same issue