Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

BSOD Erros - The current system does not support the cpu FX 8120

I have this PC:

Motherboard Gigabyte GA-78LMT-S2

Processor AMD FX-8120


NVIDIA GeForce 210

Windows 10 64 bits (clean and updated installation).

I am having random error blue screens, the event visor shows "Performance power management features on processor are disabled due to a firmware problem. Check with the computer manufacturer for updated firmware."

On windows boot I get a message "The current system does not support the cpu. If you wish to continue, the cpu will be underclocked to maintain system stability".

I changed the power source for a new one, upgraded from BIOS F4 to the last one (F6) in gygabyte site, updated all possible drivers and the problem remains.

Can it be something about the AHCI mode ? (which I have disabled)

...speedstep ? (which it is not in AMD BIOS)

...processor speed ? (automatic to 7X, reaching a max of 60°C)

...compatibility issues between motherboard, processor, graphics, SSD and Windows 10 or 64 bits?

Thanks a lot for your time !!

Message was edited by: Matt B

We have updated the title of this discussion with relevant details to better describe your issue.

15 Replies
Big Boss

AHCI mode is probably needed for your SSD to boot properly

dont install the Win10 "Spectre-fix" pls
are the latest Chipset-Driver installed?

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

- I have read AHCI give better performance for SSD but I'm not sure if my blue screens and resets are linked to it, I'm letting it as last option because I would have to reinstall windows and everything :S

- Thanks for the advice ^^

- I can't install last chipset driver, it says "it's not compatible with my OS"

Thanks for your reply


mh - maybe try this

GA-78LMT-S2 (rev. 1.0) | Motherboard - GIGABYTE Global

also check your board revision

and then driver - chipset

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

Thanks for the reply

My board is rev1.0,

Yes, I tried everything there, 

I can't install chipset driver, it says "it's not compatible with my OS",

so I installed drivers from other websites and DriverMax software (I will not do this again)

Everything seems right but as they don't have windows 10 support in gigabyte site that must be the problem :S


The only drivers they have for your MoBo is for Windows 8.1 or earlier. In BIOS make sure everything to do with the CPU is on default or Auto.

Did your MoBo drivers for Windows 8.1 or earlier install properly?  Before you upgraded to Windows 10, Did you have this problem?

Also what is the make and model of your PSU?

Thanks for your reply

- In Gigabyte website they don't have support for my MoBo in windows 10, but they have @BIOS utility, that's how I updated my BIOS to the last version.

- I checked BIOS and everything is in "default" or "auto"

- I can't install Gigabyte-web drivers or use Gigabyte utility for checking drivers because my OS "is not supported", but I updated SSD firmware from ADATA website, graphics driver from NVIDIA website, I also used "DriverMax" software to check and update other drivers, everything seems right

- I was getting exactly the same errors and blue screen in Windows 8.1 64 bits, same SSD, clean installation but it was another MoBo

- My Power Supply is an EDGE Systems Blazar AF-B500P, 115V 60H 6A/230V 50H 3A


FYI: Using DriverMax type software is very risky. The program many times installs drivers that are not compatible with the hardware on your computer. There was a thread  earlier by a Computer Repair Tech that was complaining about people bringing in their computers for repairs after using a Driver Downloader in the past and installing the wrong drivers causing the computer to malfunction.

I am not saying that all those so called driver updaters are bad news, but I haven't seen one that isn't yet. I constantly track new malware infestations back to unsuspecting users thinking they will fix things. Remember if it pops up on you computer and you didn't look for it, and it says it will help, it will probably do the opposite. Drivers should only be obtained from the maker, builder or know trustworthy download repositories.

For me, the best driver downloader are those that the manufacturers make to download and update their own drivers like Intel's Driver Support and Assists or HP Update. It just downloads and updates all Intel or HP drivers on a computer.

I did try DriverMax, but found most of the drivers it suggested were made for a particular hardware unrelated to the hardware I was trying to update the drivers to. So, I uninstalled DriverMax and stopped using those type of Driver Downloaders and Updaters. For some inexperienced Users, they may unknowingly install a different Manufacturer's driver using DriverMax or similar software and the next thing you know the computer starts having BSODs.

Thanks !! I tried to make it easy but that's not the way...

I will take your advices, I will not use automatic sofware it again, unless trust and official, not third party :/


Pokester has a point. Need to figure out if the problem you are having is Hardware or Software.

Here an interesting link about your MoBo and CPU from about a year ago: Gigabyte GA-78LMT-S2 underclocking my processor FX 8350 - [Solved] - Motherboards

The CPU you are using even though it is supported, mentions that your MoBo CPU Supported Wattage is 95 watts while as your CPU has a rating of 125 watts. Which is why the CPU is being underclocked by the MoBo. I would contact Gigabyte and find out if this is actually the case which would explain all the error messages and would also verify the above link's comment about your MoBo.

Here is your MoBo (revision 1.1) CPU Support (Same as Revisions 1.0) Revision 1.2 doesn't list your CPU:

CPU Support
Socket AM3+ - AMD 760G

N/A = Not support

Socket AM3+
VendorCPU ModelFrequencyL2
The L3 the
Core NameProcessSteppingWattageSystem
Bus (MT / s)
Since BIOS Version
Here is your CPU SPECS from AMD Support:


# of CPU Cores


# of Threads


Base Clock


Max Boost Clock


Total L1 Cache


Total L2 Cache


Total L3 Cache







AM3 +

PCI Express Version


Default TDP / TDP


Max Time


Not part of this page:

What is interesting is that on the CPU Support page it shows the much older CPU's with a higher Wattage but for all FX series CPU's it shows a Maximum Wattage of 95.

I don't know if all the information and the comment in the above mentioned link are true about the MoBo underclocking CPUs with higher wattage than is indicated in the CPU Support page. That is why I suggested you Contact Gigabyte about it.

Thanks for your time,

It's interesting how board manages power, gigabyte has a power security feature for this board so components would not be burned, this would surely explains the "underclock" issue, and maybe the BSOD because they are mostly related to "cpu power", though, with this feature, windows should work fine with the "underclocked cpu", not showing Blue Screens and restarts, maybe 64 bits need the full cpu, maybe the 120W, IDK.

It's weird because I have 2 years with same board, cpu and windows 10 and no problems until last november, so I'm thinking it also can be hardware damage issues (or some windows patch maybe?)

As you suggested, I sent some questions to Gigabyte support, and hopefully they will solve at least hardware compatibility issues, I will be feeding back any new,

Thank you bro !!


It's certainly not impossible that it's something Windows did with the Fall Creators Update. Update is a bit of a misnomer, because these are not really little updates. They are in fact complete operating system replacements, just still operating under the name Windows 10. Some of the updates they have done with Windows 10 have been at minimum like Service Pack updates of old and the 2 last creators updates have been more like a complete Windows upgrade, more like going from say Windows 7 to 10. So absolutely some major headaches and growing pains are happening. Many people have found with these updates that Windows installs wrong drivers, or no longer even supports components they have. I really think MS is doing a poor job communicating this to end users and hardware manufacturers alike.

I think first I would try to figure out if you have a hardware or software issue here.

How are things running from safe mode? Do you get that same error?

If so are you noticing anything odd or dysfunctional entering your bios/efi. Or is everything normal there?

Do you have the latest bios for your motherboard?

If those things are fine then maybe somehow Windows mismatched the chipset driver or something is corrupted there?

You could even download an ubuntu.iso and burn it to dvd or bootable usb and try running that. If the hardware is really working fine and it's software related you will know for sure if that runs fine. It's pretty quick and easy to try. You can run it right from the usb or dvd, you don't have to install it.

If you are not too vested in your current build of Windows 10 you could also just reinstall Windows. You could do a really clean install by downloading the latest .iso and installing it from DVD or USB. Download Windows 10    that link has all the info to make a standalone installer. Don't worry about activation, if you are already activated now, they already have your hardware id.

You definitely have an odd one going on, please report back if fixed or not and what you had to do. Someone might be better help here or you might just help the next guy!

Good luck!

I have around 2 years with this pc, windows 10 64 bits

The first BS came in half november, old HDD, still not actual SSD,

by that time I installed the Nvdia card, I will disable it now to check if BS still comes

I will try safe mode

Everything seems normal in BIOS, I will try thermal grease in processor because I'm getting 60+°C when max supported for is 60°

I have the latest BIOS, got it from Gigabyte @BIOS utility (even when the website says they don't have support for windows 10)

"somehow Windows mismatched the chipset driver or something is corrupted there" is very possible,

I can't install gigabyte chipset driver because it says it doesn't support my OS

I will try ubuntu after safe mode, it doesn't seems as difficult as I thought

I have a lot of software and set up needed for my work, so is's a mess reinstalling everything again,

but I will do it if I don't find the problem, only installing trust drivers this time

BUT, I'm not sure wheter stay with windows 10 or going back to 8.1 to avoid compatibility issues

Thank you very much for your time and your help, I will be feeding back any news