Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


BSOD during 20.11.2 and 20.12.1 install RX5500XT

Win 10 x64 20H2, Gigabyte X570 UD mobo, Assus RX5500XT graphics card. CPU AMD Ryzen 5 3600XT 3.8 GHz.

I have been runing this PC for 2 months using the 20.9.1 drivers without problem but when I attempted to update (after uninstalling in safe mode with DDU) to 20.12.1 during the installation (at 95%+ Audio Driver section) the system crashed with a WHEA "Uncorrectable Error" BSOD, restart failed and it went into repair mode and eventually rebooted but Radeon Settings would not open, I re-installed 20.9.1 without problem but on shutting the PC down it displayed the BSOD screen again with a permanent 0% and then restarted, the only way to shutdown was using the power switch. I restored the system from backup which fixed the shutdown problem and then uninstalled 20.9.1 with DDU and then re-installed 20.9.1  with absolutely no problem, tried the same with 20.11.2 and again got the WHEA BSOD and repair on restart problem etc, same as with 20.12.1. Also tried just updating without using DDU to uninstall 20.9.1 but same results. Also needed to restore from backup or restore point to get back a working system.

Hoping someone here knows what is going on and how to fix it?

1 Solution

I finally got the replacement mobo the Assus TUF x570 Gaming Plus, it came with bios 1407 installed which supports the CPU so have not updated it. The XMP profile 1 option correctly identified the DRAM speed and timings (3200) 16 18 18 35 1.35V in my case so left it at that and all is working well. I use a CPU fan with RGB which looks good with the Assus much more colourful than the Gigabyte mobo so no plans to turn it off although Aura utility which allows me to change the colour and speed etc adds little or nothing to the default mode.

The only negative is the basic audio, with the Gigabyte mobo if headphones were plugged into the front panel jack it would set up a 2nd output so you could switch between headphones and the speakers connected to the rear jack, with the Assus it just switches off the rear speakers until the headphones are unplugged, very minor issue though.

View solution in original post

45 Replies

Best guess is that it is going to take a new bios to fix it. 

There are about a hundred threads already on this topic in this forum.

Search for them and you can try some of the things some say helps.

All with this issue need to report it to AMD. They won't see the issue here.

You can contact AMD support here:

Also report problem to your motherboard manufacturer. They will have the greatest influence in getting AMD to fix their microcode. 

Also report this on the AMD Reddit thread and in tech site forums. This needs to get fixed and it is going to take noise from outside of this forum to gain real traction.

I am sorry for your problems, these issues should not exist. 



I would be really grateful if you would point me to some of those like posts with possible fixes  you mentioned because I can't seem to find anything.

For sure BSODs and install problems, but nothing specific to the recent releases and a hard BSOD at the end of the install. As mentioned before 20.9.1 works perfectly and can still be installed, I also know 20.11.2 works on another PC with an RX 570  so it looks to be specific to my config. I will be raising a ticket with AMD but would like to explore any other options in parallel.


I also experience BSOD with bizarre behaviors with the Driver 20.11.2 (WHQL) and 20.12.1 Optional (WHQL).
It first gave me an irql_not_less_or_equal or something like that. And sometimes the computer completely frozed while the HDD lamp was constantly on. After that I've re-installed 20.9.1 and it works good so far since it was released.
So there have to be something wrong with the new Drivers.

I'm using Windows 7 x64, Radeon HD 7000 Series.

Thanks for the link but unfortunately despite wading through a lot of those pages I did not find anything quite like the problem I am having. For sure plenty of WHEA BSODs when gaming or from last year or Win 7 but a hard OS killing failure at the end of a new driver install, every time, no.

I have raised a ticket with AMD and Gigabyte (mobo) and I will post here with any results. I havealso tried a number of other things without changing the problem, 20.10.1 also works and is currently running without problems but 20.11.2 and later still fail on install every time.

Having the exact same problem here, trying to install the recommended or optional drivers for a new 6800 installed into a MSI B350.

I'm not sure the older drivers will work with my card, so I'm desperately trying to find a solution.

Let me know if you find anything.


After a lot of exploratory testing, I have finally been able to install drivers for my 6800.  Given your problem seems remarkably similar to mine, here are the steps I took to get my system working.

Step 1
Download driver Adrenalin 2020 Edition 20.11.2 Recommended (WHQL) from the AMD site (  You should have a file called radeon-software-adrenalin-2020-20.11.2-win10-64bit-nov18.exe.

Step 2
Use 7zip (or similar tool) to extract the contents of the downloaded .exe file into a new folder.  This will allow us to customise our installation.

Step 3
Open up file InstallManifest.json in a text editor (e.g. Notepad).  This should be located in the Config folder of the extracted content from step 2.

Step 4  
Delete lines 1241 through to 2887 (inclusive).  This will limit the installation package solely to the AMD display driver and avoid the noise of installing anything else.

For example, the Packages section of the file should start as follows:

   "Packages" : {
      "Package" : [
            "Info" : {
               "Description" : "Display driver for Windows 10",
               "DrivePackageInffile" : "C0361132.INF",
               "FriendProductUpgradeGUID" : [

and end as...

                  "HWExclude" : [],
                  "OSCheck" : [
               "Order" : "37",
               "pAlgo" : "",
               "pRetryAlgo" : ""

Step 5
Delete the comma (,) character on line 1240.  This is no longer required as you removed the subsequent packages in step 4.




Step 6
Save and close the InstallManifest.json file following your changes.


Step 7
Open up file C0361132.inf in a text editor (e.g. Notepad).  This should be located in the Packages\Drivers\Display\WT6A_INF folder of the extracted content from step 2.

Step 8
Delete lines 3035* and 3036* from the file.  They originally would hold the content:

CopyINF = .\amdxe\amdxe.inf
CopyINF = .\amdfendr\amdfendr.inf

*If you are trying to follow these steps and run a graphics card other than 5500 XT, you will need to find the lines that are relevant for your particular model.  Deleting these lines will only impact the installation of Navi14 models.

Step 9
Save and close the C0361132.inf file following your changes.

Step 10
Run the Setup.exe located in the root of the extracted content from step 2.  This will use the perform the driver installation with the modified steps, hopefully with the bonus of not throwing a BSOD.


At this stage your installed display driver should be the November release.  After that, I would recommend performing any Windows and chipset driver updates.  From then on, I think you should be able to run the unmodified driver install (including December's optional release) without issue.

Obviously this approach is only recommended if you absolutely need to be on the later drivers, are 100% comfortable following the steps above and have the necessary back-ups in place from which to recover from.

Note: I accept no responsibility or accountability if anything goes wrong whilst attempting any of the above.  The risk is entirely yours to take.  The information is only provided to help demonstrate the steps I went through to get a working install.

Let me know if you have any questions.

Alternatively you could follow what appears to be a much simpler solution here:

I haven't tried it myself, but probably worth giving that a go first.



Thanks very much for both your replies, at this point I would be very reluctant to mess around with the under-clocking fix before I get anything back from my AMD ticket,  different CPU and maybe mobo anyway.

I don't really need to update at this point but may give your moded driver package fix a try later.:smileyhappy:

Many thanks again



I have received a response to the ticket I raised with AMD, basically clear mobo bios cmos reload defaults and try again. Also similar from Gigabyte and suggesting a bios downgrade, after carefully following both instructions there was no change 20.11.2 and 20.12.1 still give the WHEA BSODs and blow away the OS.

I subsequently did further trouble shooting including changing the system disk from a NVMe SSD to a Sata connected SSD and also a fresh basic Win 10 install but still no change. I was able to install and use 20.10.1 but everything later failed as before.

I reported all this back on both tickets, Gigabyte suggested trying their very latest bios F31q which I have flashed and is working but I have not tried with 20.12.1 yet.

AMD responded with the suggestion I stick with 20.10.1 and await a new version, which I hope means they now know there is a problem with 20.11/12 and a fix is on the way.


mh, as you use a GigaByte MoBo (and they suck in BIOS coding since 300er) - disable XMP and check again ;)

also: maybe do a fresh Win10 insall - helps wonders some times

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

Thanks for that!

I have always to date had excellent experience with Gigabyte mobos and disabling the XMP was one of the first things I did along with clearing the CMOS running on "optimised defaults", clean boot etc and much more as detailed in my previous post along with trying it with a fresh Win 10 basic install. Still crashes though.



"AMD responded with the suggestion I stick with 20.10.1 and await a new version, which I hope means they now know there is a problem with 20.11/12 and a fix is on the way."


Latest- My ticket with AMD was closed despite my request to keep it open, at least until I could confirm or deny a fix in the next driver version.

Not impressed, no acknowledgement that a problem exists, useless troubleshooting suggestions and they did not even request crash data etc. Seems like it was a waste of time!




"I reported all this back on both tickets, Gigabyte suggested trying their very latest bios F31q which I have flashed and is working but I have not tried with 20.12.1 yet."


Latest- This ticket remains open after I confirmed that I was still getting the same problem with bios F31q and 20.12.1.


BTW I attempted to provide feedback on the closure of the AMD ticket, which I was not satisfied with but the link they provided for that does not work!!!!!!!:smileyfrustrated:


Exactly the same problem with 21.1.1 driver.

When I run OCCT Mem or OCT test it reboots after about 2 mins with XMP Profile 1 or 10 mins with XMP disabled, the Event log shows an Error,  WHEA Logger and "Cache Hierarchy Error" every time at the time of the reboot. All other OCCT tests run OK.

I have tried a different set of memory but still the same problem and I temporarily tried a known working RX 460 GPU but that too had a WHEA BSOD at the end of the21.1.1  driver install and screwed the OS requiring a restore from backup to correct.

I have also flashed the latest bios first F32 now F33a but no change. The support ticket with Gigabyte has been updated with the latest info and remains open. Don't think I will bother raising a new ticket with AMD.

Any suggestions on what to try next gratefully received.


I used to had the same issues like you, and this helped :


Taskforce found a way around it, but you gotta follow the steps carefully.

If you get stuck or doesnt work I personally posted my experience and way out of troubles in the comments, I am Tonic1979 there.


This worked, now I got a BSOD every once a week or 2 if I put too much work on my rx 5500.


This is a problem with all AMD GPU from the line 5000, and its sstupid, they keep fixing the new ones but not this ones. I'm about to switch to NVIDIA if they don't fix it this year.


Many thanks for that but unfortunately it was no help, I was able to follow all the steps but even with the "Factory Reset" the install of the driver bombed out with the usual WHEA BSOD and blew the OS away requiring a restore from backup which leaves me again with the older driver.

Please note everyone the problem I am having is NOT an intermittent WHEA BSOD, I (know that seems to be a common problem) but I have an absolute rock solid one that happens every time I attempt an install of any drivers after 20.10.1, regardless of whether I use DDU, AMD cleanup, Factory Reset or just an update and it results in corrupting Win 10 and forcing it to go into repair mode on reboot. On the odd occasion when the repair succeeds it looks like the driver has installed OK, according to the "Device Manager, but "Radeon Settings won't  start which means I can't switch to full RGB etc.

With the 20.10.1 driver installed I am not seeing any problems in my normal usage which includes some light gaming. It is not clear to me if the errors I found during troubleshooting  with OCCT testing are related to my basic problem or not but  given they are reported by the WHEA logger, maybe. Replacing the memory and GPU has not changed the problem, which pretty much just leaves the CPU, Mobo and PSU. The OCCT Power test runs without problem and the 21.1.1 install with the replacement RX 460 also failed in the same way although its power requirement is much lower than the RX 5500XT so I am less suspicious of the PSU but any help on how I can identify what is faulty here would be most welcome.



Having run out of other ideas I finally got round to trying out your suggestions for modifying the driver package. The modifications seemed to work OK but still got the WHEA BSOD during the driver install.

Any other ideas?


Can't believe no one posted my accepted solution from months back on this. You had stability with the 20.9.1(2) driver, so simply run that one or my fix was to install the 20.8.3 using DDU in safe mode first. Since you have the 5500, this fix was for the RX 5600 XT and RX 5700 XT, the rest of it shouldn't matter. Run the older driver that worked since there's nothing new in these newer driver packages for the 5000 series cards that are EOL (End Of Life). The drivers from after 20.8.3 were leaning toward the new 6000 series cards and AMD has put no new fixes in that pertain to the 5000 series since. The best part is, you can use the entire driver package, no eliminating components!

"It worked before you broke it!"

"It worked before you broke it!"


Sorry but your reply is really not helpful! I built this PC recently using relatively current tech, high end and not inexpensive components and yes I could stay with the older working driver but what will happen in say 12 months time when I maybe try to upgrade the GPU only to find that the underlying problem I have with the CPU/Mobo or config. means none of the drivers supporting the new graphics card work and guess what no more warranty?

I need to get this fixed now while it is still possible to get an RMA on any faulty items.

The driver has nothing to do with your warranty. In 12 months you want to upgrade the GPU to a 6000 series then you use the newer 12.2.1 or newer driver meant for that card. You must always remove the old drivers using DDU or the built in AMD tool first prior to installing a new driver as well. I've been building PC's for over 20 years and ran a business doing so. 98% AMD builds, so you can take my advice or think you know what you're doing. If you had an underlying CPU/mobo config issue there are tests for that. Your particular issue clears up using an older driver which is exactly the fix for that problem on this very forum that many have used with total success.

But I'll leave you confused and not making any sense at all. My build is an AsRock X570 Phantom Gaming 4S, 16GB TeamForce Extreeme Gaming DDR4 3733 (custom timed/sub-timed to match the CPU/IF @ 3600/1800 CL 16), AMD Ryzen 3600X (PBO=enabled,10X scalar, motherboard voltage, 1.10 SOC), Gigabyte WindForce Radeon RX 6800 Gaming OC, Creative Labs Sound Blaster Z(optically passed to a Yamaha RX-V371 A/V to 5.1 and a 400W sub), Seagate Compute 1TB SSD, Corsair H110i, Corsair RM 750x, Alienware AW510K keyboard, Corsair Harpoon RGB Pro mouse, Sceptre 32" 1800R/185Hz 1080p monitor via DP.  Hopefully, "high-end" enough and costly as well for you.TimeSpy RX 6800 best 1_13_2021.png

The only recent addition is the GPU. Prior it had a Gigabyte RX 5600 XT with the new 14Gbps BIOS and I ran the 20.8.3 driver to solve your very same issue. But what do I know?

"It worked before you broke it!"

Well I am very pleased to say I have finally made some progress.

After reducing the config. down to basics, (removed a PCIe TV tuner and PCIe Firewire interface) I was able to install driver 20.11.2 and to confirm then 21.1.1 (as normal I used DDU in safe mode to uninstall first).  Both drivers installs struggled a bit though, on reaching the "Time Remaining" of 10 secs and counting down the countdown reset back to 10 secs several times. This would typically be the time when it would BSOD but without the 2 PCIe cards it seemed to recover the install completed OK.  Radeon Settings runs as normal and the system is working fine with the latest driver, even after reinstalling the 2 PCIE cards (both of which work OK). On a further attempt  to install 21.1.1 with the 2 cards  reinstalled it again failed with a BSOD before the driver install completed and also corrupted the OS.

The improvement after removing the 2 PCIe cards suggests to me a power issue but according to 2 PSU configurators I have run I need around 380W and I have a Kolink Enclave 600W. Could it be faulty?




It's never good to run on the razor's edge for a PSU. Yes, it could be defective. Kolink Enclave Series 700 W Review - Value & Conclusion | TechPowerUp

That's for the 700W version but they're all made the same by Kolink in the Enclave series. I usually double what any configurator says in total W, meaning a 750w is ideal for you. This way if something spikes or there's tons of "ripple" the system stays stable or if I want a future upgrade, I don't need a new PSU.

From these recent symptoms it looks like a defective CPU or motherboard but as you said with the older driver things worked fine. So I'll say it again go back to the older driver, it has absolutely nothing to do with warranty. Also, if you upgrade to a newer card, you need still need to reinstall the driver or you will have problems. The driver installs per specific card at the time of install. Meaning if you later get a RX 6800 XT, yes it uses the same driver, no you can't just expect it to work of the current driver installed. That's not how things work. Will it show an image and "appear" to work? Yep. Will it "black screen" or have other problems? You bet, until you reinstall the driver so it meshes with the currently installed card.

"It worked before you broke it!"

Thanks for that, I have ordered a new 750W Thermaltake PSU (I have had good experience with them in the past)  in the hope that it will fix the problem but like you I fear it may well be the CPU or mobo, which will be a real pain in the neck. I will post again when I know.

I have now gone back to 20.9.1 which works OK for email, browsing and light gaming (as did 21.1.1 once I got it installed) but,  as mentioned in an earlier post, since OCCT mem test also fails with it I believe it will only be a matter of time before I see the same failures in regular usage as I ramp it up  to include some heavy video editing and rendering.

I don't believe there is anything inherently wrong with my RX 5500XT and the 20.11.2 and above drivers (AMD recommended), it is just something on my PC, bearing in mind I had the same problem with the install using an old RX 460. The same RX 460 is normally installed on an older AM3 FX 8350 based PC where it runs fine with the 20.11.2 driver.



Woah, you said the memory fails in OCCT? Then that's system RAM, meaning you have either a bad stick, slot or board. If you're failing OCCT in any way, it should list what is not working. That test will show a CPU fault, RAM, GPU, etc. error if it finds one. That's where your issue will lie as well. 

You can't compare a Polaris card with a NAVI or a Ryzen to an FX CPU and you certainly can't say the driver works based on it working on older equipment. The RX 460 uses a different driver in the package. AMD puts the newest legacy drivers in these packages for compatibility. AMD "software recommended" only, no AMD representative called you or replied on here specifically stating to use that driver. In fact, there are other posts with staff recommending to use the prior driver, just search it out. There's a few.

"It worked before you broke it!"

Thanks again for your response but you need to read some of my earlier posts on this thread with respect to the failures with OCCT. In short the PC  reboots while running  OCCT mem and OCCT tests Event log shows WHEA logger reported "Cache Hierarchy Error" Event ID 18, OCCT itself reports no errors. I have tried replacing the memory with a set from a different manufacturer (also on the mobo approved list) but the failure was unchanged.

The support ticket I raised (8201035900) with AMD on this problem specifically recommended using the next available driver 21.1.1 and was closed on that basis, also reported in posts on this thread.

I still have an open ticket with Gigabyte on this problem and they too have recommended trying a different PSU which has now been delivered and I will be installing it over the weekend.


I read back and you never mentioned error 18, which is a processor failure error. I had a wicked time trying to fix it on my 3600X system. It turned out to be the IF being set to auto in the BIOS was part of the cause. Before that me running DDR4 3733 at the advertised speed and setting the IF to 1867, since I had no 1866 option caused it as well. I settled for reducing my RAM speed to 3600 and the IF manually set to 1800 and that cured the issue. Since I had to use my DDR4 3733 RAM kit, I used DRAM Calc to get the basic timings/sub-timings and an equation to lower my Trfc to 288 and I've been fine. I had one error 18 since and it was in late November but it turned out to be a Windows Update issue that Microsoft fixed within a day or so.

Others that get the error 18 and have your issues, while not using higher speed RAM, and have tried setting the IF manually to half the RAM speed, needed to RMA the CPU. I see you have the 3600XT and that is one that I've seen RMA'ed in other posts for this very reason. I am surprised that if you told AMD that you had error 18 they did not tell you to RMA the CPU but instead told you to upgrade the GPU driver. 

Sometimes setting the IF manually seems to fix the issue. I can't say for sure it would in every case. I think the CPU "breaks in" over time and the IF wears into a certain spec that it runs well at. So that's why this happens over time rather than out of the box. RMA'ing the CPU seems to fix it all the time. Knowing you're getting error 18, I'd say that PSU won't fix it but sending the CPU in under warranty will or trying the manual IF setting might sort it out. 

AMD tech support will always give you some generic answer like "try the latest driver" and close your case. I find reporting anything to them mostly useless unless it's a very specific driver related error. Error 18 is CPU. Why does it occur with the new driver? Who knows. That was the "trigger"? In any case you'll need to sort out the CPU issue.

"It worked before you broke it!"

Thanks again

The problem was that I was never able to see the event ID 18 error following the attempt to update the driver, I got the WHEA bsod but since it screwed up the OS and I usually had to do a restore from backup to recover I therefore lost all the event logs for the crash. It was only later when running OCCT was suggested on the Gigabyte support ticket which resulted in a reboot but did not blow away the OS that I was able to view the event logs for the failure. AMD had already closed the ticket by then so they were not informed of that info.

I will install the new PSU anyway (I think I can still get an RMA on the old one) and if necessary give the reduced IF a try, my DDR4 memory is 3200 what would you suggest I change the settings to?


3200=1600 IF. "IF" is always half the RAM for 1:1 operation, which is optimal. The "auto" function should apply that but it doesn't firmly hold it to that frequency, which may cause the problem. However, if you're running stock, even with things like PBO on but not using the "+200" option or extended voltage, this error should not happen. You might be looking at RMA on the CPU. Obvious last things to check out would be CPU temp and cooler mount. If all that's ok, no RAM failure via testing to 800% coverage, longer testing is better to be sure, then the CPU is at fault. 

"It worked before you broke it!"


Things getting weirder.

I have replaced the PSU and downloaded the latest version of OCCT and now OCCT runs all tests for long periods, over 12 hours on one run, CPU temp got up to the mid 80s deg.C but no higher.

The WHEA BSOD crash with OS corruption when trying to install graphics driver version 20.11.2 and above (including 21.2.2) remains.

Currently Asus recommend using 20.12.1 for my graphics card and furthermore following a suggestion from Gigabyte in response to the open support ticket,  I again tried a fresh install of Win 10 but during the setup phase the screen flashed and resized followed by a WHEA BSOD so it looks like MS are now using one of the latest drivers as the basic default. I can't believe that with all my hardware being still on sale and current that I can't use the latest driver package or do a fresh install of Win 10 without problems! I have little doubt that there is a problem on my CPU or motherboard that is aggravated by the new drivers rather that the PC hardware not being supported by the new drivers and I think I will request an MRA for both.


Go back to the older drivers that worked, end of story, end of issue. Nothing is new in the driver for your EOL (End Of Life) card. They put "legacy" drivers in for convenience and those might be unstable. In this case, they are. Stop trying to force a square peg through a round hole. Sure, they still sell them. Thousands were made and of the RX 5500 XT, not many were sold. The RX 5600 XT with 2GB less VRAM destroys it and then the RX 5700 XT dominates it.

RMA it all and start over, rinse, wash, repeat, definition of insanity. Trying the same thing over and over again expecting a different result. Ignoring sound advice from people with 20+ year experience building PC's, mostly AMD. Favoring generic responses from tech support form the vendor or even AMD's tech support over sage advice from people who really care and aren't reading answers from a book made for shutting people up.  

Why do you bother posting her if you simply refuse to do what works and run back to the vendor and AMD support to receive their generic responses? The forum was made for users/builders to help others with problems, since we use these products daily in the "real world", where funky problems arise. Good luck.

Someone else chime in here, I'm done following this post.

"It worked before you broke it!"

Quote:- @mackbolan777  "Someone else chime in here, I'm done following this post."

Well at least that is some progress perhaps someone else can give a more logical and less condescending response.

FYI I too have been building PCs for nearly 20 years and was a service engineer for mainframes before that. In all my experience I have never before encountered a situation where I am not able to install Windows on functional hardware that is supported  but that is where I am now. 

Ergo the hardware is not functional!

First, I wasn't "condescending", I putting the facts out there that I have advised you to the best of my personal experience that the driver you're trying to use is NOT going to work for your card. Forget about the "why". Why do you assume that AMD support or any large company support is going to give you the correct advice when I know they read a flow chart out of a book and that's what they must stick to. It doesn't mean it's right or it will fix your issue, because when their book advice fails, the next step is to close your case or issue an RMA. Then you go round and round, definition of insanity.

Second, all the PC's you built in 20 years, what brand were they for the most part? My guess is Intel, because you wouldn't be here asking questions. AMD is an enigma, nothing is "cut and dry" with them. Why do you think out of the major parts manufacturer's, AMD is the ONLY one with a consumer supported forum to handle problems that, really they should? Because they are an "enigma", every system is different to some extent, even if you use the exact same parts, the CPU/GPU is where things go one way or the other.

Third and last, you worked on "mainframes", those never used AMD CPU's, maybe a Cyrix or PPC but usually Intel. You're comparing apples to carrots, that's how different those systems are. In all the Fortune 500 companies I serviced or built anything for, they used Intel based hardware. Only recently and very rare do you find an AMD platform in a server rack. They also didn't use Windows for the most part. The "end points" did but not the server end. "Mainframes", and PC's are again apples to carrots. One uses EEC RAM, multiple PSU's, multiple CPU's on one board, RAID drive systems, possibly tape drives, SCSI's, a huge rats nest of Ethernet cables and usually no display or very basic that you connect only for service. The other is a single CPU, dedicated GPU, DDR4 RAM(modern build), a single SSD, possibly an AIO cooler, one PSU, and possibly an optical drive, running windows 10 of some variety.  

In your case Windows installs fine, it's the hardware not liking a driver and you refuse to accept the advice we give and intend to argue with us until the, who knows? Others will probably respond and tell you to use this driver or that, they same one I told you to use or other methods that will run you in circles. Even moving to a RX 5700 XT won't solve this issue. Just to test a possibility that I'm dead on with the driver, install an Nvidia anything in that and the problem will go away. Not saying that's the answer, but it will prove my point.

"It worked before you broke it!"


"In your case Windows installs fine"

That is simply not the case! When I now attempt a fresh install of Win 10 during the final set up phase it automatically loads the default graphics driver (screen flashes and resizes) and straight away crashes with a WHEA BSOD and the install aborts and won't restart! This is new it did not happen on the initial Win 10 install back in Oct 2020 and a couple of subsequent installs, so I assume MS are now using a version of the current WHQL 12.10.1 driver, which we know is a problem on my setup. The only way I can currently install Win 10 is to disconnect from the internet then manually install the older driver from storage once the install has finished but then I am left with setting up the network and activating everything manually which is a pain in the neck. It is certainly not what I expect from recently purchased current hardware. Do you regard that as "fine"?

You may well be right in saying the RX 5500XT is EOL but do you really think a 60000 series GPU will work with my hardware and the latest driver even assuming it is in my price range which it is not. I have never liked Nvidia GPUs and if you have ever tried to get one to play 3D you probably know why and without having done much research I don't think they have a PCIe 4 card in the price range of the RX 5500XT, if there is let me know I might consider it.

You are also wrong with your guess about my experience with AMD other than a couple very early on I have always used AMD CPUs and GPUs. I am not new here either and I am well aware of the failings of AMD support, the ticket on this issues was closed ages ago, without a fix, which was no surprise there but I was following the advice from @pokester  (see page 1) that both AMD and Gigabyte should be made aware of the problem. The Gigabyte ticket is still running and most likely coming to the end probably I think suggesting I rma the mobo and or CPU back to the retailer.

The PC is currently up and running with the older driver and I have no urgent need to change that but I will not give up on looking for a solution, sorry but I am just not a "don't fix it if it ain't broke" person, I like keeping things up to date.

In citing my work on mainframes I was merely pointing out that my technical experience is not just as a hobby builder.


See this is why I said to make a fresh post. When one jumps in to an old post for too long, things that are mission critical get lost, like the fact Windows does not install fine and the very issues you describe. This is beyond any driver at this point and with the experience you have, you should know something hardware isn't working or the Windows Media is possible corrupt.

It could be simple as the monitor or cable to it. A few posts said to install the monitor driver, if it has one like some Dell's do. Have you checked for case standoff's that might be in the wrong place, shorting the board? Did you need to remove the motherboard's CPU cooler tray to install the cooler? If so, the board may have have gotten scratched/scuffed during the install of the cooling solution you're using. Have you run a full, 800% coverage test of the RAM like this one: MemTest Manual ( I'm not an affiliate, but they make the best test I've used, for the $14 version that allows for making it bootable. You can run it all night, like I did to find the most intermittent or weird RAM issues that could be hiding. Memtest86 is $44, and not so great now that they changed the API/GUI, they just made it more expensive. At this point you could even check for bent/missing CPU pins, USB port broken and shorting(onboard or case),any other motherboard header with pins touching something they shouldn't, CPU thermals being ok and the paste applied correctly, SSD or hard drive SMART test and sector test, leave no stone unturned, etc. I forget now if you tried swapping a PSU? Pull out the "magnifying glass" for this.

You're correct in that a putting a 5000 series CPU in will not fix this but the best gaming one is the 5600X ~$360 USD or less. That means making sure the BIOS is before or after Patch "C", which caused many problems. Putting a 6000 series into this build is a no-go because of the software or hardware issue right now.

On a software note, Microsoft has released a new version of Windows 10 via the Media Creation Tool as of December. It may have a different base video driver, I never looked when I reinstalled early January. The driver was always from 2006 for the GPU and Windows Update, if left to it's means, eventually puts in a driver from AMD that's from a month or two prior to the current. There is a new chipset driver. but I still think this is hardware because you're saying it doesn't get past the basics. However, if your Windows media somehow got corrupted it could cause something  like this. Another OP made fresh media and the OP's issue disappeared.

I have had Nvidia cards and was hard pressed to switch to AMD until I saw the R9 390, that impressed me to buy it. Then I never went back, until 2018 when I built a fresh PC and used an Intel i7-8700K and the Nvidia MSI Duke 1080i and that was impressive to say the least, so I can't complain about Nvidia's GPU's. A single driver issue was all they had. System was stolen and I had to wait a year until I could rebuild. I went with the AMD build this time. I used the ASRock X570 Phantom Gaming S, 16GB TEAMGROUP Extreeme DDR4 3733 Gaming RAM, AMD Ryzen 3600X, Gigabyte RX 5600 XT WindForce OC 6G, Corsair H110i, Corsair RM 1000W. That's where I had issues with my RAM/IF not running correctly, even though it was heavily advertised that the 3000 series Ryzen's "sweet spot" was 3733Mhz RAM and 1866Mhz IF. I spent 7 months getting the kinks worked out and 4 months finding the best RAM setting under the 3733, which is 3600 CL 16 and 1800 IF with custom sub-timings. 

As far as Gigabyte goes, I was a fan since my 990FX build after taking a suggestion from a colleague. I find them to be very high quality for the most part and never had a board related issue with the models I used. I only went with AsRock because the price was unbelievably low at $149 in 4/2020, when X570's were running ~$180-200+. I since wish I had paid the $50 more for the Gigabyte, but it's running fine at this point. 

Keeping things up to date is generally good. AMD's GPU drivers have always been a sore spot since the moved from the Crimson driver to the Adrenaline. I was one to always get the latest GPU driver until I ran into issues with them. I did  a ton of research to find the solution of using the 20.8.3 or 20.9.2 driver package when using the 5000 series cards and most RX or Polaris based cards. You're not getting quite that far and you get a BSOD that could be CPU/GPU related or any other piece of hardware in the middle. Unfortunately, only you or a PC shop can narrow that down. The way you're describing how it won't restart after that part of the install bends towards the possibility of corrupt media but leave no stone unturned.


"It worked before you broke it!"

Many thanks for the info and suggestions:-

I have already replaced the PSU with a higher rating one (750W) and tried a different monitor and cable, also my normal monitor does have a driver and I have tried both with and without it being installed. I have tried with a different set of memory (2 x 8GB) and also did a clean Win 10 installs with just 8GB installed, 2x in different slots. All with no change.

The PC case does not use stand offs it is one of those where the screw holes are dimpled inwards to the correct height. Thanks for the info on the latest Win 10 image from MS, I will download and try that and check out your other suggestions if I get some time on the weekend or early next week. No update on the support ticket with Gigabyte just a "new" status (working on it).


Thanks again



No apparent visible problems or change with a fresh win 10 build using the latest image and the Gigabyte support ticket concluded that either the Mobo or CPU were defective. I requested and got a MRA for both from my retailer and have sent them back with a request for credit against a new order. They are not obliged to give credit, they can replace or repair the item, but I hope they do,   in which case I think I will go for a slightly more expensive mobo, I was more than happy with the performance of the 3600XT cpu so will stay with that.

I do like the look of the Assus TUF Gaming x570 Plus and would much appreciate it if anyone has any advice on that or similar priced boards.

I just bought that board. I got the one without the Wi-Fi and it's ok. The BIOS is confusing, unless you leave it all bone stock and you'll want to simply manually enter the basic RAM timings and voltage vs. using "XMP" or "DOCP". It should come with BIOS 3202 but I flashed to 3602 Agesa because I have a 5600X and run my RAM at 3933Mhz with the FCLK at 1966Mhz. 

It does what it's supposed to do overall. Features a good VRM for excellent power delivery, it has very good LLC if you get into that part. The disk that comes with the board is about useless. Go to their site for the latest LAN and audio drivers and to AMD's for the newest X570 chipset driver. Both versions of this board WI-FI or not are identical in every way. They have a built in RGB you can only program by downloading the "Crate" program, and after you sort the lighting, I would uninstall it. Alternatively, in BIOS you can completely disable the RGB, I did. 

Unless you need built in WI-FI go with the one that doesn't have it. The WI-FI version has some LAN issues for some reason I read about. The "PRO" is one to avoid for that reason too. It has a 2.5GBps rated Ethernet that is buggy right now. I'd leave the "LAN Turbo" software off as well. It just tries to prioritize your bandwidth like QOS does and does a horrible job.

Fan tuning is easy by selecting them to all be "DC" unless you have 4 pin PWM fans in your case. Then you select the mode or make your own curve for each fan. If your using an AIO and the pump connects to a board fan header, make sure that header is set to 100%. 

It is a board for "hands on" users and tuners, however is somewhat plug n play. Entering the RAM specs all manual is a standard OP these days with any AMD based board, so no point in recommending a huge list of alternatives. For things like enabling PBO, you can do it from the "AI Tweaker", where you enter your RAM stuff or under "Advanced" where the AMD "official" PBO is listed, either place works. Leave any other setting alone unless you really know what you're doing. Very easy to get in over your head. With the new BIOS the Ryzen 3000 series has access to the "Curve Optimizer" function. Don't get too excited, I've found it to be a never ending PITA if you start going down that rabbit hole. I set my CPU to "PBO Enable", "Advanced", "Motherboard", "+100" and it runs fine there. You can simply run everything stock but you still will want to enter the basic RAM info by hand.

In case you're unfamiliar, it's the first 4-5 numbers off the box or stickers on the sticks. Something like "16,16,16,16,38,50 1.35v" is common. If you need to select a different CPU due to lack of supply, go with the 5600X. For ~$300 USD it's about twice as fast as the 3600XT and more efficient. Here's a pic, I board installed.jpgjust needs ssd.jpg left the stickers they give you off.

"It worked before you broke it!"

Many thanks for that, it looks good. I got the CPU back, the retailer claims it tests out good but still waiting on the outcome of the mobo, they say a repair may be possible, they promised a decision by the end of this week so hoping I get credit and will order the Asus without  wifi. I'll let you know here.

Thanks again