cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Tefyu
Journeyman III

BSoD amdkmdag.sys 0xa0000001

my setup:
ryzen 5 3400G
team group T-force vulcan z 2666mhz (2x8) DDR4
redragon RGPS 500w 80 plus bronze
Asrock A320M-HDV R4.0 (BIOS 7.20)
Pichau Gaming SSD 256GB Sata 6GB/s, PG256X
 
Recently I'm having problems with BSoD, and would like to ask for help. The problem started after a BIOS update, and I know that the answer seems to be obvious and I should perform the BIOS downgrade but that is not possible because I am in a version where it is not possible to go back to other versions. The code displayed on the blue screen is 0xa0000001, a generic code that does not specify the problem itself, analyzing the file generated by the blue screen I saw that what caused the error was amdkmdag.sys and looking for the articles from AMD itself I found ways that maybe I could solve this problem (I'm talking about this article here: https://www.amd.com/en/support/kb/faq/gpu-800). I have the latest driver by AMD, I've tried it with different versions, as instead of the recommended one, the optional one and the drivers that are on the website of the manufacturer of my motherboard. I've already performed scans to see if my windows image may be corrupted but it wasn't. I performed a clean reinstallation of windows, and it didn't help. I have few or almost no programs on my computer to try to identify what is causing the error. I ran a memory test. I know that not one of my pieces is broken as they were working properly before everything else.
 
In short, I've done everything I found, but nothing solves... what could I do? The problem doesn't seem to have a specific pattern as to why it happens but it happens when I'm in some game like overwatch, LoL and yuzu emulator. I have already performed a stability test for a long period of time like the AIDA64 test but in these moments the problem never happens.
 
thank you for any help, and sorry for my english. Please help me.
0 Likes
1 Reply
elstaci
MVP

This tech website gives some good tips on how to fix that BSOD error: https://appuals.com/0xa0000001-bsod/

Screenshot 2022-05-06 232130.png

If all this occurred after doing a BIOS Update then it is possible the new BIOS update made something incompatible. I would open a ASRock Support ticket and see what they recommend.

 

0 Likes