Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Blue Screen On New Build Atikmpag.sys

Hello everyone, I am at a huge loss here and going in circles with my new build.

Firstly here are my System specs:

PSU: EVGA Supernova NEX750G1 (a few years old)
Motherboard: MSI B450M PRO-VDH MAX AMD Socket AM4 Motherboard
GPU: PowerColor Radeon RX 5600 XT Red Dragon 14GBPS 6GB
CPU: AMD Ryzen 5 3600 Processor
RAM: Crucial Ballistix BL2K8G30C15U4B 3000 MHz, DDR4, DRAM, Desktop Gaming Memory Kit, 16GB (8GB x2), CL15, Black
SSD: SAMSUNG SSD 850 EVO 250GB (C drive)
HDD: WDC WD1002FAEX-00Z3A0 1TB (D drive)

Background: I built an almost completely new PC last week, as my old PSU blew up, and my friend let me borrow his working PSU (Nex750G1), all the parts in my system are new, except I kept the SSD and HDD, which are not old at all.

I built my PC fine, however forgot to do a clean installation of windows and just booted up PC as usual with old drives in place, I installed new GPU and Chipset drivers.

I then encountered an error, which occurred when I was watching a youtube video/ scrolling through FB - Video TDR Failure, atikmpag.sys in the form of a blue screen. Also my machine would sometimes restart when playing games, like COD randomly.

I have tried these possible fixes:
Fresh install of W10, install drivers from CD
Fresh install of W10, install drivers from CD and disable windows update
Fresh Install of W10, install older version of drivers, meaning that in total I have tried the latest optional, the recommended, and an older version
Switch GPU physically from OC Mode on the actual Card, to Silent Mode
Attempted to replace Atikmpag.sys file (but I did not actually have the required .sy_ file on my PC to replace it with)
Run multiple stress tests
Tested CPU
Tested Mem
Tested GPU
As well as several other small fixes, like altering power saving settings, running some powercfg command in the CMD.

The only thing that appeared to work was to have zero drivers installed at all, and windows update disabled.

I don't have a spare PSU to test to see if that is the issue, and I feel that all of the symptoms are pointing towards a software fault, any advice would be greatly appreciated. Let me know if there are any other details I have missed that would help, thank you very much