Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Blender Radeon ProRender Everything Gray

I recently installed AMD ProRender for blender on my system and I am having issues with getting it to work. The problem is all of the objects turn a flat shaded gray, similar to the gray in the back of the view-port. I am using the full release of Blender 2.8. Here is a picture of what I mean.


This scene is filled with objects shaded in cycles and eevee but are now grayed out. I thought it was a shader problem with the materials not working correctly in Radeon ProRender. To troubleshoot this I changed this window to a Radeon Materials Library material. This did not work. I have also troubleshooted there not being adequate lighting. You can see my environment setup here. The HDRi is from HDRi Haven. I have played around with the different Render Modes also. I have tried uninstalling and reinstalling Radeon ProRender, Blender 2.8, and the GPU driver to no avail. Speaking of the driver, here is my system and graphics card details.


Why is this happening? What can I do to solve this?

4 Replies
Journeyman III

I am having this exact issue right now as well. Trying to run ProRender as an alternative to Eevee and Cycles which don't seem to be taking advantage of my gpu. But ProRender everything is gray and I very tried similar work arounds/test that you did.

Were you able to solve this issue?

Journeyman III

I noticed from the above picture that you have the 'Background Override' Checked. Try unchecking it and Changing to IBL in the World Tab and load up the HDRI again using the 'Open' button. Let me know if it helps. It shouldn't effect the HDRI but maybe something like that is happening. I also noticed that you had Sun and Sky selected and not IBL.


Any further insight into this? I'm having the same problem here, using a Vega 64. 'Background Override' is not checked for me, so I don't think that's the issue. Also worth noting that this issue is specifically with the viewport. When I render an image, it's working fine (apart from some unrelated issues I'm also trying to figure out).


Actually, talk about convenient timing. It looks like it was just fixed with the weekly release for 3.3.30