cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Highlighted
Esteemed Contributor III

Blender 2.80 Beta Cycles Rendering still not working with HD7970 / R9 280x GPU's. Any solution?

I have been testing Blender 2.80 Cycles Rendering.

This article discusses Blender 2.8 GPU support: Supported GPUs in Blender 2.80 — Blender Developers Blog 

It states "

AMD

GCN 1st gen and newer architectures are supported on both Windows and Linux. Terascale architecture cards are not working reliably, mainly on Windows. See the list of AMD GPUs to check which architecture your card has.

Unfortunately, this does mean some GPUs released in the last 10 years are not officially supported. No Terascale OpenGL drivers have been released for Windows in the last 3 years. On Linux, drivers do continue to be updated and Blender tends to work better. But for good performance GCN is still required."

Intel

Intel graphics for Haswell and newer are supported and generally working well. See the list of Intel GPUs to check which architecture your processor has. There are a few bugs planned to be fixed still, related to selection and reflections in Eevee on specific graphics cards.

On Windows, earlier GPU generations have issues with Eevee due to bugs in the driver. No significant driver updates have been released in the last 3 years for these GPUs. On Linux, the situation is better as the drivers continue to be updated, but for good performance newer GPUs are recommended."

I have a system with:
CPU = i7-4770K (Haswell)
GPU 1 = R9 Fury X – PCIe3.0x8.
GPU2 = R9 Fury X – PCIe3.0x8.
GPU3 = R9 Nano. – PCIe 2.0×1
GPU4 = R9 280X. – PCIe 2.0×1

I am testing blender-2.80-8fa65ed31b7f-win64
I am running Windows 10 Pro.
I am using AMD Adrenalin 19.5.2.

Here is a screenshot showing the GPU's on the system:

pastedImage_2.png

and the System Overview:

pastedImage_3.png

If I go to Blender 2.80   Edit -> Preferences -> System

shows the following GPU’s are available for Cycles Rendering:
CPU = i7-4770K (Haswell)
GPU 1 = R9 Fury X
GPU2 = R9 Fury X
GPU3 = R9 Nano.

Screenshot below:

pastedImage_4.png

The R9 280x, which is GCN1.0, is not shown as available for Cycles Rendering.
This situation was the same in Blender 2.79b. R9280x and HD7970 GCN 1.0 GPU’s have no support in Cycles.

Blender 2.79 was a great release and improvement for AMD cards, apart from the fact that R9 280x and HD7970 GPU's no longer worked with it. It meant that although I got a performance boost on 3 R9 FuryX/Nano GPU's I lost HD7970  / R9280x (2 GPU's out of 5 total) for GPU based rendering.    

The R9 280x 3GB and a Sapphire HD7970 OC 6GB card both work along with the R9 FuryX and Nanos on Blender 2.78c, so in that version, all 5 GPU's can be used.

Could you please tell me why the HD7970/R9280x GPU’s do not work with Blender 2.79 and 2.80?

Thanks.

0 Kudos
1 Reply
Highlighted
Esteemed Contributor III

Re: Blender 2.80 Beta Cycles Rendering still not working with HD7970 / R9 280x GPU's. Any solution?

I note that the latest Blender Plugin for Radeon ProRender does allow Radeon ProRender to run on an R9 280X GCN 1.0 GPU with Blender 2.8 Beta however Cycles does not run.

Quick Test Result Result here:

pastedImage_1.png

However, most of my Blender runs were using Cycles and unfortunately the above Blender Result looks somewhat different to my Cycles result, for example the HDRI background environment is missing. If I want to switch from Cycles to ProRender that means additional work to change the Blender input.  

Please  help get Cycles working on HD7970 / R9280x GPU's if it is possible.

0 Kudos