Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Black screen with RX580 after driver update

Hi everybody,

I started having the following issue a week ago: I turn on the PC and the monitor regularly shows the BIOS logo, the Windows Loader (white circles) appear and when the Windows Login should popup the only thing I get is a black screen. I noticed that if I detach the cable from my dedicated GPU to the integrated one everything show up properly. I even tried disabling the integrated GPU from the Device Manager and the RX580 turns back to life.

AMD Radeon Settings shows that the integrated is used as Primary... Unfortunately, a driver reinstall will work just for a boot: If I turn off or reboot the computer, the same problem will happen. I tested this with Fedora 28 and everything is working properly. The BIOS is set to use the NB PCIE GPU as default.

Any help here is appreciated, thanks in advance!!


2 Replies

Try disabling 'fast start'..

Windows 10 Fast Startup could be detrimental to your computer

How to Enable or Disable Fast Startup

Deciding whether to bother with Fast Startup actually takes longer than turning it on or off. First, open up your power options by hitting Windows+X or right-clicking your Start menu and selecting Power Options. In the Power Options window, click “Choose what the power buttons do.”

power options

If this is the first time you’ve messed with these settings, you’ll need click “Change settings that are currently unavailable” to make the Fast Startup option available for configuration.

available options

Scroll to the bottom of the window and you should see “Turn on fast startup (recommended),” along with other shutdown settings. Just use the check box to enable or disable Fast Startup.   Save your changes and shut down your system to test it out.

fast startup

If you don’t see the option at all, it means hibernation is not enabled on your machine. In this case, the only shutdown options you’ll see are Sleep and Lock. The quickest way to enable hibernation is to close the power settings window and then hit Windows+X and open Command Prompt (Admin). At the Command Prompt, type the command:

powercfg /hibernate on

After turning hibernate on, run through the steps again and you should see both the Hibernate and Fast Startup options.

Journeyman III

Had almost the same issue after installing a brand new 580 for the first time (no green lattice). Only happened with display port. I used DDU in safe mode as advised, restarted, and reinstalled the latest driver. That solved it for me.


Adrian Gates