Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Black Screen with R9 270X

I have ASUS R9 270X,i put the latest driver software,when its boot up after a few seconds go on black screen and after it freezes,also it do this 3 times and after it goes on windows repair,PLEASE FIX THE PROBLEM ISSUES WITH THE DRIVER IT IS UNBELIEVABLE

110 Replies

Cool, thank you.

I'll try checking later what these updates include and see if anything can be linked to the issues we're facing.

Okay. Just checked all three updates:

KB4456655 ( ):

"This update makes stability improvements for the Windows 10, version 1803 servicing stack."

- Thank you Microsoft - very "informative".

KB4457146 ( ):

"This security update resolves vulnerabilities in Adobe Flash Player that is installed on any of the operating systems that listed in the "applies to" section.

To learn more about the vulnerability, see ADV180023."

- I have my doubts it could be related to our issue.

KB4457128 ( ):

"This update includes quality improvements. No new operating system features are being introduced in this update. Key changes include:

  • Provides protection against a Spectre Variant 2 vulnerability (CVE-2017-5715) for ARM64 devices.
  • Addresses an issue that causes the Program Compatibility Assistant (PCA) service to have excessive CPU usage. This occurs when the concurrency of two simultaneous add and remove programs (ARP) monitoring threads is not handled correctly.
  • Security updates to Internet Explorer, Microsoft Edge, Microsoft scripting engine, Microsoft Graphics Component, Windows media, Windows Shell, Windows Hyper-V, Windows datacenter networking, Windows virtualization and kernel, Windows Linux, Windows kernel, Microsoft JET Database Engine, Windows MSXML, and Windows Server.

If you installed earlier updates, only the new fixes in this package will be downloaded and installed on your device.

For more information about the resolved security vulnerabilities, see the Security Update Guide."
- Now this one looks interesting and does make me raise an eyebrow.

I'll try looking further on what KB4457128 is.

But - keep in mind that KB4457128 marks Windows build as 17134.285, whereas AMD Expert Matt provided me a Belarc report, which shows the system is running build 17134.345, this would mean that the test bench also includes updates provided in KB4457128. I've checked the updates from builds 17134.285 to 17134.345 - there were no fixes being made to the updates of Windows updates in between these builds, meaning if Matt did install only the updates from the last available update - he would have the same updates that potentially KB4457128 could have caused issues for us.

So it might not be Windows updates after all.

Hi, I am having the exact same issue. Maybe I can provide one more piece to this puzzle... Have you tried Linux drivers? Because they do not work either.

Could this be a hardware wreckage due to a software update?

Hi @madcake ,

My current investigation into the matter makes me believe the issue is HW related not caused by software.

An update to my situation for those still interested - since my next build will require a lot of time and money invested, and I still want to game a little before that - I managed to find a cheap second hand working reference R9 270. Hopefully I will manage to buy it soon and will then be able to plug it in, install all the updates, drivers, and see what happens

So i bought the second hand R9 270 as mentioned previously:


We'll see tomorrow if it's software related or not No energy left today. Hard day at work.


I managed to install AMD Display Driver on the new second hand R9 270. Will Try installing all Windows updates tomorrow



Wow! So it does work. Half way there to get an absolute answer! Go go go! One step closer to the truth =)

As promised - installed all the latest Windows updates and AMD Display Driver. Everything is working perfectly on the new second-hand R9 270.

The answer - it's a hardware issue. Those who can take their cards to a repair shop - do so and find out which components fried and are causing the failure of 3D acceleration to be switched on (it's ridiculously expensive in my area to have it checked).

If it was a software caused death to the card - it was definitely not due to AMD or Windows. Although I do doubt it was software caused overall.

I know a lot of people complained about the same issue at a similar time - but it could all just be a coincidence.


@mat - I really think you can close this thread, unless someone is planning to take their card to a repair shop and find out which components might need replacement and share the info here (maybe the fix wouldn't be that expensive).

As for me - I will continue using the new card until my next build. Still sad to say goodbye to my ASUS version of this card (RIP)

Good luck everyone and bye bye!


P.S. Thank you all for participating actively in this thread, it was really nice seeing people come together

Adept III

A lot of ppl have this problem. ( me too).

This is basically a driver issue.

If you can do a clean windows install, then do it and use the 18.2.1 Driver for your card.

Removing the new driver and goin back to the old one is not enough.

Clean win install is very important.

If u find a working amd driver, NEVER update.

You have problems with your R9 270X

I have problems with my R9 380X

My pal has problems with his R9 280

Lot of ppl have this problem..

I always use MSI afterburner and Clockblocker.

I hope this helps...

I've tried these with fresh installs:

Tried drivers:









Journeyman III

Same issue here, I have a radeon XFX rx460 2gb single fan, i have tested the video card on 3 different motherboards, fresh install on all of them. I have tried different drivers and the result is the same. It was a mining card, i have flashed it several times before(unlocked shaders and lowered timings). It does seem to be a hardware issue for me, but the error appeared when i tried to build a pc with it on a fresh install with the original rom. I was wondering if anyone tried Windows 7 to get their card to work. I might try it when i have the time for it.

Adept I

Remarkable how many of these cards died in recent months (mine too).
My guess is that some driver update killed the hardware.

Adept I

It looks like our R9s have all expired at the same time... I'm going for an NVIDIA 1060  and looking for a shotgun to film my AMD's R9 270X distraction...

Stay tuned for the youtube link... in search of incredible... my a$$...


I get your frustration, and what I am going to recommend does require some custom settings but one done is rock solid and that is an RX 580. I have both the RX 580 8GB and 1060 gb. The 1060 out of box just works and works well. However the RX 580 is noticeably better in performance and has 2 more gigs in ram and boy this is making a difference with new games. So buy what makes you happy I just wanted to share my opinion as someone who has both.


Thanx for your valuable opinion mate but this is an obvious case of corporate irresponsibility... I'm not so sure the same thing will not happen with RX 580 or with any other of their products... 


I certainly understand your thoughts on that, and can't say mine differ that much. I am however pretty happy with my RX 580. However no card should need that much tweaking out of the box to even work.  Good luck to you whatever you decide and let's hope they come full circle with the quality again. After all, real competition helps all of us.

Adept I

I'm reporting the same black screen issue after updating my Radeon drivers to the latest version and doing the suggested Windows reboot on the Radeon R9 270X.

Initially I ran the BF4 game which loaded fine but not without some flickering that I hadn't seen before so thinking it was a driver issue I updated to the latest version from AMD's website, and lo and behold, I got the black screen.

Initially I thought my SSD had crashed so I reinstalled Windows 10, but when I installed the AMD drivers from the CD that came with the box (I bought the card in 2015 so the driver on the CD must be from around the same time) and the black screen came back.

After reading this thread I tried installing the 18.2.1 driver version resulting with the same issue then went into Windows' Safe Mode to change to 17.7.1 but both attempts ended with the same black screen (of doom).

I came to the same conclusion as "artis", in that my 270X had become defective at the HW level.

It's a nice coincidence, isn't it, that almost everyone's 270X died around the same time?

I forgot to mention (this will probably be some consolation) I was able to hit F5 and go into Windows' Safe Mode during each attempt of installing a different version of the driver. And now I'm using my 270X without the AMD drivers, i.e. detected as "Microsoft Basic Display Adapter", shopping for a new GPU.

If your card still works with the MBDA then the card works, so it's a software issue.


RUN DDU FROM SAFE MODE. Latest version from wagnardsoft_com.



This should do it. Both my R series cards were doing the same thing. Some seem to get hardware failure from this issue. Your card luckily is still working.


No clue what you mean with MBDA.

The only references i can find, make no sense.

Microsoft Basic Display Adapter. Its the basic Graphics driver

Mine also still works with the MBDA driver but not with ANY AMD driver I've tried


Mine only works at bootscreen

If you can get into safe mode, Go into Device Manger and uninstall or disable the AMD Drivers, you'll be able to get into windows

Same case here, notjustmichael. [EDIT: "same case", as in my 270X only works as an MBDA and it gives me a black screen (of doom) when I try installing different versions of AMD drivers.]


Thanks, pokeseter. However when I attempted to install the AMD drivers from the box that I bought in 2015 (MSI Radeon R9 270X), I did it on my Windows 10 which had been re-installed from scratch. So I'm pretty sure the OS did not have any non-Windows video drivers.

What's worse, at the time I got the black screen *during* the AMD driver installation process and I didn't even get any "congratulatory" splash screen / welcome message from AMD. I suppose this is when Windows switches over to using the AMD driver, but since the HW had already failed the switchover gave me the black screen (of doom).


Pokester, just for kicks, I tried your "DDU" steps but came up to the same situation. Here's what I did:

# On Windows, created a Restore Point for my C: drive

# Downloaded the DDU utility

# Disconnected my WiFi adapter (to ensure disconnection from the Internet).

# Went into Windows Safe Mode

# Run DDU to "Clean and restart"

# After Windows had restarted, installed AMD drivers from the CD that came with the GPU box I bought in 2015.

# As I feared, I got the black screen (of doom) as the AMD installer application was still installing the Catalyst Manager.

# I powered off the PC using the power button.

# Plugged in my Windows 10 installation USB key and navigated the menu to revert to my Restore Point created today

# After Windows had restarted from the Restore Point I regained the use of my GPU, though I checked that it had been detected by Windows as MBDA (Microsoft Basic Display Adapter).

# Re-connected my WiFi adapter

# Typed this post.

I'm shopping for a new GPU

You need to disable Windows 10 from installing Driver Updates. Easy in Pro versions. Home version no as easy. Google it.


Nope, that is highly unlikely the solution. I had disconnected my internet before I ran the AMD installer on my freshly installed Windows 10.

Maybe you have something else going on or I don't understand your situation. However, no, disabling updates, disconnecting from the INTERNET after running DDU then while disconnected is what fixes the driver install for most. Now in these 2019 versions many are finding that on the older cards they are in fact still having issues and no what has been the common fix isn't working for them and you may absolutely be one of them. If however you didn't do like what I just said it is a very likely fix and worth trying and not unlikely at all. So based on recent events you are right it may not work, but I wouldn't assume and pass up on a fix based on a guess. I don't think the issues are hardware either in many cases and have my suspension that the driver install issues are even contribution to those failures but I can't prove that. I won't even test further in fear of ruining my HD7xxx and R9 Series cards. Also your suspicion it being windows loading drivers durring boot, yep that's correct that is why the advice to disable Windows Driver Updates was suggested. The other critical things to fix there that even after getting a good driver loaded will keep screwing you over is leaving Fast Startup enabled as it is by default. It caches old driver data and reloads it even after your replaced the old driver! So do yourself a favor and disable Fast Startup/Hibernation. This advice is literally given hundreds of times with success in these forums but this forums search abilities and results are pretty poor to find the answers.  Either way it is your choice of what advice you try and I only hope you find a solution. Given some of the recent feedback on the most current drivers many of these things may seem as though they don't work. I promise they will work when coupled with the pre-2019 adrenaline drivers, unless you do really have bad hardware. Don't give up. Many of us are sure willing to help you get back to happy gaming.  It sucks that any of us even have to come here for what should work to begin with.


Pokester, I posted a step by step in my previous post, which means you can see at which point I disconnected my PC from the Internet and re-connected it again.

As for the need to disable Windows Driver Updates, doesn't this feature need the Internet connection to work, and doesn't having disconnected my PC meant that I had already put a barrier on Driver Updates from working?

I value my time since I work on call using my PC. I don't have the time to test out suggestions that don't make sense until I get it.


yes and no, it depends, if it has already previously or was already in the local repository on your computer that Windows pulls from then Windows update can hose you whether the internet is enabled or not. Also what I'm recommended is disabling just driver updates not windows updates.


I see. Well this is a clearer explanation than just "disable this" or "that" since I'm not in a QA department that has many available (and paid) hours to test out all possible avenues. I'm sure many of us here are the same way too.

All said and done I won't be exploring disabling Windows Driver Updates. I've bought a new GPU and moved on from this mess caused by an AMD product (are you reading this, AMD?).

No sadly they are not. They don't participate in THEIR forum. They at least host it and have a couple employees moderate. Those moderators have limited involvement and are not on the driver development team. So no, AMD is not listening to you, me or anyone else in the so called support forums. it actually says it right in the forum headers, if your read it. These are USER TO USER FORUMS ONLY.  Nvidia takes a big part in their forums. They also fix most issues in their control very fast. This wasn't the case for the green team years ago, but they certainly do what the preach currently. AMD should take not. But as AMD ceo said they don't concentrate on one area they look at the whole business. At the end of the day, we pc gamers don't even make a big difference in their bottom line. They make the money on cpu and game consoles these days it seems. It think they highly undervalue how much damage they are doing to their reputation. I also don't think they realize it is easier to get a new customer than to get a disgruntled customer back. They havent been making their base happy for about 2 years now IMHO and I fear it will have a long lasting affect.

"The AMD Support Community is a place where AMD users can help each other by sharing their valuable knowledge and experiences about AMD products."

Adept I

I have this problem in my HD 7850 for almost 6 months...

Anyone tested the drivers in Linux?


On Windows 10 I updated my R9 270 nonX drivers from February 2018 or 2017 to 2018.2.3 this week and got the similar problems as described in this thread. Downgrading to 2018.2.2 did not work. I have not tried DDU with a downgrade to a much earlier driver yet.

On Linux the my card works without any changes. I do not know the Linux driver that installed of the top of my head but its from after April 2018, since I have Ubuntu 18.04 and make sure that the graphics work with it after an update.

I don't think the AMD techs are right about it being a hardware failure in most cases. At in my case it is purely a Windows Driver issue.

To get to the Windows 10 log in screen I have to plug in the monitor to the HDMI port on my motherboard. And then the graphics are painfully slow. However when I tried downgrading to 2018.2.2 using the AMD setting utility the graphics seemed fixed but then I got the black screen during boot. The issue has something to do with Windows loading the drivers during boot.

I tested it in linux and it also did not work, boot dont work with my video card.

Journeyman III





please share!!!!


If you have a solution you should post it here and help the community.