Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Black Screen with R9 270X

I have ASUS R9 270X,i put the latest driver software,when its boot up after a few seconds go on black screen and after it freezes,also it do this 3 times and after it goes on windows repair,PLEASE FIX THE PROBLEM ISSUES WITH THE DRIVER IT IS UNBELIEVABLE

110 Replies
Journeyman III

I have the same problem. My video card randomly broke down on ursday 19 July while watching a movie (dirver auto-update?) and only works now without any drivers installed. I used the clean uninstall utility and first tried to reinstall 18.7.1 and then cleaned again and tried 18.5.1. Each time the screen goes blank when installing the driver and stays blank, although the card gets hot. (Win 10 - 64 bit here)

Now I can only use my computer using the integrated graphics card.

I will search for the Internet for an older driver from 2017 (like version 17.x) which is what I recommend you to do mat, and also disable driver auto-update.

I've never had any issues with this card since I bought it in 2014

Edit1: I tried installing an older driver 17.7.1 from the link below, but that did not work:

Radeon Software Crimson ReLive Edition 17.7.1 Release Notes

This made me look into windows updates and I noticed that just before my card broke down Windows installed a cumulative update: KB4345421.

Since older AMD drivers don't work anymore I now strongly believe that the source of the issues lies with this windows update not with the latest drivers.

Adept I

i have R7 270, same issue...

My card died, Please don't run Adrenaline on your cards.

Adept I

I have this problem for almost 2 months :/


First thing is try to do a system restore.

Next thing to try is DDU. Display Driver Uninstaller Download version

Try installing 17.12.1 after using DDU.

ASUS TUF X570 wifi, AMD Ryzen 5 5600G, ASRock 6700XT Challenger, Antec Truepower new 700w. 32GB
Journeyman III

Same here. R9 270, was running smoothly until I updated to the last drivers few days ago (from a ~1 year old one)

Adept III

R9 380X Black Screen on desktop. Again! Argh! This makes me mad.

Started last week.

Can't even open a web browser. Boom Black Screen.

I tried: DDU, 6 drivers including 17.12.1. disable windows update. Nothing helps. This card is a garbage. Of corse i ran out of warrianty in april.

This is an issue with the last several issues and the only fix is to go to safe mode, run DDU and return to 18.3.4 or earlier driver that worked for you. It has been reported many times. I have reported it to AMD and urge any of you with this issue to do the same here: Email Form

I have been talking with amdmatt about this but not heard any status on a fix on this.

Adept II

I have an R9 270x and I get black screen TDR crashes on some games: Heroes of the Storm, Diablo 3, Warframe, Dota 2. In Far Cry 4 I crash on the Himalayas levels. I do not get any crashes on most other games, it seems to happen more on multiplayer or online-only game engines that are a bit old now. Most games from between 2014 to now run great without problems. Games like Doom and Witcher that have much higher graphics requirements run without any problems and do not crash. My card isn't overheating and I have tried multiple drivers but I see the same crashes.

17.7.1-17.12.1: Overwatch does not work for any of the drivers published in this time frame.

17.12.1 Heroes of the Storm crashes with artifacting problems, Far Cry 4 crashes in the Himalayas level with colors going negative or thermal mode. This was the worst driver I've tested so far.

18.6.1 and 18.7.1 crashes - far cry 4, dota 2 warframe, heroes of the storm, diablo 3

18.5.1 Subnautica crashes on this patch.  Dota 2 warframe, heroes of the storm, diablo 3 all crash.

16.3.2: Diablo 3 still crashes, Far Cry 4 crashes on Himalaya levels.

I had tried the 18 series drivers the first, then 17, then 16. I'll try 15 series drivers and then try other 18 drivers. I have thought about installing MSI afterburner to underclock my card to see if that helps.

I have recently upgraded to Windows 10 and the games that crashed still crash in the same way, and the games that didn't crash still don't crash.

The games usually crash when there is a lot of action on the screen, like lots of enemies with spell effects in Diablo 3, team fights in Heroes of the storm with many physics effects, looking around in Far Cry 4 himalayas levels when there are snow effects. Dota 2 crashes constantly and Warframe crashes are rarer so I'm not sure what causes them to crash. These TDR errors happen on both Windows 7 and 10 so I don't think Windows update is responsible for the crashes. It's something to do with AMD drivers.

Do a clean win10 and install 18.2.1. Once you find a working driver, never update it.... !

Adept I

Hey there. I got the exact same problem as you. I too have an R9 270x. My problem started about several days ago.

I wasn't able to boot the pc until I went into safe mode to uninstall the graphics driver. I could then go back into Windows normally. However when I tried installing the driver back again (using catalyst, adrenaline, minimal driver installation) it went into black screen too. And I can't even boot it up anymore.

It's been several days now and there's still no reply from AMD too. Sigh, please help.

paperbag Did you get a reply back from AMD? Any chance you've fixed it?

Same problem on R9 270. Also tried all various driver versions after clean windows install and every time installing drivers after properly cleaning the old ones out.

Saw on some forums suggestions of bad psu/ram/etc.. tested all these - all were fine.

Will give the GPU to a friend to test on Monday in another rig. If symptoms repeat - I guess it might be a hardware issue after all.

Sad that my warranty has already ended..

Their response is as follows, and no I have no luck resolving the problem following their guide. However, I've changed to 1050 ti and everything is working fine again.Wish there would be other solution cheaper than the one i took. Really saddened by the fact that needing to spend for another card, knowing with confidence that there was only problem with the driver, and no company has taken any action to solve our problem.

Thank you for the email.

I understand that you are experiencing black screen issue on your computer equipped with AMD FX 8320 CPU and Radeon R9 270x graphics card running on windows 10 (64 bit) operating system.

You have mentioned that the issue started recently. It might be chances windows update also pushing the driver update for your graphics and overwriting the current driver which result to such issues. I request you to download and install the Windows Show or Hide updates tool and run it and check if there is any graphics driver available from windows. If yes, then follow the instruction to hide it.

To be on the safer side, I request you to please create System Restore point before performing any troubleshooting steps.

Again, I request you to please follow the below steps and try to install 18.9.1 driver:

  • Please use DDU Utility (Display Driver Uninstaller) by launching it in Safe mode and uninstall the previous driver. It will help you completely uninstall AMD graphics card drivers and packages from your system, without leaving leftovers behind.
  • Then restart your computer in the normal mode and run the show & hide tool.
  • After preventing driver to update via windows, I request you install all the critical and recommended updates from Windows.
  • Then install 18.9.1 driver -

Thanks for contacting AMD.

It is a shame they will not help people with this issue. My R9 380x is still in this boat too. I can get it working though with older drivers. I have success with these earlier drivers. I too however need to run more current games and an using a 1050 ti as well in that machine and moved the R9 380x and use an older driver on it as I don't game with that computer but I still keep trying to get each new driver to load with no luck.

Try the following info to at least get a working card again if you want:

The fix is to run DDU from wagnardsoft_com from safe mode, a must from safe mode. Then have the last driver that worked for you ready to install when you reboot and you will install that again and be good to go!

18.3.3 or 18.3.4 are probably the last 18x series that worked okay. Some say 18.2.1 is the last one that worked with some of the R9 2xxx series.

The last drivers that worked really well are the 17.7.1 drivers.

The only solution that worked my this year. Do a clean windows install and download the 18.2.1 amd driver. Last year almost every driver worked. And forget the driver update. If u find one working driver, you never want to update your drivers.

Test and report. and buy Nvidia next time like i do.

Thank you paperbag and Siegfried,

Will try both your suggestions and report back after the weekend.

Hope this works. I was planning on a new machine next year. Looks like I might need to start earlier.

Upgrading the GPU in the current rig would cause a chain reaction forcing me to upgrade other components..

Anyways - will get back later.


No problemo. I had this sh!t issue too. Actually the other solution is Win 8.1. I tried that also, but Gears4 is Win10 compatible only.

Dont forget, dont update your driver, after u installed the 18.2.1. 

So yesterday I tried the suggestions. Went to the extents of formatting and reinstalling windows several times. Nothing helped. The different drivers did not work.

Windows basic display driver lets the GPU work in safe and normal modes. As soon either windows tries to install the driver automatically, or when I try installing a different driver - screen goes black during display driver installation and the computer crashes into a boot loop.

My guess in my case is an actual HW issue, because it feels like maybe something is being activated in the GPU during driver installation and it simply can't take it. Maybe vram...

Gave the GPU to my friend to test in his rig. Will see hopefully the conclusion tomorrow.

I'm actually still keeping the "faulty" R9 270x that I've replaced. I think there's too much of a coincidence that everyone experienced this around the same period of time. I have 2 other friends that have experienced the same issue too within the week. I think it has something to do with the September 11, 2018 Windows update. I've checked around the internet and saw a lot of posts around that time period too.

Anyhow, my pc is now running perfectly fine. Got myself a 1050 Ti Cerberus and had to get a new SSD to install new windows too to save my files.

So coming back after a while with an update.

Tried a lot of different drivers (from original to newest) with clean installs. Tested possibly conflicting PC components. Tried it in a different PC. Of course tried clean windows image. And, believe it or not - tried reflowing it (at safe temperatures to avoid warping and or parts falling off, but enough for internals to move about and realign):


Good thing is that it still works. Sad thing is that nothing helped. Stuck running with the Microsoft Basic Display Adapter (really weird how that manages to work, right??).

Anyway. Lost hope for it. Had a tempting chance to purchase two second hand R9 290's for 90EUR, but then I did quick search on the web if they have any similar problems...and I didn't buy it. Guess why

So bye bye Team Red. Will have to start building a new rig slowly and meticulously.

Leaving this message here so that others save their time and effort.

Oh and also tried a newer bios on the card.

Sent an Online service request to AMD also. Mentioned that I'm not the only person with this problem (and that this is not the only thread in regards to the same issue). Explained the steps taken of attempted repair. Hopefully they will come back with an interesting answer.

AMD Tech Support replied promptly and have asked for more details of my system. Everything gathered and sent to them for further analysis.

I am glad that the reply was not generic and they did read the whole message.

Small update: AMD support has asked further information about my system. Info provided. Now the case has been escalated to an AMD Tech Expert.

That windows update is what killed mine too, it died on the 16th of September

Interesting. Thanks notjustmichael​. I would like to mention your message to the AMD Tech Expert who is checking the issue.

Any chance you could shortly explain if you have the same issue (only able to run with the Microsoft Basic Display Driver, and can't install any AMD display driver?), which card you are using and the name of the update received from Windows on the mentioned date?


Would appreciate that.


Journeyman III


I have the same problem. Only able to run with the Microsoft Basic Display Driver, and can't install any AMD display driver. I have the R9 270x
the problem came up on tuesday. Unfortunately can not predict why the error comes. Have my PC already reinstalled.

Artis, I really admire your persistence on this issue my friend. I think it would be appropriate for me to summarize that we all have the same issue. R9 270x, etc. I have actually narrowed down the problem and I would say with confidence it is indeed the driver and maybe its compatibility with the new windows update.

I've came out of this issue by going Green (bye bye-ed team red). Did a DDU before installing 1050Ti Cerberus, and then I'm running the new card with my old installation of windows 10. No resintallation or formatting whatsoever. It works perfectly fine now.

I've also heard from some of my friends, 2 of them having the same issue and happened around the same time too, one is AMD, the other NVIDIA, the AMD friend is still stuck with the problem, as for the NVIDIA one, he told me he didn't touch the PC for the night, and when he came home from work the other night, it was working again, without any issue. Although I could not say that they are facing the same problem as us, but if they are, I would say that NVIDIA actually did put in some work to make sure their drivers are compatible with the new changes made. Anyhow this would only be my merely speculative opinion.

Thank you @paperbag

I have received a reply from the AMD Expert:

"Thanks for coming back to me with the reports and the links to the forum.

I am aware of the forum link you provided and i have been working with some customers who experienced a similar issue.

In each case, what i have found is that this often comes down to a local system issue or a hardware issue with the graphics card.

When the card is using the Microsoft Basic Display Adapter, it is just being used to output a display with no 3D acceleration being used on the graphics card. When the AMD display driver is being installed, it attempts to enable 3D engine on the graphics card. If there is hardware failure on the graphics card, this step will fail resulting in a black screen output.

I see that you have already undertaken extensive troubleshooting above and beyond what i would normally suggest, however i did ask our technical support engineers to take a look at reproducing your issue.

We setup up test system and the system specifications are as follows:

AMD Ryzen 7 1800X Eight-Core
AMD Radeon R9 270X Series
Windows 10 (x64) Version 1803
ASRock X370 Taichi
Samsung SSD 950 PRO 512GB

We setup the above system with an R9 270X which had the 18.7.1 driver installed. We then installed the 18.10.1 driver and it installed correctly and the system rebooted as expected – we did not experience a black screen or boot loop during the installation.

I have enclosed three videos, one showing 18.7.1 installed on our test system, we then installed 18.10.1 and completed the installation. The second video shows the system after a reboot with 18.10.1 installed successfully. Due to the file size of the videos, i may have to send them in more than one response, so please allow some time for the other responses to come through. For your reference, i also attached a DXDIAG and Belarc report from our test system.

We have no known issues with installing our drivers on any graphics card and therefore we believe the issue on your system is caused by a faulty graphics card."

I also asked if they could advise which components could be checked on the GPU board. I did also point out that it was strange to see many people with the same issue happening round a similar time.

Their reply:

"Unfortunately we do not have any tools to diagnose hardware issues with graphics cards.

As electrical components can degrade over time, you may want to consider contacting a local computer repair shop to see if they are able to determine what component on the graphics card has failed."

I have checked the report and videos provided by the expert. The Windows build was the latest (meaning up to date with updates) and the videos do actually show the currently latest driver 18.10.1 being installed successfully.

I do agree with the experts verdict. It does make sense what was concluded regarding 3D acceleration not being able to kick in.

Although I am quite proficient in IT, I lack experience troubleshooting components on a board with multimeters, hence my last option would be to take it to service (but that would cost more than the card where I live).

I'm giving up and settling with the fact it is a HW issue. To be fair - I did game quite a lot...3.5 years on it, so it was worth it. Just wish it lasted another quarter.

No gaming until my new build.. but the new machine will be epic

@mat - I think you can close the thread. It is a GPU HW issue. And it was not software that bricked it.

Good luck to others who decide to continue!

P.S. if someone decides to bake it.

I tried three times in total:

1st attempt 140C for 6mins

2nd attempt 170C for 12mins

3rd attempt 200C for 12mins (I was really afraid to do this one).

None helped.

I'm actually really sceptical of their reply. If it is really a hardware issue, there won't be so many people having this issue around the same time. There must be something triggering it. Like a GC-virus turning all cards into zombies.

Second of all is that many of us that has this issue has various time spent on the card. It ranges from 6 months to 4 years. If everyone that has the same problem has spent about 4 years using the card, that's more reasonable.

Anyways, this is only one community, I have also scour other forums like tomshardware, etc. Most of them faces the same issue and no one seem to have any luck yet.

There is NO WAY that there can be a complete hardware failure ACROSS the board. I had my card for exactly 2 years, was bought 2nd hand but it was still sealed. Unfortunately Warranty was juuuuuust missed so no chance for a RMA. If it is a hardware issue it was caused by killer software, either from Windows or AMD. I would understand a hardware failure months or years apart, that makes sense because not everyone games the same(might overclock or even underclock like I did). But everyone's cards having a critical hardware failure after a specific software update within like a week. That's some conspiracy.


...just in time with new nvidia cards being out... but I'll not start going into politics

But yes - very fishy.

They have their head in the sand. Because they can't reproduce it it's just you and the hundreds other that can reproduce it. I have an r9 380x that does the same thing! I can load any of the older drivers and any since last spring cause the black screen right after Windows loads. It is not un, it is absolutely something different in the drivers. I have talked about this to amdmatt​ numerous times. I have no doubt that whatever trigers this is maybe a perfect storm of more than just a Windows and AMD conflict, it may be some 3rd, setting some of us use that allows this to happen. I don't know, I only know the older drivers work.

Hey pokester, glad that something worked out for you. Could you kindly enlighten us which version of the driver works for you so that we can try that too? I've tried several but no luck so far. Thanks.

I got 17.3.1 to work. The last one that was rock solid IMHO was 16.11.5 and that is really old now. If you aren't trying to run the latest AAA titles though it works pretty darn great for older games.

Thanks @pokester

Just tried it - didn't help me

Finally. Pretty good news.

Hey @artis. Sorry that I'm getting back to you so late.
I'm running version 1803, last updated on September 12th.
Got the Sapphire R9 270x 4G DualX OC


That's when all the flashing, flickering, restarting and artifacting started. 4 days later I needed to use the Microsoft Basic Display Adapter Driver because my PC wouldn't boot. The driver kept installing itself and my PC kept crashing. To be safe and just keep my PC running (had assignments to do), I just disabled the GPU in Device Manager with the driver installed. In my BIOS I made my IGP the primary display adapter and that at least kept the PC going but without any of the GPU functionality without having to take the GPU out. Unfortunately though, ANY AMD driver I tried to install just crashed my PC, even if I did it through device manager, installing it manually.