Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Black screen with only cursor when installing 22.6.1

Like the title says when I install the 22.6.1 drivers and restart the PC, I get black screens and can only see and move my cursor (also it looks like it's loading/working on something because of the spinning wheel)

It only happens on the 22.6.1 drivers, I had to force start my PC in safe mode and install the 22.5.2 drivers.

I tried DDU, upgrading from an older driver, unpluging unnecessary USB peripherals except for the keyboard and mouse, turning off my 2 other monitors, nothing works.

I'm on Windows 11 Pro and everything is up to date.

My setup:

CPU : Ryzen 9 5900X

GPU : RX6800 XT

RAM : 32Gb 3200MHz

Motherboard : Rog Strix X570-E Gaming


4 Replies

Personally, I would set it up with one monitor connected..

Then after restart check it's working ok, before plugging in the others..

AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb G.Skill TZ neo 3600mhz, Samsung 980pro 1tb NVME, Samsung 970 EVO Plus 1tb NVME, Lian Li Galahad AIO 240mm, Antec Titanium 1kw.
Adept III

Did you try downloading the full 22.6.1 install (after running the driver clean-up in SAFE mode) and selecting the "factory reset" option before the install? 

Ryzen 9 5900X CPU, RX 6700 XT GPU, Windows 11 Pro x64 build 22H2

I always download the full install drivers from

I tried with AMD Cleanup Utility in safe mode, still does not work with and without the factory reset. I tried turning off my OC from the BIOS, doesn't work.

They're just bugged drivers

Adept II

My monitor was also stuck on a black screen during installation of 22.6.1 without any mouse cursor visible. 
Power cycled my PC,  driver was installed but the RGB on my 6900XT Sapphire is not working anymore. 

Did a cleanup with AMD tool, installed 22.6.1 for Win 11 again. 

No black screen during this installation but it disabled/enabled my network card again just like with other drivers previously. 

My RGB is still dead so I will go back to previous driver and hope that the RGB will work again. 

My RGB is back after reverting to 22.5.1. 
I am gonna stay away from optional drivers and install just the recommended ones