Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Black Screen When Installing 17.12.2 Drivers HD 7870 Win 7


GPU: XFX AMD Radeon HD 7870

Windows 7 Ultimate x64

Driver: Radeon Adrenalin Edition 17.12.2 Optional

Intel i5 3570 - 8GB of RAM

Hello everyone,

My PC crashed while my brother was playing some game, and ever since I'm unable to boot if I have any AMD drivers installed unless I'm in Safe Mode. After the Windows logo everything I get is a black screen I've tried everything you suggest with DDU and even did a clean install of Windows, which has not solved the problem.

Hope I can get some help here from you guys. Thanks!

Message was edited by: Matt B

We have updated the title of this discussion with relevant details to better describe your issue.

78 Replies

Thanks man! Please, keep us updated


From your other thread,

You need the card connected to monitor and card set to initial display first (or auto) in your bios to install driver.

It should boot up and display using the win drivers.

Guessing you fixed the igpu black screen.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Thanks goodplay, I managed to fix that when I did a clean install of Windows. Now the only problem that persists is the one caused by AMD drivers. Thanks!


Has someone tried installing the new 18.1.1 driver? I think I'll try tomorrow, though I've already given up hopes with any driver version until AMD says something about this.


yep no problems on my end.


I tried it twice and it didn't work. I don't think the problem is related to faulty drivers or a broken GPU. It's too sudden and the hardware is new so I don't see why it would go bad so fast and without any apparent reason. Could it be related to the Spectre and Meltdown situation? I feel like there's a link between the time when Windows made all those urgency patches and the problem we are currently facing. Of course it's only a theory, could someone confirm or reject this possibility?

Just tried with the new driver a couple of minutes ago with no results. I've also thought about that nefe​, though as far as I know the problem involved W10 and I'm running W7. I've been thinking about upgrading, but I've read how a lot of people with our problem has done that and nothing changed.

I'm about to give up and buy a new card from another manufacturer, since no one seems to find a solution and AMD is blind, deaf and mute regarding this problem. I've never felt so frustrated with my PC.


I know how you feel about getting frustrated with a problem that seems to be unfixable. LoL, Sometimes I feel like taking a Sledgehammer to the computer to put it out of its misery.

Most of the time I just do a System Image Restore to the time when the Computer was working well. This is a last resort if I can't find a fix to the computer, especially if the problem prevents me from using the computer during normal use. Using a previous Restore Point, in my opinion, isn't very reliable 100% of the time. Otherwise, I really don't have anything to add to this thread. It is very difficult to figure the culprit. If it is a Windows Update, 3rd party program or AMD driver or any combination causing the problem.

I think the Windows Upate conflict is possible, since it was all too sudden and I don't remember updating my AMD drivers for a while. kiwinadians mentioned it too. The thing is, as you said it is very difficult to figure the culprit... I think I'll try posting my issue on Windows Support Forums an see what I can get from there. There's really nothing to lose at this point.


I heard back from XFX again today, and they encouraged me to do a system restore. I already tried, to no effect. Then I reinstalled windows 10, to no effect. My concern is that it is in fact hardware related, but was caused by a borked windows update, AMD driver, or some combination of both. I think the issue comes down to power supply at various power states. Somewhere in the communication between the power management in Windows getting a delivery call for power to the GPU, and then the AMD driver not receiving an expected power state and shutting down.

I can wait, as I have an old HD 5750 I can run with for a bit (however I can't play much of anything newer with it), but I'm hoping it is a solvable issue. My concern is that AMD and the card manufacturers have no incentive to take care of us users still running cards that are several years old. There is probably little testing as to the effect of driver updates on older hardware architecture, and they assume if our card fries that we'll just buy a new one. I worry this is an effective form of manufactured obsolescence that will become increasingly common in the tech world (such as with old Apple devices being slowed down), which users with have little recourse against and will find highly difficult to prove. 

I've also created a question on the Windows forums, and so far have received the usual "roll-back drivers", "refresh windows', etc. XFX has been saying the same things. Even if it is a hardware issue created by faulty drivers, I want to post it to as many places so that we can elevate the issue, and maybe get a fix for those whose cards have not yet been compromised. I don't expect to see XFX send me a new card, or AMD or Microsoft for that matter. It is just frustrating that there is essentially radio silence, or at least negligible support. If my card was new I would have done an RMA already, but I hope that these companies still would like to support those end-users who are outside of that warranty period.

kiwinadians escribió:

It is just frustrating that there is essentially radio silence, or at least negligible support.

I totally get you, man. This is what gets me on my nerves: no one is able to tell us anything, and no one seems to really care about it (aka AMD/Microsoft). Sorry for not replying these days, I've been quite busy at work. Thank you for your updates regarding XFX/Microsoft and the testing you've been doing!


XFX seems to have lost interest in my case, because after their stock answers (update bios, check windows integrity, reinstall windows) they have not even stated they will look into it, despite the fact that I have insisted there are multiple users with Pitcairn devices with the same issue and that it is quite coincidental that they all failed in the same way at around the same time.

Windows forums have offered the same advice, and unfortunately the "experts" there often suggest bloatware driver updaters and other 'diagnostic' tools that I wouldn't wish on an enemy's computer. I haven't heard a response from anyone who seems even remotely tied to the Windows development team, or even their PR team.

As far as the device goes, I've exhausted all by one last option. I've tried flashing complementary vbioses from similar devices to see if their memory timing or voltage profiles would help (they didn't), even going so far as to flash an R9 270x bios. This did boot, but was still being recognized as an HD7870, and so subsequently failed a driver install.

I have one RAM chip that is not exactly matching my pair, and while they are running in single channel, and I have had no issues with stability during memtest runs, I tried removing the chip and reinstalling the gpu. Again, this didn't do anything expect cause problems with my Windows 10 activation (apparently it doesn't like downgrading Ram amounts, only upgrading).

I created a bootable usb of Video Memory Stress Test (vmtce: ) and tested it there. My HD5750 was totally fine, but my HD7870 through a significant amount of errors. On the second test, it consistently output verified its write data as being out by 20 digits. I'm not sure if this is an actual error, or just an issue caused by the fact that this program cannot really handle RAM amounts of 2gb and over. If it is in fact reporting properly, it means some of the gpu memory is munted, which could be consistent with a voltage issue or improper cooling due to a faulty Wattman profile for our cards that could have been causing the failure.

The only thing left for me to try is to reflow the solder, something I am hesitant to do if there is no reason to. I will like pass on the baking method, and instead opt for a heat gun, trying to reflow the main chip and the ram chips. I'm going to hold off on this for a while, and see if anyone finds a solution that is more than just DDUing the drivers and reinstalling.

Adept II

I just discovered something new to help us along. I've put my HD7870 in the secondary pcie slot, and am running my HD5750 as my primary card. On installing the 7870 drivers, the black screen we are getting is actually a windows BSOD with the classic "Thread stuck in driver" error message. Going back to 2016, the main culprit then was the audio drivers. I've tried installing the driver with no audio drivers present, and with my audio drivers fully updated from the supplier (it is an intel mobo, so realtek drivers from win8.1), but to no avail.

While it is still not solved, it at least narrows the search, although AMD drivers have had their fair share of stuck threads. Maybe we'll solve it yet. I refuse to believe this is hardware failure. I have tried flashing some modded vbioses, but they are no help either. My XFX bios does not display its vrm in VBE7, and so I don't have much control over voltages, and trying to set the memory clocks for anything but state 0 doesn't work. I'm wondering if that is due to it not being a reference card. I poked into the bios in a hex editor, but even with the ATOMBIOSREADER, I can find some of the memory straps, but I'm not really sure what to do or where to go from there. It's very different from all the tutorials which are geared to polaris devices for crypto-mining.

Hopefully this helps point some of you in the right direction.

Does that mean that this may be a solvable issue after all? That apparently our real problem is a stuck thread?

This reminds me that I was thinking about updating my BIOS, and if I'm not mistaken this can usually help solving the "Thread stuck in driver" error. The thing is, I've never updated it and I'm afraid of bricking it. Do you think this could be a possible solution?


You can always try and update your bios but you chance bricking your pc.


If you have a desktop, Go to the Motherboard's manufacturer and they always have a software specifically made to Update the Motherboard's BIOS. Makes it easy to update the BIOS now a days. Just follow the instructions of the program. The ONLY thing that can brick your Motherboard during the update process is if you lose power or the computer shuts down unexpectedly during the flashing process before the BIOS is fully flashed.

I have an Asus Motherboard which I flashed my BIOS several times since I purchased it without any problems using Asus program for flashing my BIOS.

Laptops also have their own programs for flashing their BIOS same as Motherboard manufacturers.

This may help you, although unfortunately it does nothing for me. I am already running the latest bios for my Intel DP67BG board, rev 2209. It has been running that bios since I bought it used, and I reflashed it just to be sure there was no corruption or anything.

Definitely update your bios and see if it fixes anything, but I wouldn't hold my breath.

I was just trying to set ezrawolvenheart mind at ease about updating his BIOS since he has never done it before. Someone else posted that he can risk bricking his motherboard by updating his BIOS. Which is true. But as I mentioned in my reply that all Motherboard and Laptop Manufacturers have specific programs to flash BIOS relatively safe now a days. As long as ezrawolvenheart doesn't lose power to the computer or does something to interrupt the Flashing process of the BIOS it should be a safe and easy task to do.

Upgrading BIOS has solved some Users computer problems concerning drivers in the past. I feel it is a good idea to update your Motherboard or Laptop BIOS to the latest due to compatibility or security issues that arise as technology advances and your motherboard or laptop becomes more obsolete.


Good call, sorry if it sounded like I was negating your advice. I totally agree the updating to the most recent bios is the first part of call in trying to diagnose this issue, particularly for users running embedded gpus. I remember the first time I flashed a Mobo bios, and how worried I was that I would brick my device. You never forget your first time  

My caveat to your statement was probably just my old, jaded reality that this solution won't fix the problem. I hope that for most people the solution is as simple as a bios flash. I guess I'm just sad that tech companies think that 5 years is too long to support a device, and that a device lasting that long is an exception not a rule. I think as consumers though we have brought some of this on ourselves, always lining up to trade in our 6 month old device for the newest shiny thing.

I guess the real issue is that unlike the gpus of old, we are really pushing the new silicone to it's limit. With that comes very small margins between optimum performance and critical Hardware failure. The problem is that we as end consumers can sometimes have or devices bricked by miscalculations on the part of the driver engineers, and if we are out of that support cycle range, tough luck. It's also not worth the resources to prove negligence, it to file suit to demand compensation. /Rant

Thanks for walking those who have trepidation about the bios flash process through it, your guide was informative and reassuring.

Hey, No problem. I know you weren't negating what I was saying. I just wanted to let you know who I was talking to and why I posted that message.

I had before a VisionTek HD 7850 which was an excellent GPU card. I still have it in case my new GPU card goes on the blink. I bought a new GPU card because I thought the AMD driver that I installed bricked my card. After purchasing the new card, I found out I had one of four memory modules that was very bad. I removed the bad memory module and was able to update my drivers and Windows without BSODing constantly. It seems because the Memory module was bad, When I updated my AMD Driver it was updated corrupted. Not enough to show an error but enough to change the parameters of my HD 7850 card so that whenever I rebooted, I got a black screen. I went to VisionTek Support and downloaded their old AMD driver from their website and installed it. My HD 7850 came back to life again and started working normally again. I guess the manufacturer's AMD Driver reset my HD 7850 back to its default parameters. I then updated to the latest AMD Driver at that time and it installed perfectly. But since I purchased a much newer GPU card I removed and installed the new card. That is why I suggest to check the hardware or Windows Installation if installing old and new GPU drivers doesn't work.

Seems like the latest Windows Update did a job on both AMD and Nvidia Drivers. Both AMD & Nvidia forums I have seen people complain about updating and getting Black screens from the GPU cards.

When I purchased my Asus Sabertooth 990FX gen 2.0 motherboard, I installed Asus AI Suite II to maintain my cpu and case fans and to be able to flash my BIOS while in the Windows Environment. Never had a problem until I started having weird issues with Windows. Part of the problem, I found out recently, was that the latest Windows Update bricked the program. I couldn't even uninstall it. I needed to use Revo Uninstaller to locate all files and for me to manually delete it by the program. I needed to download the MSI Installer .exe file that was used to install AI Suite II to get it to even start to uninstall without errors. But unfortunately, It didn't uninstall it. Thus i needed to do a HARD uninstall using Revo Uninstaller to locate all files and registry data to delete it manually. Now my Windows is working fairly well as long as I don't let it go into it Sleep cycle. Otherwise, it screws my Audio to where I needed to reboot to get it working again. I went to Microsoft Forum to get advice and they told me to uninstall Mcafee Anti-Virus and use strictly Windows Defender A/V. I mentioned I would do that if they can positively show me it was the AntiVirus that was causing the issue otherwise I wouldn't uninstall it to use a average Antivirus program like Defender. The Microsoft Moderator didn't like that I didn't want to use Defender. I than posted several websites links stating the Defender was good but not as good as 3rd Party Antivirus. They say they and hundreds of other Microsoft Moderators stand on Defender being an outstanding Antivirus. According to the MS Moderator, all those test performed on Anti-Virus programs to test their effectiveness are basically bribed by the 3rd party programmers to give their antivirus a good test results.

Sorry for babbling, LoL, got off the subject.

Thank you all guys. I know updating a BIOS is kind of risky and it may not solve the problem, but given this point I think there's not much more to do besides trying the few options we have left. Other users with apparently the same problem have solved it in different ways, so we'll see. I don't have much hopes but I'll try this Sunday.

I didn't know you could update a BIOS in Windows environment, those are good news. I'll be really careful in any case! I'll try changing the card to another memory module just in case. If nothing of this works I guess I'll have to buy another card lol

Thanks guys! I'll come and tell you any news.


Yes, I found that flashing the BIOS under Windows environment was really easy to do with Asus AI Suite II that came with my motherboard's drivers. But as mentioned above, I needed to uninstall it because the last Windows Update bricked the program.

Journeyman III

sorry i didn't help you same problem happen with me also. I am also confuse don't know what to do

Adept II

Hey all,

Any one have any updates on their situation? Any fixes to the BSOD forthcoming?

I had a thought while I was messaging the XFX rep assigned to my case. I read on some other forum (I apologize as I can't remember where it was) of a user with a similar card who tried it in three of his friend's rigs.  It worked in 1 of the 4 he tried. Its confusing as to why that would be the case, especially since a revert to Windows 7 should really fix the issue if it were related to an issue with recent windows updates. My only thought would be that something has caused the card, the AMD driver, or the windows power management to read faulty values for the voltage requirements, and the one rig that worked had a significantly more than adequate power supply and was able to supply an over-inflated demand. I know that sounds like a stretch, but it's the only plausible explanation I can think of as to why the issue is occurring.

The other feasible answer is that some recent update has caused our cards to either over- or under-volt, and this has caused failure to many cards while under load. The most likely culprit would be corruption of the vram, as it is not protected by thermal protection, and has no sensor data warning the card of dangerous heat levels. The other option is that something is causing a memory violation - either a faulty driver, or some incompatibility between the driver, windows, and the specific memory modules used on these southern isles cards. This in turn causes the driver to hang on initialization, thus the Thread_stuck_in_driver BSOD.

Maybe one day we'll have working cards again. Keep your chins up.


You know the funny thing about all this stuff is that I have a Saphire 7870, 7950, and an R9 380  they all run Windows 10 64 bit one is in an AMD AM2+ and the other two are on AM3 boards. Never an issue with any of them. All running the latest drivers right now. Yet I have not had my new XFX RX 580 be able to run without hacks to Windows and custom settings in Wattman since I got it in November. I really wonder how much of these issues do start with improper bios setting that never get fixed by the cards makers. I don't know what else makes sense as to why some cards work and others don't. It's either gotta be bad hardware control settings in the bios or or bad QC in the parts themselves. No doubt the drivers have issues. But really it's not like everyone is literally having issues. We'd be over run here and we'd see reports on the news by now, I would think. So this stuff has gotta be working for many people too. I know this XFX was absolutely useless in wanting to help me. It is how I ended up here. I hadn't had a real video card issue since the old S3 Savage 3D days. I gotta admit though with the issues I have seen here of the hit and miss problems including on their own MB's and processors, it may be tough playing the Silicon Lottery on my next purchase. I am ready to buy right now I am just waiting to see how the new Ryzen 2 platform works when it comes out. If it isn't silky smooth, I may be jumping ship. I know this I bought my son an I5 7500 and a GTX 1050 ti and he has not had a single issue from the day he started using it. It just flat out works. I am not ripping on AMD far from it, I have definitely been in the Fanboy camp a long time. Had that system I bought my kid not been an emergency purchase and a great open box deal I wouldn't have seen the current other side of things.

I feel you man, I am as stoked as the next person about the potential of Ryzen and Threadripper, but unfortunately this experience with my GPU and the lack of response worries me enough to question what sort of support we would get for issues involving older CPU hardware in the future.

Ironically, this is the second XFX GPU I have had fail on me. The first was an old 8800gt, which luckily got RMAed just weeks before it was off warranty. That one was an obvious failure, with random BSODs and artifacts and the whole shebang. This problem just feels like a someone shut off a switch and now the card just refuses to load into an elevated state.

I've been reading the forums on those problematic newer cards and that sucks. A card running at stock should last and be effective for years. This sort of instability on a newer premier product is just unacceptable. I feel that these companies are so just sitting in Silicone Valley unaware that much of the world can't afford to just replace a GPU on a whim every few months, not to mention years.


IS yours still broken?


I had resolved those issues back in december by changing several settings. Not sure if it was one or the combination of things that helped. But never had to do anything special on my prior cards and they are all still running fine.

Adept II

So... I finally fixed my issue. After trying practically anything I could think of, even reverting back to fresh Win 7 and 8.1 installs, I decided to bake my card (I know, it doesn't actually reflow the solder...). I do believe what we are experiencing is a hardware issue, and that the Thread_stuck_in_driver BSOD is related to failing hardware. So I baked it and now it works.

While I am thankful it is working, I still have significant concerns with regard to why we are seeing significant amounts of failed older cards(and to be fair, a lot of newer cards) running at stock speeds under fairly normal conditions. I think the recent rash of failed cards is due in part to a combination of software issues between Windows and AMD, and their effect on our hardware has caused undue stress on them during acceptable loads under normal, stock circumstances. Good luck getting them to ever admit to that though.

So you can try baking your card and see if it helps. My recipe:

Remove heatsink/fan, and clean all thermal paste/pad residue with isopropyl or rubbing alcohol (or just some paper towel).

Pre-heat oven to 190 C (375 F). Check to make sure it is that temperature with an oven or candy thermometer.

Place aluminium foil on a over tray. Ball up 4 pieces of aluminium foil to make supports, and place the card face up on the supports. Make sure it is level, and the foil balls are not touching any components (have them at screw mounting points).

Bake for 9 minutes, and once your timer beeps, turn off the oven, open the door slightly, but leave the card in for another minute.

Carefully remove the tray from the oven, and let the card cool for about half an hour.

Re-apply thermal paste, attach fan and heatsink.


I haven't put it through any rigorous tests yet, but so far it seems to be doing alright. Mileage may vary. Let me know if it works for you.

I've actually had the same problem: having a HD 7700 and suddenly (I think after a windows update - the anniversary update(?)) the problems started with having a black screen (actually, a black 'backlight' screen) when I rebooted the PC.

Now, to be sure: there might be different causes and reasons for such a failure, so I don't know if others will have *exactly* the same as me. For starters, with me it wasn't a problem with a dvi-d output on a TFT screen, but it WAS a problem when I tried to use the DVI-I (with adapter) to see something on my (CRT/VGA) screen. And it wasn't about a BSOD (as I've read someone here claim): it was just the screen going black, the PC and win10 started just fine. I'm sure of this, because I could enter through teamviewer (on another PC) and everything worked ok; I could even reboot from it.

That's also how I noticed it was never with simply *restarting* windows, but only after *shutdown' AND THEN starting it up again, I got the black screen.

Now, I tried numerous, numerous things. All what has been described here and elsewhere on the Net and more: installing the latest drivers, installing legacy drivers, reinstalling the entire windows, etc. Nothing worked. Very frustrating, I must say. I wasted so much time on this. But the hint I got was that it did work after restart, but not after shutdown, so I began to think it had nothing to do with the driver on itself (though it did work when I installed the generic windows drivers, but then one is limited to the resolutions and Mhz of those, which isn't much use neither). But since it used to work, but not after the windows update, surely it must be something to do with that and/or some setting or interference with the driver and/or a power-state or wake-up call of the PC. I tried to have the 'sleep' and 'power' settings doing different things, but that didn't seem to work neither. And then I found something that did.

For me, what solved it was this:

In win10, go to settings, system, power&sleep, additional power settings, choose what the power button does, change settings that are currently unavailable. After that, you'll see the grey-out checkboxes at the bottom becoming black so you can alter them, and then you un-check 'turn on fast startup'. It says it's 'recommended', but actually, that's what is causing the problem, and you really don't notice any delay when starting up, so I'm left wondering why it's put there. This could also be something that was put there during a large window-update, or it might have been 'checked on' at that time, or maybe they made some changes to it - but in any case, if you un-check that box and save it, and you had the same problem as me, chances are high it will solve your black-screen problem with the HD7700 as well.

At least it's preferable to try this first before baking your vid or re-installing windows... :-)



Glad you found this. This is something often recommended to Windows 10 users to remedy issues. You will find this advice on many threads here.  Fast Startup is a cached startup that may contain information that is not current or even corrupt and can cause issue all for the sake of saving a few seconds. On SSD or NVME systems the difference is pretty negligible. Glad you turned it off as IMHO it is always best to start fresh every time.


Literally tried everything in this post to salvage my 7870. Miraculously, baking the card worked.

All other solutions tried: Reinstalled Windows, rolling back drivers, formatting, RAM tests, switching out hard drives. DDU was ran more times than I can count. Computer would let me boot into safe mode but it was impossible to install drivers via AMD or Windows 10 during normal boot. Trying to install the drivers would make normal boot no longer function and I would get the dreaded black screen.

Before I resigned myself to trashing the card, I followed Kiwinadian's suggested instructions to bake the card. (375 degrees F for 9 minutes, 1 minute to sit in the oven and then let it cool on a tray). After re-applying thermal paste and attaching fans I installed the card.

I was able to install drivers after doing this. The card has been working fine for several days now. Could not freaking believe it.

It's entirely possible the baking did nothing at all and it was just the cleaning and the re-application of the thermal paste that did all the work. Regardless, it's great to not have to chunk a perfectly functional card away. Thank you so much! You saved me and my brother in law some money and grief by not having to look for a new card!


Glad it worked out,

I know it was crazy to me at the time as well. I have long since moved on

to an RX 580, but I donated the card to a church that has been using it to

encode weekly video, and run their whole daisy chained monitor system.

It's been 3 years now and the thing is still going strong, it's really

unbelievable. I'm glad it worked out for you.

All the best, happy gaming.


OMG, this worked for me! After a full weekend of fiddling around with drivers, I baked the card as per the perfect instructions from @kiwinadians and with the help of the optional Windows update that properly detected the card, everything worked fine after reassembly. Apparently, they fixed the driver issues and this old, second-hand, card can now serve a few more years in the entry level gaming pc of my wife. Thank you all so much here

Journeyman III

I see no one has given a relatively definitive answer for this problem, so I shall...having just battled and solved it on a Win7 ultimate install.

The driver install assumes the HDMI port on the card is the primary.

Because everyone always hooks the HDMI to their monitor and the VGA to their entertainment systems...right? 

If you have a desktop with your HDMI hooked up to something other than the monitor, disconnect it and reinstall the driver.  If you have a laptop with an HDMI port, either disable it in BIOS (if that is possible) and reinstall the driver, or, alternatively, hook a spare monitor up to your HDMI port...I'm inferring the winblows logon will come up there.

Journeyman III

Ulen AMD Sokayım senin yapacağın işe. Windows 7 x64 işletim sisteminde AMD HD 7770 ekran kartı sürücüsünü kurunca ekran kararıyor. Görüntü gelmiyor. 1 Aydır çözüm bulamadım. Bir daha AMD Ati ekran kartı almam aldırmamda. Yazıklar olsun.....

Journeyman III

Hello everyone, i've got the same issue with my radeon ... GPU. Anyway after trying everything like update software, or dowload and old software, flashing BIOS, downgrtinting mywindows setup.... i've try to bake my GPU as tell sooner in the thread and it work for me, so thanks, the baking (190 °C for 9 minutes works). Good luck for every one doing this.


Glad to hear it worked for you as well! Thanks for spreading the word.