Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Black Screen When Installing 17.12.2 Drivers HD 7870 Win 7


GPU: XFX AMD Radeon HD 7870

Windows 7 Ultimate x64

Driver: Radeon Adrenalin Edition 17.12.2 Optional

Intel i5 3570 - 8GB of RAM

Hello everyone,

My PC crashed while my brother was playing some game, and ever since I'm unable to boot if I have any AMD drivers installed unless I'm in Safe Mode. After the Windows logo everything I get is a black screen I've tried everything you suggest with DDU and even did a clean install of Windows, which has not solved the problem.

Hope I can get some help here from you guys. Thanks!

Message was edited by: Matt B

We have updated the title of this discussion with relevant details to better describe your issue.

78 Replies

Sorry, but I'm not getting any help in there and I think I did not address the issue correctly. My real problem isn't the "No AMD driver..." error message, but the black screen. I posted this because I wanted to re-address it.


Rules are rules. Bump your old post or edit it...don't post another. You will have people wasting their time giving you the same answers you have already received. Use the search function of the forum to read similar posts and make sure your OS is up to date.

** Windows 7 and Windows 8.1 must be fully updated before attempting to install any AMD driver. All 'critical', 'recommended', and 'optional' (no language packs,etc) updates as well as any Service Packs (SP) must be installed before any attempt to install graphics drivers. If you do not get this message .... keep installing until you do:

I've locked the older thread, please use this one going forward.

Thank you amdmatt​, sorry if I caused any inconvenience.

kingfish​ I understand, I'll take it into account for a next time.

Regarding the issue, yes, my Windows is fully updated. I've tried installing the two newer drivers (17.12.2 and 17.12.1), but none of them worked.

I also tried installing older CCC drivers (16.6,15.2 and 14.4). 16.6 didn't work, and with 15.2 and 14.4 Windows managed to boot, but the screen was filled with artifacts and it crashed in around a minute in both cases.

I've also tried installing the driver manually (extracting the files and installing only the Display Driver through the Device Manager), and it didn't work.

I read in another recent post a user that solved the problem modding the vBIOS, but I have no idea how that works. Can anyone give me some help?

Thanks in advance!

Adept I

I'm running into the same issue. I've managed to isolate the steps that cause the black screen for me (the screen is on but just outputting a black screen). It seems to be during the driver install.

CPU: Phenom II X4 955

GPU: XFX 7870

OS: Windows 10 Pro N 64bit (Build 1709)

What I've tried so far:

  1. Did clean install of windows.
  2. Prevented windows from installing 3rd party hardware drivers (not doing this installed AMD display driver which causes black screen).
  3. Performed all OS updates.
  4. Attempted to install Radeon Software "Adrenalin Edition 17.12.2" ('17.12.1" has the same results)
  5. During the installation my monitor goes black and stays black.

Power cycling the computer seems to remove the driver and reverts to the basic windows display driver and lets me boot into my desktop.


CPU: I5-2500


I am getting exactly the same issue. I bought my mobo/cpu and hd 7870 used from someone who had been using it successfully for about two years. For the first few rounds of gaming, everything was going well. I got a black screen while playing Skyrim, and after a reboot the black screen persisted. I couldn't boot into safe mode, as it would immediately restart.

Cue reinstalling win 10, and whenever I try to reinstall an amd driver I get an immediate crash. I may try to install the older 15.2 or or 14.4 drivers as stated above. My older HD 5750 runs just perfectly, and I am worried there may have been damage to the card due to a driver error, much like what happened during the 2012 driver debacle. Before the crash I was running 18.1 drivers and everything seemed fine, although I didn't think to monitor my temps in afterburner. The card was not excessively hot right after the crash, and there was no artifacts or other indications of imminent failure as I've had with gpus failing in the past.

This is the first thread I've seen of this problem occurring now, as most of the related black screen threads are from back in 2012-13, so hopefully there are some new solutions. Back then, it seemed like the general consensus was RMA, or if out of warranty, bake it and hope for the best. I've raised a ticket with XFX, and hopefully they will come through with a vbios or something.


kiwinadians Mine is the exact same model, also from XFX. Have you got any news from XFX? Did you get your card to work somehow?


Hey Ezra,

Just heard back from XFX today. They gave me the stock answer:

"It shouldn't be too hot upon start. Please check if the fan can spin and clean the heatsink.

If the driver can be installed , check the temperature in Wattamn"

I had obviously stated that the driver could not be installed, etc. I have sent them a reply noting that my temps before my crash were only in the 70C range, and immediately after the crash I opened the case and the card was not overly hot to touch, even right behind the core. Unless it is similar to the early AMD driver issue, where low fan speeds were causing memory chips to fail.

Basically, I told them that I think this is some sort of driver/windows update conflict. That seems like the only reasonable explanation for two identical cards running on similar systems to fail within days of each other under similar sorts of conditions, that seems too coincidental.

I don't have RMA status, as I got it used only a few weeks ago, and it was running perfectly under much heavier loads for the week I had it set up before this failure. It seems to be related to switching power states during the driver install, and as such, I think the vbios, or some power delivery conflict with a recent windows update is part of the culprit.

kiwinadians escribió:

Basically, I told them that I think this is some sort of driver/windows update conflict. That seems like the only reasonable explanation for two identical cards running on similar systems to fail within days of each other under similar sorts of conditions, that seems too coincidental.

Yes, it makes sense.

I don't know much about vbios, power states and that kind of stuff to be honest, so I can't really help shine some light on the issue. I hope you get some good news from XFX in the next days Would be much to ask to keep us updated in this thread, if you have any news from XFX or if you manage to solve the problem? I would really appreciate it.

Adept II

Same problem for me.

CPU: AMD - FX 6300 - Black Edition

GPU: MSI - Radeon R7 370 Gaming - 4 Go

OS: Windows 10 64bit

I already made a thread about it in which several possible solutions were given (none of which worked for me): GPU black screen with R7 370

Apparently, it could be a driver conflict with Windows 10.


Currently I'm running W7, and I've read around the forum and various websites that people with W7/W8/W10 have pretty much the same issue. It seems to be something related with AMD drivers and Windows in general, I don't know. I've also read about people who have upgraded or downgraded their system to no avail. the problem seems to persist.

Yesterday I was reading this post which seemed to talk about our same problem: R9 290 Crashing With Black Screen

Apparently they modded the vBIOS or something like that. Can anyone shine a light on this? Does it work? merutsuelstaci


You need to ask the OPS of the thread. Seems like it did work. But you have to realize that each GPU vBIOS is different. Upgrading a BIOS on a computer, you use a file from the manufacturer specially made for that BIOS upgrade. But on vBIOS you are changing manually the parameters of the vBIOS. Input a wrong data and you can have an expensive paperweight unless the GPU card has a backup vBIOS.

I would suggest everyone with the recent black screen issue to make a "AMD REPORT ISSUE" ticket here: AMD Issue Reporting Form

So if we do mod the vBIOS, we jeopardize the entire computer? Or only the GPU?


Just the GPU card. If the manufacturer of your GPU card has a vBIOS update that would be the safe way to upgrade your vBIOS. But if you modify the current vBIOS and you input a wrong data. Your GPU card may not work correctly or not work at all. You really need to know what you are doing to modify your current vBIOS.


Ok, I guess it will be as a last resort then.


Mostly black screen occurs because of incorrect voltage determined by EVV or faulty VRAM or some power issues.

When you use your graphic card without the driver it stuck at idle clocks so everything is fine, but as soon as you install the driver a memory clock could jump to its max value and system immediately crash with black screen. No matter what windows version is installed.

There are two ways to fix it by modding vbios:

1. set up manual voltage for all DPM states, generally it's possible to do even some downvolting (most reference r9 290 can work at max voltage 1.175-1.200v instead of 1.250-1.275v used in stock vbios)

2. downclock vram

//everything above is actual for r9 290/390, but maybe it's applicable to some other cards (step 2 at least). I never modded vbios for an older than r9 290 cards.

Well I don't know anything about how to mod a vBIOS... Could you point us towards a guide that explains how to do it?


for hawaii and polaris you can easily find good guides on by googling "hawaii bios editing" or "polaris bios editing".

for other cards I don't know, guess this one should be useful for tahiti ATI Hd 7950/7970 bios mod thread


can you do the same thing using AMD Wattman or some other 3rd party software without modifying the vBIOS?


it's impossible because OS won't load when the driver installed.


I'm having the same problem when installing newer drivers like 17.12.1/2. Black screen during installation (forced to reboot PC manually) and after Windows boot logo only black screen. When I run 17.7.2 however, everything is rock stable.

I'm glad to hear that setting manual voltages for each DPM state helps, modding vBIOS cannot be the solution, if this issue doesn't occur in any driver version. Maybe Wattman is initialized in a wrong way for some cards?

wattman should be disabled by default at clean driver installation as far as i know. You need to accept some agreement on wattman page before it get enabled.

If you are able to install the old driver and use wattman you could try to set up all settings (voltage and lower memory clock by 50-100mhz) in 17.7.2 and then update driver to newer version without uninstalling it. Maybe it will work that way, don't know. I prefer to use the only driver itself without control panel, relive and other software + modded vbios with all settings what I want, so I saw wattman interface only on screenshots


Makes sense. So there has to be something wrong with the driver.

I modded my BIOS and set the voltages to fixed values. The complete black screen is gone now, but my monitor will lose its signal once on Windows login screen. This is kinda the most stable it has ever gotten with newer drivers. I will also try to lower the memory clock and see if the signal loss will be gone. But again: this cannot be the solution to this. AMD should acknowledge this issue already. When they introduced the first drivers for Windows creators update, they mentioned it under "Known Issues". But it magically disappeared without ever getting fixed or mentioned again.


Adrenaline has been a headache for most people. I hope the time they are taking before issuing a new driver update, they are working on fixing the issues.


Tomorrow I'll try installing 17.7.2 as you say dimi1606, I'll post my results.

Honestly I'm hoping AMD is working on this, because I have no idea how to modify the vBIOS, and I don't really want to mess with it unless it was my last resort. If the solution was fixing something on the vBIOS, who would be responsible for providing a solution? AMD, or my GPU manufacturer (XFX in my case)?

Again, it would be nice hearing something from AMD about this issue I'll fill that AMD Issue Reporting Form, I encourage you guys to do the same.


Well, I wish you good luck. Modding the vBIOS didn't fix it for me. It just made it "better". So I'm back to the old driver as well.


I just tried installing driver 17.7.2 with the same results.

Black screen after the installation was finished.


revert back to a stable version. this driver was rushed because of the holiday and poorly tested.


Any idea on what that would be? None of the drivers seem to be working correctly. Seems to be a combination of windows and AMD drivers.


Same thing. Tried installing 17.7.2 with no positive results.

Adept II

Modding the vBIOS sounds like a bit of a long shot indeed. Plus if we do that and we end up breaking things, then the manufacturer will simply say that it's our own fault for messing with something we aren't supposed to, and down goes the warranty.

I don't know if AMD takes this kind of issue seriously but I certainly do. If it turns out this cannot be fixed, I will vote with my wallet by turning towards another brand the next time I buy a component for my computer.

Has anyone got any update on this? I have a beautiful and expensive paperweight at my desk since 3 weeks ago and I'm giving up hope of solving the issue.

Does anyone know if I would have the same problem with another AMD card? I don't have one to test.


I read that Windows is issuing an update for AMD devices that have been basically rendered bricks but the update. I don't know what to tell you man. You might have to a complete factor reset.

Adept II

Could one of the moderators give us some official information about this? I think it's important we know wether there's a point in waiting for a fix or not.

Some people in youtube comments were saying it is because AMD brought a company ATI, now their drivers conflict with some hardware, & they either lack the ability to fix the issue, or just don't care to.


Who knows, but I don't really think that's the problem since AMD bought ATI more than 10 years ago... Also, this doesn't seem to be a generalized issue (not everyone has it), even though we're seeing a number of similar cases around here. To be honest, I have no idea what the root cause of the problem could be, as it seems to happen in different versions of Windows, drivers and different GPUs.

As nefe​ says I would also like some words from AMD about this. We need to know if there's going to be a way to fix this without putting our GPUs into the oven or something like that, or if we should be preparing our wallets to buy another one.


Some things that could be worth a try,

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

I think I'm gonna bring my computer to a professional today and I'll hear what he has to say about it. Maybe he can fix it or maybe he can't but at least it should bring some light on the matter. I'll let you guys know what he told me once I get my computer back.