cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

norman_
Adept I

black screen w 2400g and 18.5.1 drivers now with ADDED CORRUPTION

Hey- I've been troubleshooting the black screen thing and I think I'm maybe a bit different.  Cuz my boot drive gets hosed.   I am cross posting to the processors sub-forum too.

brand-new rig:

Ryzen 5 2400G,

gigabyte ax370 gaming 5, bios F23f

g.skill F4-3200C15D-16GVR (2x8GB sticks; test well in memtest; the below happens if at stock 2133/1.2v or 3200/1.35v, XMP or manual, or in between),

seasonic M12 II PSU,

mydigitalssd Nvme 480G (usual os drive),

Plextor M4Pro ssd (SATA/Cable; backup drive; has had win 10 before but not ATM),

hooked up to a TV w/ known-good HDMI cable.

All drivers on the gigabyte CD install just fine.  However, there is no video display controller in Device Manager that corresponds to the Vega units.  Only the windows basic driver shows up.  I believe the disc installs radeon driver 16.x, but it is not noticed by the OS.

When I try to install/update the video driver (using 18.5.1) the installer runs and eventually the screen goes dead after installing the driver...

Rebooting does NOT get me anywhere- when I'm "lucky" the screen goes dead after passing the bios/setup.  It may or may not actually load windows- can't tell.

Usually immediately, but sometimes after a try or two, it refuses to load windows.  I can get into the recovery environment but nothing I've tried works as advertised.

I've spent 2 weeks determining the cause... and its AMDs drivers or this specific chip/apu.

And just cuz I'm special- unlike others, I get my OS drive corrupted every single time I try to use radeon drivers.  Can't use a system restore point and all recovery options fail; nor can I reset.  chkdsk shows no errors/problems. 

The only thing that gets it working again is clean re-install. 

But I can't connect to the internet w that box- Win update grabs the driver and installs it whether I want it or not.  I am not aware of a way (other than keeping the machine offline) to keep windows from doing this.  So when I go online... black... so re-install, rinse, repeat.

Could this be the a faulty APU or crappy drivers?

I've RMA'd the mobo (it did die after a couple days of me beating on it), and am trying to get the same for the APU.  Also doing email support w AMD, gigabyte.

Any ideas?  Help?  Is phone support worth the time?​

7 Replies
kingfish
MVP

Re: black screen w 2400g and 18.5.1 drivers now with ADDED CORRUPTION

Use one or more of the methods described here to prevent/delay Microsofts automatic driver installation. You can also delete the previous drivers from the C:/AMD folder. > https://www.tenforums.com/gtsearch.php?cx=partner-pub-7156303416008077%3A205v6qk06j2&cof=FORID%3A9&i...

0 Likes
norman_
Adept I

Re: black screen w 2400g and 18.5.1 drivers now with ADDED CORRUPTION

Well, OK. 

This does not allow the Vega cores to function as intended, though.  Performance with the microsoft basic driver is... poor.  I'm going to throw another hour at it and try older drivers.  And block Win10 from phoning home.

0 Likes
kingfish
MVP

Re: black screen w 2400g and 18.5.1 drivers now with ADDED CORRUPTION

Do you have the computer power plan set to 'Performance' ? It should be as in Win10 this affects the core parking.

0 Likes
Ray_AMD
Community Manager
Community Manager

Re: black screen w 2400g and 18.5.1 drivers now with ADDED CORRUPTION

0 Likes
norman_
Adept I

Re: black screen w 2400g and 18.5.1 drivers now with ADDED CORRUPTION

Hi folks-  Thanks for the suggestions.  I have the system set for UEFI, no compatability mode (in BIOS).  Power settings have been "performance" in various iterations; I have also set this in today's install.

I tried the earlier 17.10.x drivers (from microsoft update catalogue, having files dated 5/10/18) with no improvement.

But I have made some progress it seems- I managed to enable safe boot w/ the shift key and blocked driver updates by the reg hack ... 

Now when it dies I can boot into safe mode, nuke the offending driver w/ DDU, and reboot to Win10 (normal mode) without corrupting the boot drive. Yay!  I have done this exactly once.

And I can now connect to the internet without M$oft forcing the driver upon my machine.  Yay!  Done once, too.

Maybe I managed to corrupt the drive by booting/rebooting repeatedly at random times during the startup process.  Dunno.  But I was able yesterday to restore the corrupted system with the Win 7 backup/restore control panel, so that has worked... once.

feels like ~50% improved.  Still have no usable graphics drivers. So now I'm like everyone else

0 Likes
dcyd3
Journeyman III

Re: black screen w 2400g and 18.5.1 drivers now with ADDED CORRUPTION

hi everyone,

also some issues with this driver

18.2.1 working fine

in amd software ok update to 18.5.1

installing rebooting and HERE black screen (uhuh drivers not verified ? no control ? no UNDO function ? no menu standard mod for REVERSE ? an idea for future drivers ! YES --- oh we understand users ok all programmers make a undo fuinction with menu f8 yes community ask it YES they ask !!! in case of trouble they can go to the previously and we are SAFE ---- XXD)

so reboot pressing f8 caus win10

give me a MENU

go to left choice advanced.... not repare (trying = nothing)

here down i see an option where i canb load in secure mode with or not connection

i m trying that ok

i have my screen so i know it s a corruption of the driver

last test will be

disable my r9

trynig to load integrated r7 coming with a10

or changing display to previously driver (i think we can do that in previously driver !)

in case of trouble the other possibility is using windows standard driver

reboot and desinstalling 18.5.1 for re-installing 18.2.1

i think for that there is a program call i think "ddu" but not sure of this and caution using at your own risk

i try that

if can help anybody be cool

(sorry if poor english french by default)

0 Likes
norman_
Adept I

Re: black screen w 2400g and 18.5.1 drivers now with ADDED CORRUPTION

I found the solution to my issue -  it was not my idea - but I don't remember who posted it as their own resolution to this precise problem.  Thanks, whoever!!

My gratitude eventually reminded me I should post the fix for my issue- I was not the only one with such problems

It seems the HDMI output of the 2400G is... um, particularly demanding. My original cable was, and remains, perfectly useful for other connections- DVD to TV, things in and out of my AV receiver.  So I ASSUMED it was good enough for this APU.  Nope!  It appears the GPU, with the updated driver, needs more bandwidth than out-of-the-box.    Because my HDMI cable works just fine - until the new drivers installed.

Full graphics output was achieved with a higher-quality (monoprice "premium") cable.

I would like to give credit to who/wherever mentioned this as a possible remedy.